summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Renié2017-01-23 14:54:57 +0100
committerBruno Renié2017-01-23 14:54:57 +0100
commit8bafce901c013b148e7bdfdaeef127e976f61d9f (patch)
tree8d7b16084cf878d887710779df8e02b93b51eaf2
downloadaur-8bafce901c013b148e7bdfdaeef127e976f61d9f.tar.gz
VaudTax 2016
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
-rw-r--r--execute_from_usr_share.patch15
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..58e9a63f4fef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vaudtax
+ pkgdesc = VaudTax
+ pkgver = 2016
+ pkgrel = 1
+ url = http://www.vd.ch/themes/etat-droit-finances/impots/vaudtax/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = webkitgtk2
+ depends = jre8-openjdk
+ depends = gnome-vfs
+ source = https://vaudtax-dl.vd.ch/vaudtax2016/telechargement/linux/VaudTax_2016.tar.gz
+ source = execute_from_usr_share.patch
+ md5sums = caa0e1a0e46823fc83de03e38ed23aef
+ md5sums = 50de86f022910871d336571832e5f810
+
+pkgname = vaudtax
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..163c828903e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Bruno Renié <brutasse@gmail.com>
+pkgname=vaudtax
+pkgver=2016
+_pkgver=1.0.1-production
+pkgrel=1
+pkgdesc="VaudTax"
+url="http://www.vd.ch/themes/etat-droit-finances/impots/vaudtax/"
+depends=('webkitgtk2' 'jre8-openjdk' 'gnome-vfs')
+arch=(i686 x86_64)
+license=('custom')
+source=('https://vaudtax-dl.vd.ch/vaudtax2016/telechargement/linux/VaudTax_2016.tar.gz'
+'execute_from_usr_share.patch')
+_dirname="VaudTax_$pkgver-$_pkgver"
+
+prepare() {
+ cd "$_dirname"
+}
+build() {
+ cd "$_dirname"
+}
+package() {
+ cd "$_dirname"
+ patch -p1 < ../execute_from_usr_share.patch
+
+ _app_home=/usr/share/${pkgname}
+
+ install -d "${pkgdir}"{${_app_home}/bin,/usr/bin}
+
+ cp -r lib "${pkgdir}${_app_home}"
+ cp -r config "${pkgdir}${_app_home}"
+ install -D -m644 version.xml "${pkgdir}${_app_home}/version.xml"
+
+ cp ${pkgname}-${pkgver} "${pkgdir}"${_app_home}/bin/${pkgname}
+ ln -s "${pkgdir}"${_app_home}/bin/${pkgname} "${pkgdir}"/usr/bin/${pkgname}
+}
+md5sums=('caa0e1a0e46823fc83de03e38ed23aef'
+ '50de86f022910871d336571832e5f810')
diff --git a/execute_from_usr_share.patch b/execute_from_usr_share.patch
new file mode 100644
index 000000000000..ce352957ac92
--- /dev/null
+++ b/execute_from_usr_share.patch
@@ -0,0 +1,15 @@
+--- a/vaudtax-2016
++++ b/vaudtax-2016
+@@ -5,11 +5,7 @@
+
+ classpath='lib/dvbern-lib-update.jar'
+
+-if [ ! -f ///$classpath ] ; then
+- cd `dirname $0`
+-else
+- cd //
+-fi
++cd /usr/share/vaudtax/
+
+ type java &> /dev/null
+ if [ "$?" -ne "0" ] ; then