summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2018-01-16 13:21:01 +0330
committerMohammadreza Abdollahzadeh2018-01-16 13:21:01 +0330
commit72facacc1fc5342bf6963846049c25416795262d (patch)
tree8bd374fb903d35a544a049456685d34fd612ea12
parentdccf4617f2a27f5497b3d7a7e236d099d8b7aa1c (diff)
downloadaur-72facacc1fc5342bf6963846049c25416795262d.tar.gz
fix PKGBUILD
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
2 files changed, 10 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8932bdca627..c7610b49946c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,13 @@
-# Generated by mksrcinfo v8
-# Sat Jan 21 19:16:32 UTC 2017
pkgbase = vazir-code-fonts
pkgdesc = A beautiful monospace Persian font based on Vazir and Inconsolata fonts.
pkgver = 1.0.3
- pkgrel = 1
- url = https://rastikerdar.github.io/vazir-code-font/
+ pkgrel = 2
+ url = https://github.com/rastikerdar/vazir-code-font
arch = any
license = OFL
depends = fontconfig
provides = ttf-vazir-code
- provides = vazir-code-fonts
conflicts = ttf-vazir-code
- conflicts = vazir-code-fonts
- replaces = ttf-vazir-code
source = vazir-code-fonts-1.0.3.zip::https://github.com/rastikerdar/vazir-code-font/releases/download/v1.0.3/vazir-code-font-v1.0.3.zip
sha256sums = 8a0bcc3e0ab9f086aeb3d8d2827825dc5b582f34562ad4c0b6f79242a692249a
diff --git a/PKGBUILD b/PKGBUILD
index 2a239e84ec89..febff4818a04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,20 @@
pkgname=vazir-code-fonts
pkgver=1.0.3
-pkgrel=1
+pkgrel=2
pkgdesc="A beautiful monospace Persian font based on Vazir and Inconsolata fonts."
-url="https://rastikerdar.github.io/vazir-code-font/"
+url="https://github.com/rastikerdar/vazir-code-font"
arch=(any)
license=('OFL')
depends=('fontconfig')
-provides=('ttf-vazir-code' "$pkgname")
-conflicts=('ttf-vazir-code' "$pkgname")
-replaces=('ttf-vazir-code')
-source=("$pkgname-$pkgver.zip::https://github.com/rastikerdar/vazir-code-font/releases/download/v$pkgver/vazir-code-font-v$pkgver.zip")
+provides=('ttf-vazir-code')
+conflicts=('ttf-vazir-code')
+source=("${pkgname}-${pkgver}.zip::${url}/releases/download/v${pkgver}/vazir-code-font-v${pkgver}.zip")
sha256sums=('8a0bcc3e0ab9f086aeb3d8d2827825dc5b582f34562ad4c0b6f79242a692249a')
package() {
- install -d "$pkgdir/usr/share/fonts/${pkgname%-fonts}"
- install -t "$pkgdir/usr/share/fonts/${pkgname%-fonts}" -m644 ./Vazir-Code*.{eot,ttf,woff}
- install -Dm644 ./LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -d "${pkgdir}/usr/share/fonts/${pkgname%-fonts}"
+ install -t "${pkgdir}/usr/share/fonts/${pkgname%-fonts}" -m644 ./Vazir-Code*.ttf
+ install -Dm644 ./LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-
# vim:set ts=2 sw=2 et: