summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2017-01-21 22:46:56 +0330
committerMohammadreza Abdollahzadeh2017-01-21 22:46:56 +0330
commitdccf4617f2a27f5497b3d7a7e236d099d8b7aa1c (patch)
tree2534c6f1ea0171594cf65cd8434ad8e17ad824c4
downloadaur-dccf4617f2a27f5497b3d7a7e236d099d8b7aa1c.tar.gz
Initial Import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD24
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d8932bdca627
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sat Jan 21 19:16:32 UTC 2017
+pkgbase = vazir-code-fonts
+ pkgdesc = A beautiful monospace Persian font based on Vazir and Inconsolata fonts.
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://rastikerdar.github.io/vazir-code-font/
+ arch = any
+ license = OFL
+ depends = fontconfig
+ provides = ttf-vazir-code
+ provides = vazir-code-fonts
+ conflicts = ttf-vazir-code
+ conflicts = vazir-code-fonts
+ replaces = ttf-vazir-code
+ source = vazir-code-fonts-1.0.3.zip::https://github.com/rastikerdar/vazir-code-font/releases/download/v1.0.3/vazir-code-font-v1.0.3.zip
+ sha256sums = 8a0bcc3e0ab9f086aeb3d8d2827825dc5b582f34562ad4c0b6f79242a692249a
+
+pkgname = vazir-code-fonts
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a239e84ec89
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# $Id$
+# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+
+pkgname=vazir-code-fonts
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="A beautiful monospace Persian font based on Vazir and Inconsolata fonts."
+url="https://rastikerdar.github.io/vazir-code-font/"
+arch=(any)
+license=('OFL')
+depends=('fontconfig')
+provides=('ttf-vazir-code' "$pkgname")
+conflicts=('ttf-vazir-code' "$pkgname")
+replaces=('ttf-vazir-code')
+source=("$pkgname-$pkgver.zip::https://github.com/rastikerdar/vazir-code-font/releases/download/v$pkgver/vazir-code-font-v$pkgver.zip")
+sha256sums=('8a0bcc3e0ab9f086aeb3d8d2827825dc5b582f34562ad4c0b6f79242a692249a')
+
+package() {
+ install -d "$pkgdir/usr/share/fonts/${pkgname%-fonts}"
+ install -t "$pkgdir/usr/share/fonts/${pkgname%-fonts}" -m644 ./Vazir-Code*.{eot,ttf,woff}
+ install -Dm644 ./LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: