summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2017-01-21 22:41:29 +0330
committerMohammadreza Abdollahzadeh2017-01-21 22:41:29 +0330
commit55be76c491345a6096c22c7c04c4cd62c8f7873b (patch)
treeb8ebac2f09a8054cd1c513293f876dce4ec714a0
downloadaur-55be76c491345a6096c22c7c04c4cd62c8f7873b.tar.gz
Initial Import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD25
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c4ffee83c65c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sat Jan 21 19:11:22 UTC 2017
+pkgbase = vazir-fonts
+ pkgdesc = A beautiful Persian font based on DejaVu font.
+ pkgver = 6.3.4
+ pkgrel = 1
+ url = https://rastikerdar.github.io/vazir-font/
+ arch = any
+ license = OFL
+ depends = fontconfig
+ provides = ttf-vazir
+ provides = vazir-fonts
+ conflicts = ttf-vazir
+ conflicts = vazir-fonts
+ replaces = ttf-vazir
+ source = vazir-fonts-6.3.4.zip::https://github.com/rastikerdar/vazir-font/releases/download/v6.3.4/vazir-font-v6.3.4.zip
+ sha256sums = 5bb038c1e9e1dcbd4e0801bf259476e610007b974e708f3730c421af779e1388
+
+pkgname = vazir-fonts
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..670a1e0588d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id$
+# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+
+pkgname=vazir-fonts
+pkgver=6.3.4
+pkgrel=1
+pkgdesc="A beautiful Persian font based on DejaVu font."
+url="https://rastikerdar.github.io/vazir-font/"
+arch=(any)
+license=('OFL')
+depends=('fontconfig')
+provides=('ttf-vazir' "$pkgname")
+conflicts=('ttf-vazir' "$pkgname")
+replaces=('ttf-vazir')
+source=("$pkgname-$pkgver.zip::https://github.com/rastikerdar/vazir-font/releases/download/v$pkgver/vazir-font-v$pkgver.zip")
+sha256sums=('5bb038c1e9e1dcbd4e0801bf259476e610007b974e708f3730c421af779e1388')
+
+package() {
+ install -d "$pkgdir/usr/share/fonts/${pkgname%-fonts}"
+ install -t "$pkgdir/usr/share/fonts/${pkgname%-fonts}" -m644 ./Vazir*.{eot,ttf,woff}
+ install -t "$pkgdir/usr/share/fonts/${pkgname%-fonts}" -m644 ./{Farsi*,Without-Latin}/Vazir*.{eot,ttf,woff}
+ install -Dm644 ./LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: