summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnatol Pomozov2023-03-09 18:02:29 -0800
committerAnatol Pomozov2023-03-09 18:02:29 -0800
commit50840dd134ed9c0834b527d5d76ad003ddd45f12 (patch)
tree636a53c4d03cba929a89d75c8c8b018ee087693b
parentdcb7ba1ab1137cbb05a829ba563c46159c3e0808 (diff)
downloadaur-vboot-utils.tar.gz
updpkg
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
-rw-r--r--disable-errors.patch13
-rw-r--r--fix.patch43
-rw-r--r--makefile.patch12
5 files changed, 29 insertions, 62 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 076bc1dfdf65..0e691edbc3a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vboot-utils
pkgdesc = Chromium OS verified boot utilities
- pkgver = 100.14526
+ pkgver = 112.15359
pkgrel = 1
url = https://chromium.googlesource.com/chromiumos/platform/vboot_reference
arch = i686
@@ -12,8 +12,10 @@ pkgbase = vboot-utils
depends = libutil-linux
depends = openssl
depends = libzip
- depends = flashrom
- source = git+https://chromium.googlesource.com/chromiumos/platform/vboot_reference#branch=release-R100-14526.B
+ depends = flashrom-git
+ source = git+https://chromium.googlesource.com/chromiumos/platform/vboot_reference#branch=release-R112-15359.B
+ source = disable-errors.patch
sha256sums = SKIP
+ sha256sums = b70df18064195e2fb9b2d5335ce788d2d1db49ab9981c63367089587c6d697ce
pkgname = vboot-utils
diff --git a/PKGBUILD b/PKGBUILD
index 877df7bde22e..463af2e124ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,23 @@
pkgname=vboot-utils
pkgdesc='Chromium OS verified boot utilities'
-pkgver=100.14526
+pkgver=112.15359
_tag=release-R${pkgver/\./-}.B
pkgrel=1
arch=(i686 x86_64)
url='https://chromium.googlesource.com/chromiumos/platform/vboot_reference'
license=('custom:chromiumos')
-depends=(libutil-linux openssl libzip flashrom)
+depends=(libutil-linux openssl libzip flashrom-git)
makedepends=(git libyaml trousers)
-source=(git+https://chromium.googlesource.com/chromiumos/platform/vboot_reference#branch=$_tag)
-sha256sums=('SKIP')
+source=(git+https://chromium.googlesource.com/chromiumos/platform/vboot_reference#branch=$_tag
+ disable-errors.patch)
+sha256sums=('SKIP'
+ 'b70df18064195e2fb9b2d5335ce788d2d1db49ab9981c63367089587c6d697ce')
+
+prepare() {
+ cd vboot_reference
+ patch -p1 < ../disable-errors.patch
+}
build() {
cd vboot_reference
diff --git a/disable-errors.patch b/disable-errors.patch
new file mode 100644
index 000000000000..34d497dd56ba
--- /dev/null
+++ b/disable-errors.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 9cfe65be..3bb64f98 100644
+--- a/Makefile
++++ b/Makefile
+@@ -125,7 +125,7 @@ endif
+ # Provide default CC and CFLAGS for firmware builds; if you have any -D flags,
+ # please add them after this point (e.g., -DVBOOT_DEBUG).
+ DEBUG_FLAGS := $(if $(filter-out 0,${DEBUG}),-g -Og,-g -Os)
+-WERROR := -Werror
++WERROR :=
+ FIRMWARE_FLAGS := -nostdinc -ffreestanding -fno-builtin -fno-stack-protector
+ COMMON_FLAGS := -pipe ${WERROR} -Wall -Wstrict-prototypes -Wtype-limits \
+ -Wundef -Wmissing-prototypes -Wno-trigraphs -Wredundant-decls -Wshadow \
diff --git a/fix.patch b/fix.patch
deleted file mode 100644
index ae67fde8f4a4..000000000000
--- a/fix.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-commit ca26590ccc73a0c9ca625acab5f2acaa08408d7d
-Author: Anatol Pomozov <anatol.pomozov@gmail.com>
-Date: Wed May 27 19:17:03 2020 -0700
-
- Fix linking issue
-
- /usr/bin/ld: /mnt/cold/sources/vboot_reference/build/libvboot_util.a(subprocess.o):/home/anatol/sources/vboot_reference/host/lib/include/subprocess.h:93: multiple definition of `subprocess_stdin'; /mnt/cold/sources/vboot_reference/build/libvboot_util.a(crossystem.o):/home/anatol/sources/vboot_reference/host/lib/include/subprocess.h:93: first defined here
- /usr/bin/ld: /mnt/cold/sources/vboot_reference/build/libvboot_util.a(subprocess.o):/home/anatol/sources/vboot_reference/host/lib/include/subprocess.h:103: multiple definition of `subprocess_stderr'; /mnt/cold/sources/vboot_reference/build/libvboot_util.a(crossystem.o):/home/anatol/sources/vboot_reference/host/lib/include/subprocess.h:103: first defined here
- /usr/bin/ld: /mnt/cold/sources/vboot_reference/build/libvboot_util.a(subprocess.o):/home/anatol/sources/vboot_reference/host/lib/include/subprocess.h:88: multiple definition of `subprocess_null'; /mnt/cold/sources/vboot_reference/build/libvboot_util.a(crossystem.o):/home/anatol/sources/vboot_reference/host/lib/include/subprocess.h:88: first defined here
-
- Signed-off-by: Anatol Pomozov <anatol.pomozov@gmail.com>
-
-diff --git a/host/lib/include/subprocess.h b/host/lib/include/subprocess.h
-index eaf75502..b24b987f 100644
---- a/host/lib/include/subprocess.h
-+++ b/host/lib/include/subprocess.h
-@@ -85,22 +85,22 @@ struct subprocess_target {
- /**
- * A convenience subprocess target which uses TARGET_NULL.
- */
--struct subprocess_target subprocess_null;
-+extern struct subprocess_target subprocess_null;
-
- /**
- * A convenience subprocess target which uses TARGET_FD to STDIN_FILENO.
- */
--struct subprocess_target subprocess_stdin;
-+extern struct subprocess_target subprocess_stdin;
-
- /**
- * A convenience subprocess target which uses TARGET_FD to STDOUT_FILENO.
- */
--struct subprocess_target subprocess_stdout;
-+extern struct subprocess_target subprocess_stdout;
-
- /**
- * A convenience subprocess target which uses TARGET_FD to STDERR_FILENO.
- */
--struct subprocess_target subprocess_stderr;
-+extern struct subprocess_target subprocess_stderr;
-
- /**
- * Call a process and run until completion.
diff --git a/makefile.patch b/makefile.patch
deleted file mode 100644
index ec56c08f7fcf..000000000000
--- a/makefile.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/Makefile b/Makefile
-index b35dc913..3e8c2b45 100644
---- a/Makefile
-+++ b/Makefile
-@@ -324,7 +324,6 @@ export BUILD_RUN
- .PHONY: all
- all: fwlib futil utillib hostlib cgpt tlcl \
- $(if ${SDK_BUILD},utils_sdk,utils_board) \
-- $(if $(filter x86_64,${ARCH}),fuzzers) \
- $(if ${COV},coverage)
-
- ##############################################################################