summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnatol Pomozov2020-03-09 10:48:44 -0700
committerAnatol Pomozov2020-03-09 10:48:44 -0700
commit8bc48a5962966f69757a9ef676b976ed16e6a6d1 (patch)
tree0ddbec13bcc6a8a691bbe36479b41eece69abfcf
parentad8def9e0df3a448db49ce218689008555be594d (diff)
downloadaur-8bc48a5962966f69757a9ef676b976ed16e6a6d1.tar.gz
updpkg
Upstream removed static binaries thus a large chunk of our old patch gone The project dos not build with gcc as gcc does not support -fsanitizer=fuzeer. Disable fuzzer tools for now.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
-rw-r--r--makefile.patch12
-rw-r--r--no_static.patch40
4 files changed, 24 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28b184930b28..17877f5086d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sun May 6 15:35:23 UTC 2018
pkgbase = vboot-utils
pkgdesc = Chromium OS verified boot utilities
- pkgver = 67.10575
+ pkgver = 81.12871
pkgrel = 1
url = https://chromium.googlesource.com/chromiumos/platform/vboot_reference
arch = i686
@@ -12,10 +10,10 @@ pkgbase = vboot-utils
makedepends = trousers
depends = libutil-linux
depends = openssl
- source = https://chromium.googlesource.com/chromiumos/platform/vboot_reference/+archive/release-R67-10575.B.tar.gz
- source = no_static.patch
- sha1sums = SKIP
- sha1sums = b45016e2f1a9833d24d68a3d35a043258cab9405
+ source = https://chromium.googlesource.com/chromiumos/platform/vboot_reference/+archive/release-R81-12871.B.tar.gz
+ source = makefile.patch
+ sha256sums = 88ff2e28bf0af3d1e5d5fb9fab2ed8f67644d4ffff6ffe4be07407141a1b8727
+ sha256sums = 7804878ce24b2ca9bd8858bfffcf97b12627b2c7524879240a958cec244afdcb
pkgname = vboot-utils
diff --git a/PKGBUILD b/PKGBUILD
index 6376bdc08fbc..f978d0c9cc2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=vboot-utils
pkgdesc='Chromium OS verified boot utilities'
-pkgver=67.10575
+pkgver=81.12871
_tag=release-R${pkgver/\./-}.B
pkgrel=1
arch=(i686 x86_64)
@@ -12,12 +12,12 @@ license=('custom:chromiumos')
depends=(libutil-linux openssl)
makedepends=(libyaml trousers)
source=(https://chromium.googlesource.com/chromiumos/platform/vboot_reference/+archive/$_tag.tar.gz
- no_static.patch)
-sha1sums=('SKIP'
- 'b45016e2f1a9833d24d68a3d35a043258cab9405')
+ makefile.patch)
+sha256sums=('88ff2e28bf0af3d1e5d5fb9fab2ed8f67644d4ffff6ffe4be07407141a1b8727'
+ '7804878ce24b2ca9bd8858bfffcf97b12627b2c7524879240a958cec244afdcb')
prepare() {
- patch -p1 < ./no_static.patch
+ patch -p1 < makefile.patch
}
build() {
@@ -25,13 +25,11 @@ build() {
}
check() {
- #fails because https://chromium-review.googlesource.com/c/chromiumos/platform/vboot_reference/+/349670/3/tests/futility/expect_output/show.tests_devkeys_root_key.vbpubk#1
- #make runtests
- true
+ make runtests
}
package() {
- make DESTDIR="$pkgdir" MINIMAL=1 install
+ make install DESTDIR="$pkgdir" MINIMAL=1
install -d "$pkgdir"/usr/share/vboot/
cp -r tests/devkeys "$pkgdir"/usr/share/vboot/devkeys
install -m 644 -D LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
diff --git a/makefile.patch b/makefile.patch
new file mode 100644
index 000000000000..fcb4251cd9d8
--- /dev/null
+++ b/makefile.patch
@@ -0,0 +1,12 @@
+diff --git a/Makefile b/Makefile
+index 0c075e06..2c3e5e9e 100644
+--- a/Makefile
++++ b/Makefile
+@@ -834,7 +834,6 @@ host_tools: utils futil tests
+
+ .PHONY: host_stuff
+ host_stuff: utillib hostlib \
+- $(if $(filter x86_64,${ARCH}),fuzzers) \
+ $(if ${NO_BUILD_TOOLS},,cgpt host_tools)
+
+ .PHONY: clean
diff --git a/no_static.patch b/no_static.patch
deleted file mode 100644
index 5bac160d1f68..000000000000
--- a/no_static.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 1f3e7f66..2103127f 100644
---- a/Makefile
-+++ b/Makefile
-@@ -643,8 +643,6 @@ SIGNING_COMMON = scripts/image_signing/common_minimal.sh
-
- # The unified firmware utility will eventually replace all the others
- FUTIL_BIN = ${BUILD}/futility/futility
--# But we still need both static (tiny) and dynamic (with openssl) versions.
--FUTIL_STATIC_BIN = ${FUTIL_BIN}_s
-
- # These are the executables that are now built in to futility. We'll create
- # symlinks for these so the old names will still work.
-@@ -1112,12 +1110,7 @@ signing_install: ${SIGNING_SCRIPTS} ${SIGNING_SCRIPTS_DEV} ${SIGNING_COMMON}
- # new Firmware Utility
-
- .PHONY: futil
--futil: ${FUTIL_STATIC_BIN} ${FUTIL_BIN}
--
--${FUTIL_STATIC_BIN}: LDLIBS += ${CRYPTO_STATIC_LIBS} -lpthread
--${FUTIL_STATIC_BIN}: ${FUTIL_STATIC_OBJS} ${UTILLIB}
-- @${PRINTF} " LD $(subst ${BUILD}/,,$@)\n"
-- ${Q}${LD} -o $@ ${CFLAGS} ${LDFLAGS} -static $^ ${LDLIBS}
-+futil: ${FUTIL_BIN}
-
- ${FUTIL_BIN}: LDLIBS += ${CRYPTO_LIBS}
- ${FUTIL_BIN}: ${FUTIL_OBJS} ${UTILLIB} ${FWLIB20} ${UTILBDB}
-@@ -1125,10 +1118,10 @@ ${FUTIL_BIN}: ${FUTIL_OBJS} ${UTILLIB} ${FWLIB20} ${UTILBDB}
- ${Q}${LD} -o $@ ${CFLAGS} ${LDFLAGS} $^ ${LDLIBS}
-
- .PHONY: futil_install
--futil_install: ${FUTIL_BIN} ${FUTIL_STATIC_BIN}
-+futil_install: ${FUTIL_BIN}
- @${PRINTF} " INSTALL futility\n"
- ${Q}mkdir -p ${UB_DIR}
-- ${Q}${INSTALL} -t ${UB_DIR} ${FUTIL_BIN} ${FUTIL_STATIC_BIN}
-+ ${Q}${INSTALL} -t ${UB_DIR} ${FUTIL_BIN}
- ${Q}for prog in ${FUTIL_SYMLINKS}; do \
- ln -sf futility "${UB_DIR}/$$prog"; done
-