summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2015-06-08 11:11:42 +0200
committerMaxime Gauduin2015-06-08 11:11:42 +0200
commit5c0169eadbc9ddb5b2f417502b7ce4c364681767 (patch)
tree8b85fc640784266ffe28d4888ec5a058b9bb4319
downloadaur-5c0169eadbc9ddb5b2f417502b7ce4c364681767.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--MKPKG4
-rw-r--r--PKGBUILD21
-rw-r--r--vboxhost-hook.install5
4 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..442c693aa071
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = vboxhost-hook
+ pkgdesc = mkinitcpio hook to compile the virtualbox host modules
+ pkgver = 1.0
+ pkgrel = 3
+ url = https://github.com/alucryd/mkinitcpio-hooks
+ install = vboxhost-hook.install
+ arch = any
+ license = GPL3
+ depends = virtualbox-host-dkms
+ source = https://raw.github.com/alucryd/mkinitcpio-hooks/master/vboxhost
+ sha256sums = 6c5e321b6dac90ca6b7c7e45c842081762d140679bf186dcb948d65eb702bd15
+
+pkgname = vboxhost-hook
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..c0a167d22f7b
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,4 @@
+arch=('any')
+pkgname=('vboxhost-hook')
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d401f6ed96a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=vboxhost-hook
+pkgver=1.0
+pkgrel=3
+pkgdesc='mkinitcpio hook to compile the virtualbox host modules'
+url='https://github.com/alucryd/mkinitcpio-hooks'
+arch=('any')
+license=('GPL3')
+depends=('virtualbox-host-dkms')
+install="${pkgname}.install"
+source=('https://raw.github.com/alucryd/mkinitcpio-hooks/master/vboxhost')
+sha256sums=('6c5e321b6dac90ca6b7c7e45c842081762d140679bf186dcb948d65eb702bd15')
+
+package() {
+ sed "s|_arch|$CARCH|" -i vboxhost
+ install -dm 755 "${pkgdir}"/usr/lib/initcpio/install
+ install -m 644 vboxhost "${pkgdir}"/usr/lib/initcpio/install/
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/vboxhost-hook.install b/vboxhost-hook.install
new file mode 100644
index 000000000000..cc9944f6c567
--- /dev/null
+++ b/vboxhost-hook.install
@@ -0,0 +1,5 @@
+post_install() {
+ echo "Please add 'vboxhost' to the HOOKs array in /etc/mkinitcpio.conf and make sure you have installed the header files for your kernel to enable the automatic modules compilation."
+}
+
+# vim: ts=2 sw=2 et: