summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBernardo Meurer2018-09-24 20:49:27 -0700
committerBernardo Meurer2018-09-24 20:52:28 -0700
commiteae0eb5ba87c7e5374e9e890d2c6d5eb9e3ded44 (patch)
tree53c73ca820d6d7f185f4303a0f78dbeaf8a6ee43
downloadaur-eae0eb5ba87c7e5374e9e890d2c6d5eb9e3ded44.tar.gz
Added source files and patch
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
-rw-r--r--cstring.patch11
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b18852257fc1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vbrfix
+ pkgdesc = A CLI useful for fixing corrupt mp3 files
+ pkgver = 0.24
+ pkgrel = 1
+ url = https://packages.ubuntu.com/cosmic/vbrfix
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = make
+ source = http://archive.ubuntu.com/ubuntu/pool/universe/v/vbrfix/vbrfix_0.24+dfsg.orig.tar.xz
+ source = cstring.patch
+ md5sums = 27ee9a38a5dac9344b9256bf6d06ab4e
+ md5sums = 11808e35dd062464d7d7a044c43cba09
+ sha256sums = 11c24c246da232a5ad73c37fcfab89dedb820ddc76167395411df4a836ce3a29
+ sha256sums = 81057c6da66649a441b544c75eaf9b8005561a3c3437aebf8bdb2855edc0a7ce
+
+pkgname = vbrfix
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e09417e972b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+pkgname=vbrfix
+pkgver=0.24
+pkgrel=1
+pkgdesc="A CLI useful for fixing corrupt mp3 files"
+arch=('i686' 'x86_64')
+url="https://packages.ubuntu.com/cosmic/vbrfix"
+license=('GPL2')
+makedepends=('make')
+source=("http://archive.ubuntu.com/ubuntu/pool/universe/v/vbrfix/vbrfix_$pkgver+dfsg.orig.tar.xz" "cstring.patch")
+md5sums=('27ee9a38a5dac9344b9256bf6d06ab4e'
+ '11808e35dd062464d7d7a044c43cba09')
+sha256sums=('11c24c246da232a5ad73c37fcfab89dedb820ddc76167395411df4a836ce3a29'
+ '81057c6da66649a441b544c75eaf9b8005561a3c3437aebf8bdb2855edc0a7ce')
+
+prepare() {
+ cd "vbrfixc-$pkgver" || exit 1
+ patch -Np1 -i "${srcdir}/cstring.patch"
+}
+
+build() {
+ cd "vbrfixc-$pkgver" || exit 1
+ ls
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "vbrfixc-$pkgver" || exit 1
+ make prefix="$pkgdir/usr/" install
+}
+
diff --git a/cstring.patch b/cstring.patch
new file mode 100644
index 000000000000..3bdf21fd76f9
--- /dev/null
+++ b/cstring.patch
@@ -0,0 +1,11 @@
+diff -ura vbrfix.orig/vbrfixc/vbrfix.h vbrfix.new/vbrfixc/vbrfix.h
+--- vbrfix.orig/vbrfixc/vbrfix.h 2018-09-24 20:00:36.527976709 -0700
++++ vbrfix.new/vbrfixc/vbrfix.h 2018-09-24 20:01:07.687976257 -0700
+@@ -18,6 +18,7 @@
+ #define VBRFIX_H
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <cstring>
+ #include <fstream>
+ #include "wputil.h"
+ struct Frame{