summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpatrick brisbin2021-06-22 13:43:48 -0400
committerpatrick brisbin2021-06-22 13:43:48 -0400
commit61608a16b2f1da352aa28cd7c5616f726c72464f (patch)
tree4731f1127b512606035871f43074a96dee91fa8b
parent28efae0ec4b92ded73e7ebda16fc4b176d655724 (diff)
downloadaur-61608a16b2f1da352aa28cd7c5616f726c72464f.tar.gz
Update PKGBUILD
-rw-r--r--PKGBUILD36
1 files changed, 11 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 236ffd5ec437..805c31a0eb73 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,25 @@
# Maintainer: Pat Brisbin <pbrisbin@gmail.com>
-_gitname=vbump
-_gitroot='https://github.com/pbrisbin/vbump'
+_gitname=vbump
pkgname="$_gitname-git"
-pkgver=0.0.0
+pkgver=r10.8dc72bc
pkgrel=1
pkgdesc='Automatically bump package versions'
arch=('any')
-url=$_gitroot
+url=https://github.com/pbrisbin/vbump
license=('MIT')
+depends=('sh')
makedepends=('git')
-source=("git://github.com/pbrisbin/$_gitname")
+source=("git+https://github.com/pbrisbin/$_gitname")
md5sums=('SKIP')
-build() {
- cd "$srcdir"
- msg "Connecting to GIT server...."
-
- if [[ -d "$_gitname" ]]; then
- cd "$_gitname" && git pull origin
- msg "The local files are updated."
- else
- git clone "$_gitroot" "$_gitname"
- fi
-
- msg "GIT checkout done or server timeout"
- msg "Starting build..."
-
- rm -rf "$srcdir/$_gitname-build"
- git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
- cd "$srcdir/$_gitname-build"
+pkgver() {
+ cd "$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd "$srcdir/$_gitname-build"
- make DESTDIR="$pkgdir/" install
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_gitname/LICENSE"
+ cd "$_gitname"
+ make DESTDIR="$pkgdir" PREFIX="/usr" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}