summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsatcom8862020-07-16 22:04:30 +0200
committersatcom8862020-07-16 22:04:30 +0200
commitb3d71796c860bc59c570c8cdf37bc9e71f6f2717 (patch)
treeef63fb6ed4ec71ae61fa405db9e00b59e4259429
parentf5abbf94f087af4510136548f3e1b5ea3ed673ac (diff)
downloadaur-b3d71796c860bc59c570c8cdf37bc9e71f6f2717.tar.gz
Forgot to create the directory for the .icd file
-rw-r--r--.SRCINFO3
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD7
3 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c7df725627d..ef559969ec4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vc4cl-git
pkgdesc = VC4CL is an implementation of the OpenCL 1.2 standard for the VideoCore IV GPU.
pkgver = r170.eec7e57
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/doe300/VC4CL
arch = any
license = MIT
@@ -11,6 +11,7 @@ pkgbase = vc4cl-git
makedepends = cmake
makedepends = llvm
makedepends = opencl-headers
+ makedepends = pkg-config
depends = clang
depends = clinfo
depends = ocl-icd
diff --git a/.gitignore b/.gitignore
index 66d482008743..58fd4763f8e9 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,6 @@
pkg
-src \ No newline at end of file
+src
+
+*.pkg.*
+
+VC4CL \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 6c92a40c69fe..4580572219c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=vc4cl-git
pkgver=r170.eec7e57
-pkgrel=2
+pkgrel=3
pkgdesc="VC4CL is an implementation of the OpenCL 1.2 standard for the VideoCore IV GPU."
arch=('any')
url="https://github.com/doe300/VC4CL"
license=('MIT')
groups=()
depends=('clang' 'clinfo' 'ocl-icd' 'vc4c-git')
-makedepends=('make' 'git' 'gcc' 'cmake' 'llvm' 'opencl-headers')
+makedepends=('make' 'git' 'gcc' 'cmake' 'llvm' 'opencl-headers' 'pkg-config')
optdepends=()
provides=('opencl-pi' 'opencl-vc4' 'opencl-driver' 'vc4-opencl' 'vc4cl')
source=("VC4CL::git+https://github.com/doe300/VC4CL" "VC4CL.icd")
@@ -28,7 +28,8 @@ build() {
}
package() {
- install -m 644 "$srcdir/VC4CL.icd" $pkgdir/etc/OpenCL/vendors/
+ mkdir -m 755 "$pkgdir/etc/OpenCL/vendors/"
+ install -m 644 "$srcdir/VC4CL.icd" "$pkgdir/etc/OpenCL/vendors/"
cd $srcdir/VC4CL/build
make DESTDIR="$pkgdir"/ install
}