summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancisco Pina Martins2015-08-03 16:55:49 +0100
committerFrancisco Pina Martins2015-08-03 16:55:49 +0100
commit0227a74cdcd7c21b314eb67a398e2e4bcf436c19 (patch)
tree05c9bd5ce99a5564d928c5ddfb099ed7ac21e231
parentab0a64050d82889078cbdefbc0b65f57ffe13671 (diff)
downloadaur-0227a74cdcd7c21b314eb67a398e2e4bcf436c19.tar.gz
Updated to latest upstream and new hosting.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
2 files changed, 19 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dff0254165b0..27d7b938d2d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = vcftools
- pkgdesc = Easily accessible methods for working with complex genetic variation data in the form of VCF files.
- pkgver = 0.1.12b
+ pkgdesc = A set of tools written in Perl and C++ for working with VCF files
+ pkgver = 0.1.13
pkgrel = 1
- url = http://vcftools.sourceforge.net/
+ url = https://vcftools.github.io/
arch = x86_64
- license = GPL3
+ license = LGPL3
depends = perl
depends = zlib
- source = http://downloads.sourceforge.net/vcftools/vcftools_0.1.12b.tar.gz
- md5sums = 662758d1139c138cf5a0239ed99f12c2
+ source = https://github.com/vcftools/vcftools/archive/v0.1.13.tar.gz
+ md5sums = 45368c056b1c3a35c478e1300a5a7eca
pkgname = vcftools
diff --git a/PKGBUILD b/PKGBUILD
index a646d1f82d0d..c2f727784712 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,29 @@
# Contributor: Christian Krause ("wookietreiber") <kizkizzbangbang@googlemail.com>
pkgname=vcftools
-pkgver=0.1.12b
+pkgver=0.1.13
pkgrel=1
-pkgdesc="Easily accessible methods for working with complex genetic variation data in the form of VCF files."
+pkgdesc="A set of tools written in Perl and C++ for working with VCF files"
arch=('x86_64')
-url="http://vcftools.sourceforge.net/"
-license=('GPL3')
+url="https://vcftools.github.io/"
+license=('LGPL3')
depends=('perl' 'zlib')
-source=(http://downloads.sourceforge.net/${pkgname}/${pkgname}_${pkgver}.tar.gz)
-md5sums=('662758d1139c138cf5a0239ed99f12c2')
+source=(https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz)
+md5sums=('45368c056b1c3a35c478e1300a5a7eca')
build() {
- cd "${srcdir}/${pkgname}_${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
make
}
package() {
- cd "${srcdir}/${pkgname}_${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
- PREFIX="${pkgdir}/usr" make install
- rmdir "${pkgdir}/usr/bin/man1"
+ make \
+ PREFIX=${pkgdir}/usr \
+ MANDIR=${pkgdir}/usr/share/man/man1 \
+ MODDIR=${pkgdir}/usr/lib/perl15/vendor_perl \
+ install
install -D -m755 cpp/vcftools "${pkgdir}/usr/bin/vcftools"
- install -D -m644 cpp/vcftools.1 "${pkgdir}/usr/share/man/man1/vcftools.1"
}