summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancisco Pina Martins2015-06-09 14:11:33 +0100
committerFrancisco Pina Martins2015-06-09 14:11:33 +0100
commitab0a64050d82889078cbdefbc0b65f57ffe13671 (patch)
treedd30273fd44ee1f2d44b0ea465b7b56f9d500928
downloadaur-ab0a64050d82889078cbdefbc0b65f57ffe13671.tar.gz
Initial import.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dff0254165b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = vcftools
+ pkgdesc = Easily accessible methods for working with complex genetic variation data in the form of VCF files.
+ pkgver = 0.1.12b
+ pkgrel = 1
+ url = http://vcftools.sourceforge.net/
+ arch = x86_64
+ license = GPL3
+ depends = perl
+ depends = zlib
+ source = http://downloads.sourceforge.net/vcftools/vcftools_0.1.12b.tar.gz
+ md5sums = 662758d1139c138cf5a0239ed99f12c2
+
+pkgname = vcftools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a646d1f82d0d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Stunts <f.pinamartins@gmail.com>
+# Contributor: Christian Krause ("wookietreiber") <kizkizzbangbang@googlemail.com>
+
+pkgname=vcftools
+pkgver=0.1.12b
+pkgrel=1
+pkgdesc="Easily accessible methods for working with complex genetic variation data in the form of VCF files."
+arch=('x86_64')
+url="http://vcftools.sourceforge.net/"
+license=('GPL3')
+depends=('perl' 'zlib')
+source=(http://downloads.sourceforge.net/${pkgname}/${pkgname}_${pkgver}.tar.gz)
+md5sums=('662758d1139c138cf5a0239ed99f12c2')
+
+build() {
+ cd "${srcdir}/${pkgname}_${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}_${pkgver}"
+
+ PREFIX="${pkgdir}/usr" make install
+ rmdir "${pkgdir}/usr/bin/man1"
+
+ install -D -m755 cpp/vcftools "${pkgdir}/usr/bin/vcftools"
+ install -D -m644 cpp/vcftools.1 "${pkgdir}/usr/share/man/man1/vcftools.1"
+}