summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYishen Miao2023-05-29 07:45:56 +0000
committerYishen Miao2023-05-29 07:48:24 +0000
commit591711310cf26559bcc41f38af729b79c2c70edf (patch)
treea7d89a256cad26799bbd1e21ca06a068331a16a7
parentde93ad69be6c2a3f1402ddba76b83c1c0466a0d3 (diff)
downloadaur-591711310cf26559bcc41f38af729b79c2c70edf.tar.gz
Adapting to vcio
Adapts package to vcio.
-rw-r--r--.SRCINFO24
-rw-r--r--Makefile2
-rw-r--r--PKGBUILD37
-rw-r--r--dkms.conf2
4 files changed, 27 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1f924f99fbd..ae60be7a68d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
-pkgbase = rpi-poe-fan-dkms-git
- pkgdesc = Hwmon driver for Raspberry Pi PoE(+)HAT fan
- pkgver = 3.b422a76
+pkgbase = vcio-dkms-git
+ pkgdesc = Character device driver for VC4 mailbox
+ pkgver = 6.324f7e52
pkgrel = 1
- url = https://github.com/raspberrypi/linux/blob/b422a76/drivers/hwmon/rpi-poe-fan.c
+ url = https://github.com/raspberrypi/linux/blob/324f7e52/drivers/char/broadcom/vcio.c
arch = any
license = GPL
depends = dkms
- provides = rpi-poe-fan=3.b422a76-1
- conflicts = rpi-poe-fan
- source = https://raw.githubusercontent.com/raspberrypi/linux/b422a76/drivers/hwmon/rpi-poe-fan.c
- source = https://raw.githubusercontent.com/raspberrypi/linux/b422a76/include/soc/bcm2835/raspberrypi-firmware.h
+ provides = vcio=6.324f7e52-1
+ conflicts = vcio
+ source = https://github.com/raspberrypi/linux/blob/324f7e52/drivers/char/broadcom/vcio.c
source = dkms.conf
source = Makefile
- b2sums = 92a4e558f527f155deb17af88ea3cfd03aad8dcac9f6ca7100d49d39627c98f9aeefef721583768719b00a130dc11c2494d6d2453bea419582bb3c7ebe3f0b1d
- b2sums = 5d4034b09087ee9f0d9e8408a08b0df9b63524a2cd32710f1ded05bbfbfcc5c7aede0eb11847c041811384d74c338a86b907b8965284f094593d6e42369120f5
- b2sums = a70240cc2424ecade86a37acc57f2d7b55a9cf6fbf65fb1f0033e297bb4c5ebb9fc87da0b65b982f518f5a7437dd3717ca9c9a9d584144c14ca3063e068fd4de
- b2sums = cb19c21e9bbb2995198c54d3478a09cfc1893daa6a33404611664979b0bd09729a3576542f693cb71dad005363fa330cb8d5e91c6b81292c4598aee54ae49b34
+ sha256sums = 06c58eb27872de4ff581cc77dec34b307d5de098fa81e0237e6309062ec46aea
+ sha256sums = d0d0fde95be8b1e9ad37de3a6a08e048729f5503545140357f31d3c3289613ac
+ sha256sums = f0ecf0592234f1a4df517a6917334537df18ffe9803b52e88ab1a79bc475deaf
-pkgname = rpi-poe-fan-dkms-git
+pkgname = vcio-dkms-git
diff --git a/Makefile b/Makefile
index b59f9453e975..6c34b3b79664 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
-obj-m += rpi-poe-fan.o
+obj-m += vcio.o
KERNEL=/usr/lib/modules/${KERNELRELEASE}/build
all:
make -C ${KERNEL} M=$(PWD) modules
diff --git a/PKGBUILD b/PKGBUILD
index 5982122abd4d..57a462f05188 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,31 @@
-# Maintainer: Maciej Szeptuch <neverous at neverous dot info>
+# Maintainer: Yishen Miao <mys721tx at gmail dot com>
+# Contributor: Maciej Szeptuch <neverous at neverous dot info>
-_pkgbase=rpi-poe-fan
-_commit=b422a76
-pkgname=rpi-poe-fan-dkms-git
-pkgver=3.${_commit}
+_pkgbase=vcio
+_commit=324f7e52
+pkgname=${_pkgbase}-dkms-git
+pkgver=6.${_commit}
pkgrel=1
-pkgdesc='Hwmon driver for Raspberry Pi PoE(+)HAT fan'
-url=https://github.com/raspberrypi/linux/blob/${_commit}/drivers/hwmon/rpi-poe-fan.c
+pkgdesc='Character device driver for VC4 mailbox'
+url=https://github.com/raspberrypi/linux/blob/${_commit}/drivers/char/broadcom/vcio.c
arch=(any)
license=('GPL')
depends=(dkms)
provides=(${_pkgbase}=${pkgver}-${pkgrel})
conflicts=(${_pkgbase})
source=(
- https://raw.githubusercontent.com/raspberrypi/linux/${_commit}/drivers/hwmon/rpi-poe-fan.c
- https://raw.githubusercontent.com/raspberrypi/linux/${_commit}/include/soc/bcm2835/raspberrypi-firmware.h
+ https://github.com/raspberrypi/linux/blob/${_commit}/drivers/char/broadcom/vcio.c
dkms.conf
Makefile
)
-b2sums=(
- '92a4e558f527f155deb17af88ea3cfd03aad8dcac9f6ca7100d49d39627c98f9aeefef721583768719b00a130dc11c2494d6d2453bea419582bb3c7ebe3f0b1d'
- '5d4034b09087ee9f0d9e8408a08b0df9b63524a2cd32710f1ded05bbfbfcc5c7aede0eb11847c041811384d74c338a86b907b8965284f094593d6e42369120f5'
- 'a70240cc2424ecade86a37acc57f2d7b55a9cf6fbf65fb1f0033e297bb4c5ebb9fc87da0b65b982f518f5a7437dd3717ca9c9a9d584144c14ca3063e068fd4de'
- 'a7c1bfb35e77dc50920bc33ab7bd77bc1acbf832fc28ca4a629ab72eb5d6a6bfe1a862a9fd3e5c1721af339772f83687cd2371ce5c39b7cc507eb815f2f1c3ae'
+sha256sums=(
+ '06c58eb27872de4ff581cc77dec34b307d5de098fa81e0237e6309062ec46aea'
+ 'd0d0fde95be8b1e9ad37de3a6a08e048729f5503545140357f31d3c3289613ac'
+ 'f0ecf0592234f1a4df517a6917334537df18ffe9803b52e88ab1a79bc475deaf'
)
-prepare() {
- # Make the driver use local raspberrypi-firmware.h copy with new values, as they are not yet upstreamed
- sed -i -e 's|<soc/bcm2835/raspberrypi-firmware.h>|"raspberrypi-firmware.h"|' rpi-poe-fan.c
-
- # Fix for linux 5.12+
- sed -i -e 's|thermal_cdev_update|//thermal_cdev_update|' rpi-poe-fan.c
-}
-
package() {
- install -Dm 644 Makefile rpi-poe-fan.c raspberrypi-firmware.h dkms.conf -t "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}
+ install -Dm 644 Makefile vcio.c dkms.conf -t "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}
sed -e "s/@_PKGBASE@/${_pkgbase}/" \
-e "s/@PKGVER@/${pkgver}/" \
diff --git a/dkms.conf b/dkms.conf
index b839e013cde3..edd8f051ae43 100644
--- a/dkms.conf
+++ b/dkms.conf
@@ -3,5 +3,5 @@ PACKAGE_VERSION=@PKGVER@
MAKE[0]="make all"
CLEAN="make clean"
BUILT_MODULE_NAME[0]=@_PKGBASE@
-DEST_MODULE_LOCATION=/kernel/drivers/hwmon
+DEST_MODULE_LOCATION=/kernel/drivers/char
AUTOINSTALL=yes