summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSandy Carter2015-08-27 11:05:00 -0400
committerSandy Carter2015-08-27 11:05:00 -0400
commit7a79717049ad8aa330adabe1fffd4279555ede07 (patch)
treeb067f2e5bd240a4dbb067600155cc282de8ff262
parent6c35038311a5647662b81495932bf48b82e3979d (diff)
downloadaur-7a79717049ad8aa330adabe1fffd4279555ede07.tar.gz
Update and simplify package
Update maintainer and contributor comment Use official repo description for pkgdesc Use root website for url Remove options. If users run out of memory, they need to change their own make flags in /etc/makepkg.cfg Encapsulate variables Build in source dir, no need to have -build directory Add gitignore Name of downloaded archive from github is not that important once extracted
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD26
2 files changed, 16 insertions, 15 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0f10ae9448c9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.swp
+*.pkg.tar.xz
+*.tar.gz
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
index 197a576f140b..ad040f3ba961 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
-# Maintainer: Raziel23 <venom23 at runbox dot com>
+# Maintainer: Sandy Carter <bwrsandman@gmail.com>
+# Contributor: Raziel23 <venom23 at runbox dot com>
pkgname=vcmi
pkgver=0.98
-pkgrel=2
-pkgdesc="Heroes of Might and Magic 3 game engine"
+pkgrel=3
+pkgdesc="Open-source engine for Heroes of Might and Magic III"
arch=('i686' 'x86_64')
-url="http://forum.vcmi.eu/portal.php"
+url="http://vcmi.eu"
license=('GPL2')
depends=('boost-libs' 'ffmpeg' 'sdl2_image' 'sdl2_mixer' 'sdl2_ttf' 'qt5-base' 'libxkbcommon-x11'
'desktop-file-utils' 'gtk-update-icon-cache' 'hicolor-icon-theme' 'minizip')
@@ -13,26 +14,21 @@ makedepends=('boost' 'cmake')
optdepends=('innoextract: required by vcmibuilder'
'unshield: required by vcmibuilder'
'unzip: required by vcmibuilder')
-options=('!makeflags' 'strip' 'debug')
-install="$pkgname.install"
-source=("$pkgname-$pkgver.tar.gz::https://github.com/vcmi/$pkgname/archive/$pkgver.tar.gz"
+install="${pkgname}.install"
+source=(https://github.com/vcmi/${pkgname}/archive/${pkgver}.tar.gz
'0001-Fix-building-with-Boost-1.58.patch')
md5sums=('6a69e52a3380358220eba67332b097c6'
'1dbb6a91a35d141a2d266ad235a790e1')
prepare() {
- # Remove the last build.
- [[ -d "$pkgname-$pkgver-build" ]] && rm -rf "$pkgname-$pkgver-build"
- mkdir "$pkgname-$pkgver-build"
-
- cd "$pkgname-$pkgver"
+ cd "${srcdir}/${pkgname}-${pkgver}"
# Backport fix building with Boost 1.58.
patch -Np1 -i '../0001-Fix-building-with-Boost-1.58.patch'
}
build() {
- cd "$pkgname-$pkgver-build"
- cmake "../$pkgname-$pkgver" \
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ cmake \
-DCMAKE_INSTALL_PREFIX='/usr' \
-DCMAKE_INSTALL_LIBDIR='lib' \
-DCMAKE_SKIP_RPATH='FALSE' \
@@ -41,7 +37,7 @@ build() {
}
package() {
- cd "$pkgname-$pkgver-build"
+ cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="$pkgdir" install
}