diff options
author | gigas002 | 2024-09-07 01:06:49 +0900 |
---|---|---|
committer | gigas002 | 2024-09-07 01:06:49 +0900 |
commit | aae7b83940574eeaa26ae1c793e1dd0834ae6334 (patch) | |
tree | 9c0778fd227cac4660c9b63cf810631b192526e5 | |
parent | 6eee04b556c6190751261528dd25c76ff756a9a9 (diff) | |
download | aur-aae7b83940574eeaa26ae1c793e1dd0834ae6334.tar.gz |
patch for boost 1.86
-rw-r--r-- | .SRCINFO | 2 | ||||
-rw-r--r-- | .gitignore | 2 | ||||
-rw-r--r-- | PKGBUILD | 6 | ||||
-rw-r--r-- | boost.patch | 57 |
4 files changed, 64 insertions, 3 deletions
@@ -1,7 +1,7 @@ pkgbase = vcmi pkgdesc = Open-source engine for Heroes of Might and Magic III pkgver = 1.5.7 - pkgrel = 1 + pkgrel = 2 url = http://vcmi.eu install = vcmi.install arch = i686 diff --git a/.gitignore b/.gitignore index b74111c95d9c..5057c87cdb5c 100644 --- a/.gitignore +++ b/.gitignore @@ -5,5 +5,5 @@ !.gitignore !.SRCINFO !PKGBUILD -!server.patch +!boost.patch !vcmi.install @@ -4,7 +4,7 @@ pkgname=vcmi pkgver=1.5.7 -pkgrel=1 +pkgrel=2 pkgdesc="Open-source engine for Heroes of Might and Magic III" arch=('i686' 'x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64') url="http://vcmi.eu" @@ -17,6 +17,7 @@ provides=('vcmi') conflicts=('vcmi') install="${pkgname}.install" source=("${pkgname}-${pkgver}.tar.gz::https://github.com/${pkgname}/${pkgname}/releases/download/${pkgver}/VCMI-Sources.tar.gz") +patch="boost.patch" sha256sums=('aab79529e06613c90f627a92a8ee46bd9941ea542e76e9d2f1f19d10bfe667fd') # workaround @@ -28,6 +29,9 @@ prepare() { mv "$srcdir"/* "${startdir}/${pkgname}-${pkgver}/" mv "${startdir}/${pkgname}-${pkgver}/" "${srcdir}/${pkgname}-${pkgver}/" fi + + cd $srcdir/${pkgname}-${pkgver} + patch -p1 -i $startdir/$patch } build() { diff --git a/boost.patch b/boost.patch new file mode 100644 index 000000000000..d79f12df8177 --- /dev/null +++ b/boost.patch @@ -0,0 +1,57 @@ +diff --git a/client/ServerRunner.cpp b/client/ServerRunner.cpp +index 8ab4df8..36765de 100644 +--- a/client/ServerRunner.cpp ++++ b/client/ServerRunner.cpp +@@ -9,16 +9,17 @@ + */ + #include "StdInc.h" + ++#ifndef VCMI_MOBILE ++#include <boost/process/v1/child.hpp> ++#include <boost/process/v1/io.hpp> ++#endif ++ + #include "ServerRunner.h" + + #include "../lib/VCMIDirs.h" + #include "../lib/CThreadHelper.h" + #include "../server/CVCMIServer.h" + +-#ifndef VCMI_MOBILE +-#include <boost/process/child.hpp> +-#include <boost/process/io.hpp> +-#endif + + ServerThreadRunner::ServerThreadRunner() = default; + ServerThreadRunner::~ServerThreadRunner() = default; +@@ -84,7 +85,7 @@ void ServerProcessRunner::start(uint16_t port, bool connectToLobby, std::shared_ + args.push_back("--lobby"); + + std::error_code ec; +- child = std::make_unique<boost::process::child>(serverPath, args, ec, boost::process::std_out > logPath); ++ child = std::make_unique<boost::process::v1::child>(serverPath, args, ec, boost::process::v1::std_out > logPath); + + if (ec) + throw std::runtime_error("Failed to start server! Reason: " + ec.message()); +diff --git a/client/ServerRunner.h b/client/ServerRunner.h +index d045e0c..a89bc87 100644 +--- a/client/ServerRunner.h ++++ b/client/ServerRunner.h +@@ -45,7 +45,7 @@ public: + + #ifndef VCMI_MOBILE + +-namespace boost::process { ++namespace boost::process::v1 { + class child; + } + +@@ -53,7 +53,7 @@ class child; + /// Available only on desktop systems where process management is allowed + class ServerProcessRunner : public IServerRunner, boost::noncopyable + { +- std::unique_ptr<boost::process::child> child; ++ std::unique_ptr<boost::process::v1::child> child; + + public: + void start(uint16_t port, bool connectToLobby, std::shared_ptr<StartInfo> startingInfo) override;
\ No newline at end of file |