summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSandy Carter2016-09-24 10:56:40 -0400
committerSandy Carter2016-09-24 10:56:40 -0400
commit350d32856b9fb97d0dab8e698daa2fcfb1af9f68 (patch)
treed81e245837bab57380b4f3b99f9b43963deb0159
parent14b4b9abe3ebac5aaeecfe157c43c8e369861c19 (diff)
downloadaur-350d32856b9fb97d0dab8e698daa2fcfb1af9f68.tar.gz
Improve build on multiple cores
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD22
2 files changed, 13 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 374c75831aed..e5d6ecd92a01 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,10 @@
+# Generated by mksrcinfo v8
+# Sat Sep 24 14:56:06 UTC 2016
pkgbase = vcmi-git
- pkgdesc = Heroes of Might and Magic 3 game engine
- pkgver = r4845.e529ac6
+ pkgdesc = Open-source engine for Heroes of Might and Magic III
+ pkgver = r6067.a03419e
pkgrel = 1
- url = http://forum.vcmi.eu/portal.php
+ url = http://vcmi.eu
install = vcmi-git.install
arch = i686
arch = x86_64
@@ -26,9 +28,6 @@ pkgbase = vcmi-git
optdepends = unzip: required by vcmibuilder
provides = vcmi
conflicts = vcmi
- options = !makeflags
- options = strip
- options = debug
source = vcmi-git::git+https://github.com/vcmi/vcmi.git#branch=develop
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index fff8bca81e09..827a24ee8921 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
-# Maintainer: Raziel23 <venom23 at runbox dot com>
+# Maintainer: Sandy Carter <bwrsandman@gmail.com>
+# Contributor: Raziel23 <venom23 at runbox dot com>
pkgname=vcmi-git
-pkgver=r4845.e529ac6
+pkgver=r6067.a03419e
pkgrel=1
-pkgdesc="Heroes of Might and Magic 3 game engine"
+pkgdesc="Open-source engine for Heroes of Might and Magic III"
arch=('i686' 'x86_64')
-url="http://forum.vcmi.eu/portal.php"
+url="http://vcmi.eu"
license=('GPL2')
depends=('boost-libs' 'ffmpeg' 'sdl2_image' 'sdl2_mixer' 'sdl2_ttf' 'qt5-base' 'libxkbcommon-x11'
'desktop-file-utils' 'gtk-update-icon-cache' 'hicolor-icon-theme' 'minizip')
@@ -15,7 +16,6 @@ optdepends=('innoextract: required by vcmibuilder'
'unzip: required by vcmibuilder')
provides=('vcmi')
conflicts=('vcmi')
-options=('!makeflags' 'strip' 'debug')
install="$pkgname.install"
source=("$pkgname::git+https://github.com/vcmi/vcmi.git#branch=develop")
md5sums=('SKIP')
@@ -25,15 +25,9 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- # Remove the last build.
- [[ -d "$pkgname-build" ]] && rm -rf "$pkgname-build"
- mkdir "$pkgname-build"
-}
-
build() {
- cd "$pkgname-build"
- cmake "../$pkgname" \
+ cd "${srcdir}/${pkgname}"
+ cmake \
-DCMAKE_INSTALL_PREFIX='/usr' \
-DCMAKE_INSTALL_LIBDIR='lib' \
-DCMAKE_SKIP_RPATH='FALSE' \
@@ -42,7 +36,7 @@ build() {
}
package() {
- cd "$pkgname-build"
+ cd "${srcdir}/${pkgname}"
make DESTDIR="$pkgdir" install
}