summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-02-24 09:58:09 +0300
committerCaleb Maclennan2020-02-24 09:58:09 +0300
commit5bdf948ff0a974690415ba654bb15fb77e47c0b9 (patch)
tree50b1ff8969bcf98e1bed5951315cda69b380de55
parent758bb26baa74149037ec2ac6b222ae8d8eef1f7b (diff)
downloadaur-5bdf948ff0a974690415ba654bb15fb77e47c0b9.tar.gz
Use unique download name
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e47d92a22ba9..cad0fb3ffba4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = vcsh
pkgdesc = manage config files in HOME via fake bare git repositories
pkgver = 1.20151229
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/RichiH/vcsh
arch = any
license = GPL
depends = git
optdepends = myrepos: helps manage a large number of repositories
- source = https://github.com/RichiH/vcsh/archive/v1.20151229.zip
- sha256sums = 817874ee1022732197e10d385eb9c88f2d7a5629a067761f0dd5ca9459d40a8e
+ source = vcsh-1.20151229.tar.gz::https://github.com/RichiH/vcsh/archive/v1.20151229.tar.gz
+ sha256sums = ae069506b0490287aefa582ab4e6af1c7ebc4dca743b17d91e0c8d0327d7a3fa
pkgname = vcsh
diff --git a/PKGBUILD b/PKGBUILD
index 17a751b49712..b3f3b2233a49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,25 +6,23 @@
pkgname=vcsh
pkgver=1.20151229
-pkgrel=2
+pkgrel=3
pkgdesc='manage config files in HOME via fake bare git repositories'
arch=('any')
-url='https://github.com/RichiH/vcsh'
+url="https://github.com/RichiH/$pkgname"
license=('GPL')
depends=('git')
optdepends=('myrepos: helps manage a large number of repositories')
-source=("https://github.com/RichiH/$pkgname/archive/v$pkgver.zip")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/RichiH/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('ae069506b0490287aefa582ab4e6af1c7ebc4dca743b17d91e0c8d0327d7a3fa')
_src_dir="$pkgname-$pkgver"
-sha256sums=('817874ee1022732197e10d385eb9c88f2d7a5629a067761f0dd5ca9459d40a8e')
prepare() {
cd "$_src_dir"
-
sed -i 's|\(install:\) all|\1|' Makefile
}
package() {
cd "$_src_dir"
-
make DESTDIR="$pkgdir/" ZSHDIR='$(PREFIX)/share/zsh/site-functions' install
}