summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-03-29 21:57:20 +0300
committerCaleb Maclennan2021-03-29 21:57:20 +0300
commit8143a8355cbe9ae5fb51883cc50d63290539cde8 (patch)
tree12b5ea23815d6b23b09b7029cfe34437d7d0ded4
parent86f83ef862682c3f5584676955e95d64cd75a9e8 (diff)
downloadaur-8143a8355cbe9ae5fb51883cc50d63290539cde8.tar.gz
upgpkg: vcsh 1.20190619-2
Build separate from package
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af5cd2c02860..2d106f011323 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vcsh
pkgdesc = Version Control System for $HOME that manages multiple Git repositories
pkgver = 1.20190619
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/RichiH/vcsh
arch = any
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index c3787f497b2d..ef4609185432 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,15 +6,15 @@
pkgname=vcsh
pkgver=1.20190619
-pkgrel=1
+pkgrel=2
pkgdesc='Version Control System for $HOME that manages multiple Git repositories'
arch=('any')
url="https://github.com/RichiH/$pkgname"
license=('GPL')
depends=('git')
-optdepends=('myrepos: helps manage a large number of repositories')
makedepends=('ruby-ronn')
checkdepends=('perl' 'perl-shell-command')
+optdepends=('myrepos: helps manage a large number of repositories')
source=("$pkgname-$pkgver.tar.gz::https://github.com/RichiH/$pkgname/archive/v$pkgver.tar.gz")
sha256sums=('9f9373bd96dfa1317ff119b2a3feaffc0e5331816e940267daf088637f995f5f')
@@ -23,6 +23,11 @@ prepare() {
sed -i 's#^\(install:\) all#\1 manpages#' Makefile
}
+build() {
+ cd "$pkgname"
+ make manpages
+}
+
check() {
cd "$pkgname-$pkgver"
make test