summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNils Amiet2023-05-01 20:45:11 +0200
committerNils Amiet2023-05-01 20:45:11 +0200
commit845b63e25ab34a951f5dbbd0a2f38f5ec8ad73a0 (patch)
tree1f1c04eaae25e3c0fb35a516e07207e7b674ed66
parente3e08732dce6c8bfa736778930529bc710e0ad8b (diff)
downloadaur-845b63e25ab34a951f5dbbd0a2f38f5ec8ad73a0.tar.gz
Fix build after move to poetry
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c54e8ee340d3..e3164f47ca71 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = vcsi-git
pkgdesc = Create video contact sheets, thumbnails
pkgver = 7
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/amietn/vcsi
arch = any
license = MIT
makedepends = git
+ makedepends = python-installer
+ makedepends = python-poetry
depends = python
depends = ffmpeg
depends = python-numpy
diff --git a/PKGBUILD b/PKGBUILD
index 059312fc79af..69e451b18716 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Nils Amiet <amietn@foobar>
pkgname=vcsi-git
pkgver=7
-pkgrel=4
+pkgrel=5
pkgdesc="Create video contact sheets, thumbnails"
arch=(any)
url="https://github.com/amietn/vcsi"
license=('MIT')
groups=()
depends=(python ffmpeg python-numpy python-pillow python-jinja python-texttable ttf-dejavu python-parsedatetime python-setuptools)
-makedepends=(git)
+makedepends=(git python-installer python-poetry)
provides=(vcsi)
conflicts=(vcsi)
replaces=()
@@ -18,7 +18,16 @@ install=
source=("${pkgname}::git+https://github.com/amietn/vcsi.git")
sha256sums=('SKIP')
+prepare() {
+ git -C "${srcdir}/${pkgname}" clean -dfx
+}
+
+build() {
+ cd "${pkgname}"
+ poetry build
+}
+
package() {
cd "${pkgname}"
- python setup.py install --root="${pkgdir}/" --optimize=1
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}