summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOSAMC2024-04-21 18:12:56 +0000
committerFlorian Hülsmann2024-04-21 18:12:56 +0000
commit51b336495ff54c57bda57ad6721e6c66962edea6 (patch)
treeacbdecaddbd3493d84d6d5396d36b70b08b21f0b
parent87b19468ca48995c6eaa02106097082395ead0ec (diff)
downloadaur-51b336495ff54c57bda57ad6721e6c66962edea6.tar.gz
vcvrack: set explicit WM class (#410)
* vcvrack: set explicit WM class * fix .desktop * revert gendesk, since it doesn't see the PKGBUILD for external SRCDIR * force .desktop override * binary hint in .install * revert _repo → _name
-rw-r--r--.SRCINFO5
-rw-r--r--.install3
-rw-r--r--PKGBUILD13
-rw-r--r--wmclass.patch14
4 files changed, 29 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e82bcfe43c3..662ba29d69b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = vcvrack
pkgdesc = Open-source Eurorack modular synthesizer simulator
pkgver = 2.5.1
- pkgrel = 1
+ pkgrel = 2
url = https://vcvrack.com/
+ install = .install
arch = aarch64
arch = x86_64
groups = pro-audio
@@ -39,6 +40,7 @@ pkgbase = vcvrack
source = tinyexpr.git::git+https://github.com/codeplea/tinyexpr
source = vcvrack-fundamental-2.6.0.tar.gz::https://github.com/VCVRack/Fundamental/archive/v2.6.0.tar.gz
source = plugins.patch
+ source = wmclass.patch
source = vcvrack.sh
source = profile.sh
source = trademark.eml
@@ -54,6 +56,7 @@ pkgbase = vcvrack
sha256sums = SKIP
sha256sums = 1e3662c1f5cf57e484e7f605028fbe032e1eab541b73e10453d36df400e68ae0
sha256sums = 3ad0ea63ce2d5bf62b27e7b51a6d098040435636939d36a584a9b609578a9c9e
+ sha256sums = f1abd73a4de8a97328ff0111fb59ab9f0bde42b2b8f0d2a2ee7fb964e47dbe5e
sha256sums = 21ac35c6ad4e5a29c32939b17baaf7ac1936077eda2214e28675eefcf2021db8
sha256sums = e1da6ccf04bae3a2101151fec7ddd32e48ff92b0a1146b559fd3221c778d521f
sha256sums = 1159629aa90abb7c972c0f630d55d018b88a6b3bc3ff0bb9466cc06982f38641
diff --git a/.install b/.install
new file mode 100644
index 000000000000..dff1e14d4a04
--- /dev/null
+++ b/.install
@@ -0,0 +1,3 @@
+post_upgrade() {
+ echo "vcvrack 2.5.1-2 changed the binary name from Rack to vcvrack"
+}
diff --git a/PKGBUILD b/PKGBUILD
index 8cf2d82031f9..a59a4c69c544 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,11 +8,12 @@
_name=Rack
pkgname=vcvrack
pkgver=2.5.1
-pkgrel=1
+pkgrel=2
pkgdesc='Open-source Eurorack modular synthesizer simulator'
url='https://vcvrack.com/'
license=(custom GPL-3.0-or-later)
arch=(aarch64 x86_64)
+install=.install
_plugin_name=Fundamental
_plugin_ver=2.6.0
_plugin_pkg=$pkgname-${_plugin_name,,}
@@ -36,6 +37,7 @@ source=(
'tinyexpr.git::git+https://github.com/codeplea/tinyexpr'
"$_plugin_pkg-$_plugin_ver.tar.gz::https://github.com/VCVRack/$_plugin_name/archive/v$_plugin_ver.tar.gz"
'plugins.patch'
+ 'wmclass.patch'
'vcvrack.sh'
'profile.sh'
'trademark.eml'
@@ -52,6 +54,7 @@ sha256sums=('SKIP'
'SKIP'
'1e3662c1f5cf57e484e7f605028fbe032e1eab541b73e10453d36df400e68ae0'
'3ad0ea63ce2d5bf62b27e7b51a6d098040435636939d36a584a9b609578a9c9e'
+ 'f1abd73a4de8a97328ff0111fb59ab9f0bde42b2b8f0d2a2ee7fb964e47dbe5e'
'21ac35c6ad4e5a29c32939b17baaf7ac1936077eda2214e28675eefcf2021db8'
'e1da6ccf04bae3a2101151fec7ddd32e48ff92b0a1146b559fd3221c778d521f'
'1159629aa90abb7c972c0f630d55d018b88a6b3bc3ff0bb9466cc06982f38641')
@@ -75,13 +78,13 @@ prepare() {
# support building plugins and loading system-wide plugins
patch -p1 -i ../plugins.patch
+ # set proper window manager class
+ patch -p1 -i ../wmclass.patch
gendesk -f -n \
--pkgname $pkgname \
- --name "VCV Rack" \
- --exec Rack \
--pkgdesc "$pkgdesc" \
- --genericname "Virtual modular synthesizer" \
+ --name "VCV Rack" \
--categories "AudioVideo;Audio"
}
@@ -109,7 +112,7 @@ package() {
cd $_name
install -vDm755 Rack -t "$pkgdir"/usr/lib/$pkgname
install -vDm755 libRack.so -t "$pkgdir"/usr/lib
- install -vDm755 "$srcdir"/vcvrack.sh "$pkgdir"/usr/bin/Rack
+ install -vDm755 "$srcdir"/vcvrack.sh "$pkgdir"/usr/bin/$pkgname
install -vDm644 template.vcv Core.json cacert.pem -t "$pkgdir"/usr/lib/$pkgname
# resources
diff --git a/wmclass.patch b/wmclass.patch
new file mode 100644
index 000000000000..6fa5751279c3
--- /dev/null
+++ b/wmclass.patch
@@ -0,0 +1,14 @@
+diff --git a/src/window/Window.cpp b/src/window/Window.cpp
+index 19d3cd8c..4488e3d5 100644
+--- a/src/window/Window.cpp
++++ b/src/window/Window.cpp
+@@ -268,6 +268,9 @@ Window::Window() {
+
+ #if defined ARCH_MAC
+ glfwWindowHint(GLFW_COCOA_RETINA_FRAMEBUFFER, GLFW_TRUE);
++#elif defined ARCH_LIN
++ glfwWindowHintString(GLFW_X11_CLASS_NAME, "vcvrack");
++ glfwWindowHintString(GLFW_WAYLAND_APP_ID, "vcvrack");
+ #endif
+
+ // Create window