summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOSAMC2024-04-15 22:12:54 +0000
committerFlorian Hülsmann2024-04-15 22:12:54 +0000
commita23ee4d7a42180cdecaff5dfdb96a2dec0af20e1 (patch)
tree1990e8fc6f51139adeb458b75418ab4fe32ad53b
parentb1416e27853b2aeb2747503a8f0d061e1c7e0c65 (diff)
downloadaur-a23ee4d7a42180cdecaff5dfdb96a2dec0af20e1.tar.gz
vcvrack: fix release tag (#405)
* vcvrack: fix release tag * fix patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--plugins.patch12
3 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61fe03988adb..443fceb2920a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vcvrack
pkgdesc = Open-source Eurorack modular synthesizer simulator
pkgver = 2.5.0
- pkgrel = 1
+ pkgrel = 2
url = https://vcvrack.com/
arch = x86_64
arch = aarch64
@@ -28,7 +28,7 @@ pkgbase = vcvrack
depends = jansson
provides = vcvrack-fundamental=2.6.0
conflicts = vcvrack-fundamental
- source = Rack::git+https://github.com/VCVRack/Rack#tag=8c6f41b778b4bf8860b89b36d5503fd37924077f
+ source = Rack::git+https://github.com/VCVRack/Rack#tag=f9e90eda901dad84f80f93d61f92afc5e37ad2bb
source = filesystem.git::git+https://github.com/gulrak/filesystem
source = fuzzysearchdatabase.git::git+https://bitbucket.org/j_norberg/fuzzysearchdatabase
source = nanosvg.git::git+https://github.com/memononen/nanosvg
@@ -54,7 +54,7 @@ pkgbase = vcvrack
sha256sums = SKIP
sha256sums = SKIP
sha256sums = 1e3662c1f5cf57e484e7f605028fbe032e1eab541b73e10453d36df400e68ae0
- sha256sums = daaf645f3b321449f72ae1c05d1fb285fee4c570f629d4cd9322a885fd059858
+ sha256sums = 3ad0ea63ce2d5bf62b27e7b51a6d098040435636939d36a584a9b609578a9c9e
sha256sums = 21ac35c6ad4e5a29c32939b17baaf7ac1936077eda2214e28675eefcf2021db8
sha256sums = e1da6ccf04bae3a2101151fec7ddd32e48ff92b0a1146b559fd3221c778d521f
sha256sums = 1159629aa90abb7c972c0f630d55d018b88a6b3bc3ff0bb9466cc06982f38641
diff --git a/PKGBUILD b/PKGBUILD
index 106b445b2569..a3f3301ebf21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
_name=Rack
pkgname=vcvrack
pkgver=2.5.0
-pkgrel=1
+pkgrel=2
pkgdesc='Open-source Eurorack modular synthesizer simulator'
url='https://vcvrack.com/'
license=(custom CCPL GPL3)
@@ -22,7 +22,7 @@ makedepends=(alsa-lib cmake curl gendesk git glew jack jq libarchive libpulse op
provides=("$_plugin_pkg=$_plugin_ver")
conflicts=($_plugin_pkg)
groups=(pro-audio)
-_tag=8c6f41b778b4bf8860b89b36d5503fd37924077f
+_tag=f9e90eda901dad84f80f93d61f92afc5e37ad2bb
source=(
"$_name::git+https://github.com/VCVRack/$_name#tag=$_tag"
'filesystem.git::git+https://github.com/gulrak/filesystem'
@@ -51,7 +51,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'1e3662c1f5cf57e484e7f605028fbe032e1eab541b73e10453d36df400e68ae0'
- 'daaf645f3b321449f72ae1c05d1fb285fee4c570f629d4cd9322a885fd059858'
+ '3ad0ea63ce2d5bf62b27e7b51a6d098040435636939d36a584a9b609578a9c9e'
'21ac35c6ad4e5a29c32939b17baaf7ac1936077eda2214e28675eefcf2021db8'
'e1da6ccf04bae3a2101151fec7ddd32e48ff92b0a1146b559fd3221c778d521f'
'1159629aa90abb7c972c0f630d55d018b88a6b3bc3ff0bb9466cc06982f38641')
diff --git a/plugins.patch b/plugins.patch
index 0d74d1debee0..f955bd2fc86d 100644
--- a/plugins.patch
+++ b/plugins.patch
@@ -1,5 +1,5 @@
diff --git a/plugin.mk b/plugin.mk
-index 47438416..e1f70545 100644
+index 0a599244..cc2643d7 100644
--- a/plugin.mk
+++ b/plugin.mk
@@ -1,9 +1,13 @@
@@ -18,7 +18,7 @@ index 47438416..e1f70545 100644
ifndef SLUG
$(error SLUG could not be found in manifest)
-@@ -33,10 +37,10 @@ ifdef ARCH_LIN
+@@ -29,10 +33,10 @@ ifdef ARCH_LIN
TARGET := $(TARGET).so
# This prevents static variables in the DSO (dynamic shared object) from being preserved after dlclose().
FLAGS += -fno-gnu-unique
@@ -30,14 +30,14 @@ index 47438416..e1f70545 100644
+ FLAGS += -I/usr/include/vcvrack -I/usr/include/vcvrack/dep
+ # Link shared libs
+ LDFLAGS += -ldl
- RACK_USER_DIR ?= $(HOME)/.Rack2
+ XDG_DATA_HOME ?= $(HOME)/.local/share
+ RACK_USER_DIR ?= $(XDG_DATA_HOME)/Rack2
endif
-
diff --git a/src/plugin.cpp b/src/plugin.cpp
-index 25621f66..33571d9e 100644
+index f039dd07..f292e6a9 100644
--- a/src/plugin.cpp
+++ b/src/plugin.cpp
-@@ -269,6 +269,9 @@ void init() {
+@@ -276,6 +276,9 @@ void init() {
if (settings::safeMode)
return;