summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Runge2019-07-07 14:46:25 +0200
committerDavid Runge2019-07-07 14:46:25 +0200
commit6bd8fadbee8005b5ad6890d915e094da9b309cf4 (patch)
tree47e508c0c91561a24141587a52b2de098c21b2af
parente0f7886aa4133901355955dd8b5549d6579f27aa (diff)
downloadaur-6bd8fadbee8005b5ad6890d915e094da9b309cf4.tar.gz
PKGBUILD: Upgrading to some more recent version (compatible to new plugin API). Sadly there's no proper upstream tagging any more (because yolo).
Building against vcvrack, by providing RACK_DIR and FLAGS to find Makefile includes and header includes (respectively). Using USE_SYSTEM_LIBS=true, as provided via patch in vcvrack. Adding license file (this is BSD) and docs.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD70
2 files changed, 35 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3e853b8acf9..0bf90c73516e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,16 @@
pkgbase = vcvrack-befaco
- pkgdesc = Befaco's VCV modules
- pkgver = 0.6.0
+ pkgdesc = Rack plugins based on Befaco Eurorack modules
+ pkgver = 0.6.0+21+g31da1ab
pkgrel = 1
url = https://github.com/VCVRack/Befaco
install = vcvrack-befaco.install
- arch = i686
arch = x86_64
license = BSD
makedepends = git
+ makedepends = jq
makedepends = zip
- depends = vcvrack>=0.6
- source = vcvrack-Befaco::git+https://github.com/VCVRack/Befaco.git#tag=v0.6.0
- source = vcvrack::git+https://github.com/VCVRack/Rack.git#tag=v0.6.0
- source = git+https://github.com/AndrewBelt/osdialog.git
- source = git+https://github.com/AndrewBelt/oui-blendish.git
- source = git+https://github.com/memononen/nanosvg.git
- source = git+https://github.com/memononen/nanovg.git
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
+ depends = vcvrack
+ source = Befaco-0.6.0+21+g31da1ab::git+https://github.com/VCVRack/Befaco.git#commit=31da1ab46d698e6a89867b7a10251870e1d8aa91
sha256sums = SKIP
pkgname = vcvrack-befaco
diff --git a/PKGBUILD b/PKGBUILD
index 1934ca639551..b37bbce20926 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,57 +1,47 @@
# Maintainer: Miroslav Koškár <http://mkoskar.com/>
+# Contributor: David Runge <dave@sleepmap.de>
-_rackver=0.6.0
-_plugname='Befaco'
+_name='Befaco'
+# upstream doesn't tag properly any more (plugin.json suggests the version is
+# currently at 1.0.0) because yolo
+_commit='31da1ab46d698e6a89867b7a10251870e1d8aa91'
pkgname='vcvrack-befaco'
-pkgver=0.6.0
+pkgver=0.6.0+21+g31da1ab
pkgrel=1
-pkgdesc="Befaco's VCV modules"
+pkgdesc="Rack plugins based on Befaco Eurorack modules"
url='https://github.com/VCVRack/Befaco'
-license=(BSD)
-arch=(i686 x86_64)
-depends=('vcvrack>=0.6')
-makedepends=(git zip)
+license=('BSD')
+arch=('x86_64')
+depends=('vcvrack')
+makedepends=('git' 'jq' 'zip')
install="$pkgname.install"
+source=("${_name}-${pkgver}::git+https://github.com/VCVRack/${_name}.git#commit=${_commit}")
+sha256sums=('SKIP')
-source=(
- "vcvrack-$_plugname::git+https://github.com/VCVRack/$_plugname.git#tag=v$pkgver"
- "vcvrack::git+https://github.com/VCVRack/Rack.git#tag=v$_rackver"
- git+https://github.com/AndrewBelt/osdialog.git
- git+https://github.com/AndrewBelt/oui-blendish.git
- git+https://github.com/memononen/nanosvg.git
- git+https://github.com/memononen/nanovg.git
-)
-sha256sums=(
- SKIP
- SKIP
- SKIP
- SKIP
- SKIP
- SKIP
-)
+pkgver() {
+ cd "${_name}"-"${pkgver}"
+ git describe --tags | sed 's/^v//;s/-/+/g'
+}
prepare() {
- cd vcvrack
- git submodule init
- git config submodule.ext/nanosvg.url "$srcdir/nanosvg"
- git config submodule.ext/nanovg.url "$srcdir/nanovg"
- git config submodule.ext/osdialog.url "$srcdir/osdialog"
- git config submodule.ext/oui-blendish.url "$srcdir/oui-blendish"
- git submodule update
-
- cd plugins
- git clone "$srcdir/vcvrack-$_plugname" "$_plugname"
+ cd "${_name}"-"${pkgver}"
}
build() {
- cd "vcvrack/plugins/$_plugname"
- sed -i 's/FLAGS =/FLAGS +=/' Makefile
- FLAGS='-I/opt/vcvrack/include' make dist
+ # define RACK_DIR, so Makefile snippets can be found
+ export RACK_DIR="/usr/share/vcvrack"
+ # define FLAGS, so headers can be included
+ export FLAGS="-I/usr/include/vcvrack -I/usr/include/vcvrack/dep"
+ cd "${_name}"-"${pkgver}"
+ USE_SYSTEM_LIBS=true make
+ USE_SYSTEM_LIBS=true make dist
}
package() {
- cd "vcvrack/plugins/$_plugname"
- install -D -m644 "dist/$_plugname-$pkgver-lin.zip" \
- "$pkgdir/opt/vcvrack/$_plugname.zip"
+ cd "${_name}"-"${pkgver}"
+ install -vDm 644 "dist/${_name}"*".zip" \
+ "${pkgdir}/opt/vcvrack/${_name}.zip"
+ install -vDm 644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -vDm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
}