summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiroslav Koškár2018-04-15 11:37:51 +0200
committerMiroslav Koškár2018-04-15 11:39:55 +0200
commite0f7886aa4133901355955dd8b5549d6579f27aa (patch)
tree8b66d9258845bdfa05ef6c4f6d0039561433f4b4
parentf9a788856da5a37b14e475a61a1691d466c33b5c (diff)
downloadaur-e0f7886aa4133901355955dd8b5549d6579f27aa.tar.gz
0.6.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
-rw-r--r--vcvrack-befaco.install15
3 files changed, 30 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9f0a9dff806..e3e853b8acf9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = vcvrack-befaco
pkgdesc = Befaco's VCV modules
- pkgver = 0.5.0
+ pkgver = 0.6.0
pkgrel = 1
url = https://github.com/VCVRack/Befaco
+ install = vcvrack-befaco.install
arch = i686
arch = x86_64
license = BSD
makedepends = git
- depends = vcvrack
- source = vcvrack-Befaco::git+https://github.com/VCVRack/Befaco.git#tag=v0.5.0
- source = vcvrack::git+https://github.com/VCVRack/Rack.git#tag=v0.5.1
+ makedepends = zip
+ depends = vcvrack>=0.6
+ source = vcvrack-Befaco::git+https://github.com/VCVRack/Befaco.git#tag=v0.6.0
+ source = vcvrack::git+https://github.com/VCVRack/Rack.git#tag=v0.6.0
source = git+https://github.com/AndrewBelt/osdialog.git
source = git+https://github.com/AndrewBelt/oui-blendish.git
- source = git+https://github.com/mackron/dr_libs.git
source = git+https://github.com/memononen/nanosvg.git
source = git+https://github.com/memononen/nanovg.git
sha256sums = SKIP
@@ -21,7 +22,6 @@ pkgbase = vcvrack-befaco
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = SKIP
pkgname = vcvrack-befaco
diff --git a/PKGBUILD b/PKGBUILD
index 290fc694d304..1934ca639551 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
# Maintainer: Miroslav Koškár <http://mkoskar.com/>
-_rackver=0.5.1
+_rackver=0.6.0
_plugname='Befaco'
pkgname='vcvrack-befaco'
-pkgver=0.5.0
+pkgver=0.6.0
pkgrel=1
pkgdesc="Befaco's VCV modules"
url='https://github.com/VCVRack/Befaco'
license=(BSD)
arch=(i686 x86_64)
-depends=(vcvrack)
-makedepends=(git)
+depends=('vcvrack>=0.6')
+makedepends=(git zip)
+install="$pkgname.install"
source=(
"vcvrack-$_plugname::git+https://github.com/VCVRack/$_plugname.git#tag=v$pkgver"
"vcvrack::git+https://github.com/VCVRack/Rack.git#tag=v$_rackver"
git+https://github.com/AndrewBelt/osdialog.git
git+https://github.com/AndrewBelt/oui-blendish.git
- git+https://github.com/mackron/dr_libs.git
git+https://github.com/memononen/nanosvg.git
git+https://github.com/memononen/nanovg.git
)
@@ -29,13 +29,11 @@ sha256sums=(
SKIP
SKIP
SKIP
- SKIP
)
prepare() {
cd vcvrack
git submodule init
- git config submodule.ext/dr_libs.url "$srcdir/dr_libs"
git config submodule.ext/nanosvg.url "$srcdir/nanosvg"
git config submodule.ext/nanovg.url "$srcdir/nanovg"
git config submodule.ext/osdialog.url "$srcdir/osdialog"
@@ -48,13 +46,12 @@ prepare() {
build() {
cd "vcvrack/plugins/$_plugname"
- make
+ sed -i 's/FLAGS =/FLAGS +=/' Makefile
+ FLAGS='-I/opt/vcvrack/include' make dist
}
package() {
cd "vcvrack/plugins/$_plugname"
- install -D -m644 -t "$pkgdir/usr/share/licenses/vcvrack/$_plugname" LICENSE*
- install -d "$pkgdir/opt/vcvrack/plugins/$_plugname"
- cp -dr --preserve=mode -t "$pkgdir/opt/vcvrack/plugins/$_plugname" \
- res plugin.so
+ install -D -m644 "dist/$_plugname-$pkgver-lin.zip" \
+ "$pkgdir/opt/vcvrack/$_plugname.zip"
}
diff --git a/vcvrack-befaco.install b/vcvrack-befaco.install
new file mode 100644
index 000000000000..202201c48614
--- /dev/null
+++ b/vcvrack-befaco.install
@@ -0,0 +1,15 @@
+post_common() {
+ cat <<-EOF
+ Since VCV Rack 0.6.0 system plugins are no longer supported.
+ Copy (or link) /opt/vcvrack/<plugin>.zip to your ~/.Rack/plugins directory
+ (it's done automatically for Fundamental upon first launch).
+ EOF
+}
+
+post_install() {
+ post_common
+}
+
+post_upgrade() {
+ post_common
+}