summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Runge2019-07-06 22:45:55 +0200
committerDavid Runge2019-07-06 22:45:55 +0200
commit95a53d4fe31c549e6883eea84c22c030a84d0794 (patch)
tree143f5492cbe82f6a847b544614e73f6deea6c51c
parentaf332ae627f2f2a84552ba7d1771035ceb9c01e5 (diff)
downloadaur-95a53d4fe31c549e6883eea84c22c030a84d0794.tar.gz
PKGBUILD: Upgrading to some recent (more or less yolo defined) version, which according to plugin.json is 1.0.1, but as there are no tags, we don't really know...
Removing .install file, as this plugin gets special treatment and gets autoloaded from the system install location... because. Removing static library mess with libsamplerate in Makefile. Exporting RACK_DIR (to include Makefile snippets from vcvrack), FLAGS (to find the headers from vcvrack) and LDFLAGS (to link against system libsamplerate). Using USE_SYSTEM_LIBS=true, which was introduced in the patched version of vcvrack. Installing docs and LICENSE (it is BSD).
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD76
-rw-r--r--vcvrack-fundamental.install15
3 files changed, 42 insertions, 72 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb00c8a5e4fd..8f06d1a41262 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,18 @@
pkgbase = vcvrack-fundamental
pkgdesc = Fundamental VCV modules
- pkgver = 0.6.0
+ pkgver = 0.6.0+99+g770e045
pkgrel = 1
url = https://github.com/VCVRack/Fundamental
- install = vcvrack-fundamental.install
- arch = i686
arch = x86_64
+ license = CCPL
license = BSD
makedepends = git
+ makedepends = jq
makedepends = zip
- depends = vcvrack>=0.6
- source = vcvrack-Fundamental::git+https://github.com/VCVRack/Fundamental.git#tag=v0.6.0
- source = vcvrack::git+https://github.com/VCVRack/Rack.git#tag=v0.6.0
- source = git+https://github.com/AndrewBelt/osdialog.git
- source = git+https://github.com/AndrewBelt/oui-blendish.git
- source = git+https://github.com/memononen/nanosvg.git
- source = git+https://github.com/memononen/nanovg.git
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
+ depends = vcvrack
+ depends = libsamplerate
+ source = Fundamental-0.6.0+99+g770e045::git+https://github.com/VCVRack/Fundamental.git#commit=770e045d2a466fd40524d04077f93c80d6c495f8
+ sha512sums = SKIP
pkgname = vcvrack-fundamental
diff --git a/PKGBUILD b/PKGBUILD
index a03d4f141181..c864bbf102d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,56 +1,50 @@
# Maintainer: Miroslav Koškár <http://mkoskar.com/>
+# Contributor: David Runge <dave@sleepmap.de>
-_rackver=0.6.0
-_plugname='Fundamental'
+_name='Fundamental'
+# according to plugin.json, this is already somehow 1.0.1.. but oh well... yolo
+_commit='770e045d2a466fd40524d04077f93c80d6c495f8'
-pkgname='vcvrack-fundamental'
-pkgver=0.6.0
+pkgname=vcvrack-fundamental
+pkgver=0.6.0+99+g770e045
pkgrel=1
pkgdesc='Fundamental VCV modules'
-url='https://github.com/VCVRack/Fundamental'
-license=(BSD)
-arch=(i686 x86_64)
-depends=('vcvrack>=0.6')
-makedepends=(git zip)
-install="$pkgname.install"
+url="https://github.com/VCVRack/Fundamental"
+license=('CCPL' 'BSD')
+arch=('x86_64')
+depends=('vcvrack' 'libsamplerate')
+makedepends=('git' 'jq' 'zip')
+source=("${_name}-${pkgver}::git+https://github.com/VCVRack/$_name.git#commit=${_commit}")
+sha512sums=('SKIP')
-source=(
- "vcvrack-$_plugname::git+https://github.com/VCVRack/$_plugname.git#tag=v$pkgver"
- "vcvrack::git+https://github.com/VCVRack/Rack.git#tag=v$_rackver"
- git+https://github.com/AndrewBelt/osdialog.git
- git+https://github.com/AndrewBelt/oui-blendish.git
- git+https://github.com/memononen/nanosvg.git
- git+https://github.com/memononen/nanovg.git
-)
-sha256sums=(
- SKIP
- SKIP
- SKIP
- SKIP
- SKIP
- SKIP
-)
+pkgver() {
+ cd "${_name}"-"${pkgver}"
+ git describe --tags | sed 's/^v//;s/-/+/g'
+}
prepare() {
- cd vcvrack
- git submodule init
- git config submodule.ext/nanosvg.url "$srcdir/nanosvg"
- git config submodule.ext/nanovg.url "$srcdir/nanovg"
- git config submodule.ext/osdialog.url "$srcdir/osdialog"
- git config submodule.ext/oui-blendish.url "$srcdir/oui-blendish"
- git submodule update
-
- cd plugins
- git clone "$srcdir/vcvrack-$_plugname" "$_plugname"
+ cd "${_name}"-"${pkgver}"
+ # removing static lib stuff
+ sed -e '7,20d' -i Makefile
}
build() {
- cd "vcvrack/plugins/$_plugname"
- FLAGS='-I/opt/vcvrack/include' make dist
+ # define RACK_DIR, so Makefile snippets can be found
+ export RACK_DIR="/usr/share/vcvrack"
+ # define FLAGS, so headers can be included
+ export FLAGS="-I/usr/include/vcvrack -I/usr/include/vcvrack/dep"
+ # exporting LDFLAGS for libsamplerate, as the Delay module requires it
+ export LDFLAGS="$(pkg-config --libs samplerate) ${LDFLAGS}"
+ cd "${_name}"-"${pkgver}"
+ USE_SYSTEM_LIBS=true make
+ USE_SYSTEM_LIBS=true make dist
}
package() {
- cd "vcvrack/plugins/$_plugname"
- install -D -m644 "dist/$_plugname-$pkgver-lin.zip" \
- "$pkgdir/opt/vcvrack/$_plugname.zip"
+ cd "${_name}"-"${pkgver}"
+ install -vDm 644 "dist/${_name}"*".zip" \
+ "${pkgdir}/opt/vcvrack/${_name}.zip"
+ install -vDm 644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -vDm 644 {CHANGELOG,README}.md \
+ -t "${pkgdir}/usr/share/doc/${pkgname}"
}
diff --git a/vcvrack-fundamental.install b/vcvrack-fundamental.install
deleted file mode 100644
index 202201c48614..000000000000
--- a/vcvrack-fundamental.install
+++ /dev/null
@@ -1,15 +0,0 @@
-post_common() {
- cat <<-EOF
- Since VCV Rack 0.6.0 system plugins are no longer supported.
- Copy (or link) /opt/vcvrack/<plugin>.zip to your ~/.Rack/plugins directory
- (it's done automatically for Fundamental upon first launch).
- EOF
-}
-
-post_install() {
- post_common
-}
-
-post_upgrade() {
- post_common
-}