summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLolix2019-07-01 01:00:45 +0200
committerLolix2019-07-01 01:00:45 +0200
commit4165ba323390ec0723af8ea25fff8538b4a3f153 (patch)
treea724b316c9575c3b7d6b7d54611841f56f4c6498
parent8f8100a9fb1de49b3b6e5b9146e185b7fb3a013c (diff)
downloadaur-4165ba323390ec0723af8ea25fff8538b4a3f153.tar.gz
Revision
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD95
2 files changed, 88 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 438e75f4d078..130186a8716b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
pkgbase = vcvrack-git
pkgdesc = Open-source virtual Eurorack DAW
- pkgver = 0.5.0.r2.ga17ae2c
+ pkgver = 1.1.0.r10.g266b63d
pkgrel = 1
url = https://github.com/VCVRack/Rack
arch = i686
arch = x86_64
license = BSD
makedepends = git
+ makedepends = unzip
+ makedepends = wget
+ makedepends = cmake
depends = glew
depends = glfw-x11
depends = jansson
@@ -16,20 +19,42 @@ pkgbase = vcvrack-git
depends = rtmidi
depends = rtaudio
depends = gtk2
+ provides = vcvrack
+ conflicts = vcvrack
source = vcvrack::git+https://github.com/VCVRack/Rack.git
+ source = git+https://github.com/memononen/nanovg.git
+ source = git+https://github.com/memononen/nanosvg.git
source = git+https://github.com/AndrewBelt/osdialog.git
source = git+https://github.com/AndrewBelt/oui-blendish.git
- source = git+https://github.com/mackron/dr_libs.git
- source = git+https://github.com/memononen/nanosvg.git
- source = git+https://github.com/memononen/nanovg.git
+ source = git+https://github.com/thestk/rtaudio.git
+ source = git+https://github.com/AndrewBelt/glfw.git
source = vcvrack.sh
+ source = https://github.com/nigels-com/glew/releases/download/glew-2.1.0/glew-2.1.0.tgz
+ source = http://www.digip.org/jansson/releases/jansson-2.12.tar.gz
+ source = https://vcvrack.com/downloads/dep/speexdsp-SpeexDSP-1.2rc3.tgz
+ source = https://www.openssl.org/source/openssl-1.1.1b.tar.gz
+ source = https://curl.haxx.se/download/curl-7.64.1.tar.gz
+ source = https://libzip.org/download/libzip-1.5.2.tar.gz
+ source = https://www.zlib.net/zlib-1.2.11.tar.gz
+ source = http://www.music.mcgill.ca/~gary/rtmidi/release/rtmidi-4.0.0.tar.gz
+ source = https://bitbucket.org/jpommier/pffft/get/29e4f76ac53b.zip
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 69736bbb5f49f9ce451c1311ec4399f4f59a86056233f151b9457116089a502d
+ sha256sums = c2cb85f3244fc1303646a3961aa0d591238fb81d4978541ef3f974db564aec46
+ sha256sums = 04de91e7e6763039bc11940095cd9c7f880baba82196a7765f727ac05a993c95
+ sha256sums = 5f8dec765048efac5d919aded51b26a32a05397ea207aa769ff6b53c7027d2c9
+ sha256sums = c8dded1454747f65956f981c95e7f89a06abdaa2a53e8aeaa66bab2a3d59cebd
+ sha256sums = 5c557b023230413dfb0756f3137a13e6d726838ccd1430888ad15bfb2b43ea4b
+ sha256sums = 432d3f466644b9416bc5b649d344116a753aeaa520c8beaf024a90cba9d3d35d
+ sha256sums = be694a4abb2ffe5ec02074146757c8b56084dbcebf329123c84b205417435e15
+ sha256sums = c3e5e9fdd5004dcb542feda5ee4f0ff0744628baf8ed2dd5d66f8ca1197cb1a1
+ sha256sums = 370cfe710f43fbeba8d2b8c8bc310f314338c519c2cf2865e2d2737b251526cd
+ sha256sums = bb10afba127904a0c6c553fa445082729b7d72373511bda1b12a5be0e03f318a
pkgname = vcvrack-git
diff --git a/PKGBUILD b/PKGBUILD
index 11855e2eb83b..e9b4ad9a3f51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,66 +1,87 @@
-# Maintainer: Miroslav Koškár <http://mkoskar.com/>
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org>
+# Contributor: Miroslav Koškár
-_basename='vcvrack'
-
-pkgname='vcvrack-git'
-pkgver=0.5.0.r2.ga17ae2c
+pkgname=vcvrack-git
+pkgver=1.1.0.r10.g266b63d
pkgrel=1
-pkgdesc='Open-source virtual Eurorack DAW'
-url='https://github.com/VCVRack/Rack'
+pkgdesc="Open-source virtual Eurorack DAW"
+url="https://github.com/VCVRack/Rack"
license=(BSD)
arch=(i686 x86_64)
depends=(glew glfw-x11 jansson libsamplerate curl libzip rtmidi rtaudio gtk2)
-makedepends=(git)
-
+makedepends=(git unzip wget cmake)
+provides=(vcvrack)
+conflicts=(vcvrack)
source=(
- "$_basename::git+https://github.com/VCVRack/Rack.git"
+ "${pkgname%-git}::git+https://github.com/VCVRack/Rack.git"
+ git+https://github.com/memononen/nanovg.git
+ git+https://github.com/memononen/nanosvg.git
git+https://github.com/AndrewBelt/osdialog.git
git+https://github.com/AndrewBelt/oui-blendish.git
- git+https://github.com/mackron/dr_libs.git
- git+https://github.com/memononen/nanosvg.git
- git+https://github.com/memononen/nanovg.git
+ git+https://github.com/thestk/rtaudio.git
+ git+https://github.com/AndrewBelt/glfw.git
vcvrack.sh
+ https://github.com/nigels-com/glew/releases/download/glew-2.1.0/glew-2.1.0.tgz
+ http://www.digip.org/jansson/releases/jansson-2.12.tar.gz
+ https://vcvrack.com/downloads/dep/speexdsp-SpeexDSP-1.2rc3.tgz
+ https://www.openssl.org/source/openssl-1.1.1b.tar.gz
+ https://curl.haxx.se/download/curl-7.64.1.tar.gz
+ https://libzip.org/download/libzip-1.5.2.tar.gz
+ https://www.zlib.net/zlib-1.2.11.tar.gz
+ http://www.music.mcgill.ca/~gary/rtmidi/release/rtmidi-4.0.0.tar.gz
+ https://bitbucket.org/jpommier/pffft/get/29e4f76ac53b.zip
)
-sha256sums=(
- SKIP
- SKIP
- SKIP
- SKIP
- SKIP
- SKIP
- 69736bbb5f49f9ce451c1311ec4399f4f59a86056233f151b9457116089a502d
-)
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'c2cb85f3244fc1303646a3961aa0d591238fb81d4978541ef3f974db564aec46'
+ '04de91e7e6763039bc11940095cd9c7f880baba82196a7765f727ac05a993c95'
+ '5f8dec765048efac5d919aded51b26a32a05397ea207aa769ff6b53c7027d2c9'
+ 'c8dded1454747f65956f981c95e7f89a06abdaa2a53e8aeaa66bab2a3d59cebd'
+ '5c557b023230413dfb0756f3137a13e6d726838ccd1430888ad15bfb2b43ea4b'
+ '432d3f466644b9416bc5b649d344116a753aeaa520c8beaf024a90cba9d3d35d'
+ 'be694a4abb2ffe5ec02074146757c8b56084dbcebf329123c84b205417435e15'
+ 'c3e5e9fdd5004dcb542feda5ee4f0ff0744628baf8ed2dd5d66f8ca1197cb1a1'
+ '370cfe710f43fbeba8d2b8c8bc310f314338c519c2cf2865e2d2737b251526cd'
+ 'bb10afba127904a0c6c553fa445082729b7d72373511bda1b12a5be0e03f318a')
pkgver() {
- cd "$_basename"
+ cd "${pkgname%-git}"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$_basename"
+ cd "${pkgname%-git}"
git submodule init
- git config submodule.ext/dr_libs.url "$srcdir/dr_libs"
- git config submodule.ext/nanosvg.url "$srcdir/nanosvg"
- git config submodule.ext/nanovg.url "$srcdir/nanovg"
- git config submodule.ext/osdialog.url "$srcdir/osdialog"
- git config submodule.ext/oui-blendish.url "$srcdir/oui-blendish"
+ git config submodule.dep/nanovg.url "$srcdir/nanovg"
+ git config submodule.dep/nanosvg.url "$srcdir/nanosvg"
+ git config submodule.dep/osdialog.url "$srcdir/osdialog"
+ git config submodule.dep/oui-blendish.url "$srcdir/oui-blendish"
+ git config submodule.dep/rtaudio.url "$srcdir/rtaudio"
+ git config submodule.dep/glfw.url "$srcdir/glfw"
git submodule update
+ cp -a ../*.tar.gz dep
+ cp -a ../*.zip dep
}
build() {
- cd "$_basename"
+ cd "${pkgname%-git}"
+ make dep
local tag flags
tag=$(git describe --tags --abbrev=0)
- FLAGS=$(pkg-config --cflags-only-I glew glfw3 jansson samplerate libcurl libzip rtmidi rtaudio gtk+-2.0)
- export FLAGS
+ export FLAGS=$(pkg-config --cflags-only-I glew glfw3 jansson samplerate libcurl libzip rtmidi rtaudio gtk+-2.0)
make VERSION="${tag##v}"
}
package() {
- cd "$_basename"
+ cd "${pkgname%-git}"
install -D -m755 "$srcdir/vcvrack.sh" "$pkgdir/usr/bin/vcvrack"
- install -D -m644 -t "$pkgdir/usr/share/licenses/$_basename" LICENSE*
- install -D -m755 -t "$pkgdir/opt/$_basename" Rack
- install -d "$pkgdir/opt/$_basename/plugins"
- cp -dr --preserve=mode -t "$pkgdir/opt/$_basename" res
+ install -D -m644 -t "$pkgdir/usr/share/licenses/${pkgname%-git}" LICENSE*
+ install -D -m755 -t "$pkgdir/opt/${pkgname%-git}" Rack
+ install -d "$pkgdir/opt/${pkgname%-git}/plugins"
+ cp -dr --preserve=mode -t "$pkgdir/opt/${pkgname%-git}" res
}