summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPopolon2021-12-03 14:05:03 +0100
committerPopolon2021-12-03 14:05:03 +0100
commitd2f56153f511cabc758af04c5fc5306c4bba401c (patch)
tree6f72fec15cd1bb9898faf432c627463716f44bdf
parente6680ee0f4024d68a02d71b845bd289e05074dcf (diff)
downloadaur-d2f56153f511cabc758af04c5fc5306c4bba401c.tar.gz
addapt source, so only need to change _branchname between v1 and v2 to use Rack1 or 2, it is architecture independant
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 12 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e3ac8a4cefd..e89f67ebb20b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,14 @@
pkgbase = vcvrack-git
pkgdesc = Open-source virtual Eurorack DAW
pkgver = 1.1.6.r18.ga5fc5891
- pkgrel = 7
+ pkgrel = 8
url = https://github.com/VCVRack/Rack
arch = i686
arch = x86_64
+ arch = armv7h
+ arch = armv8
+ arch = riscv32
+ arch = riscv64
license = BSD
makedepends = git
makedepends = unzip
@@ -19,6 +23,7 @@ pkgbase = vcvrack-git
depends = rtmidi
depends = rtaudio
depends = gtk2
+ depends = gtk3
depends = jq
provides = vcvrack
conflicts = vcvrack
diff --git a/PKGBUILD b/PKGBUILD
index 4159d78a8e49..c5b8ed52b0f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,12 @@
pkgname=vcvrack-git
_branchname=v1
pkgver=1.1.6.r18.ga5fc5891
-pkgrel=7
+pkgrel=8
pkgdesc="Open-source virtual Eurorack DAW"
url="https://github.com/VCVRack/Rack"
license=(BSD)
-arch=(i686 x86_64)
-depends=(glew glfw-x11 jansson libsamplerate curl libzip rtmidi rtaudio gtk2 jq)
+arch=(i686 x86_64 armv7h armv8 riscv32 riscv64)
+depends=(glew glfw-x11 jansson libsamplerate curl libzip rtmidi rtaudio gtk2 gtk3 jq)
makedepends=(git unzip wget cmake)
provides=(vcvrack)
conflicts=(vcvrack)
@@ -44,6 +44,9 @@ build() {
package() {
cd "${pkgname%-git}"
install -D -m755 "$srcdir/vcvrack.sh" "$pkgdir/usr/bin/vcvrack"
+ if [ ${_branchname} == "v2" ]; then
+ install -D -m644 -t "$pkgdir/usr/lib" "libRack.so"
+ fi
install -D -m644 -t "$pkgdir/usr/share/licenses/${pkgname%-git}" LICENSE*
install -D -m755 -t "$pkgdir/opt/${pkgname%-git}" Rack
install -d "$pkgdir/opt/${pkgname%-git}/plugins"