summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPopolon2021-10-09 09:46:13 +0200
committerPopolon2021-10-09 09:46:13 +0200
commitfa4f2e8465e4f3ae4979f95848b530cf1fe4cba6 (patch)
treef40c74d98903e97717267f7825bbe9ed08308bab
parent64052e23a62cfb0b6205f0053b16b61d91a57ed2 (diff)
downloadaur-fa4f2e8465e4f3ae4979f95848b530cf1fe4cba6.tar.gz
adapt PKGBUILD to new simplified rules
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
2 files changed, 6 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b0f029518bb..a1b265a751a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vcvrack-git
pkgdesc = Open-source virtual Eurorack DAW
pkgver = 1.1.6.r18.ga5fc5891
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/VCVRack/Rack
arch = i686
arch = x86_64
@@ -19,25 +19,10 @@ pkgbase = vcvrack-git
depends = rtmidi
depends = rtaudio
depends = gtk2
+ depends = jq
provides = vcvrack
conflicts = vcvrack
source = vcvrack::git+https://github.com/VCVRack/Rack.git
- source = git+https://github.com/memononen/nanovg.git
- source = git+https://github.com/memononen/nanosvg.git
- source = git+https://github.com/AndrewBelt/osdialog.git
- source = git+https://github.com/AndrewBelt/oui-blendish.git
- source = git+https://github.com/thestk/rtaudio.git
- source = git+https://github.com/AndrewBelt/glfw.git
- source = vcvrack.sh
- source = vcvrack.desktop
sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = 6299d2de5b6c71db5c9e736095bbf141e4f0bc6eb90b4791aa384b3accd59bbd
- sha256sums = a7aa48156543ca6d05def561b6708935d7fd284baff4412716ad7077fb221b6c
pkgname = vcvrack-git
diff --git a/PKGBUILD b/PKGBUILD
index fb414562af49..23302d8b13f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,35 +4,20 @@
pkgname=vcvrack-git
pkgver=1.1.6.r18.ga5fc5891
-pkgrel=5
+pkgrel=6
pkgdesc="Open-source virtual Eurorack DAW"
url="https://github.com/VCVRack/Rack"
license=(BSD)
arch=(i686 x86_64)
-depends=(glew glfw-x11 jansson libsamplerate curl libzip rtmidi rtaudio gtk2)
+depends=(glew glfw-x11 jansson libsamplerate curl libzip rtmidi rtaudio gtk2 jq)
makedepends=(git unzip wget cmake)
provides=(vcvrack)
conflicts=(vcvrack)
source=(
"${pkgname%-git}::git+https://github.com/VCVRack/Rack.git"
- git+https://github.com/memononen/nanovg.git
- git+https://github.com/memononen/nanosvg.git
- git+https://github.com/AndrewBelt/osdialog.git
- git+https://github.com/AndrewBelt/oui-blendish.git
- git+https://github.com/thestk/rtaudio.git
- git+https://github.com/AndrewBelt/glfw.git
- vcvrack.sh
- vcvrack.desktop
)
sha256sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- '6299d2de5b6c71db5c9e736095bbf141e4f0bc6eb90b4791aa384b3accd59bbd'
- 'a7aa48156543ca6d05def561b6708935d7fd284baff4412716ad7077fb221b6c')
+)
pkgver() {
cd "${pkgname%-git}"
@@ -41,16 +26,7 @@ pkgver() {
prepare() {
cd "${pkgname%-git}"
- git submodule init
- git config submodule.dep/nanovg.url "$srcdir/nanovg"
- git config submodule.dep/nanosvg.url "$srcdir/nanosvg"
- git config submodule.dep/osdialog.url "$srcdir/osdialog"
- git config submodule.dep/oui-blendish.url "$srcdir/oui-blendish"
- git config submodule.dep/rtaudio.url "$srcdir/rtaudio"
- git config submodule.dep/glfw.url "$srcdir/glfw"
- git submodule update
- cp -a ../*.tar.gz dep
- #cp -a ../*.zip dep
+ git submodule update --init --recursive
}
build() {