summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPopolon2020-07-13 23:36:25 +0200
committerPopolon2020-07-13 23:36:25 +0200
commitf9e13307265420b02e807c66875feedddbe7bb8b (patch)
treebb1e3c1af950b26e6cf797eb997dd243cd159a9c
parent46004a8d7da3c3ab8e139cc32bf724ab4726d699 (diff)
downloadaur-vcvrack-mental-git.tar.gz
update following previous Miroslav Koškár changes for vcvrack-fundamental, depend on vcvrack instead of vcvrack-git until vcvrack-git is patched
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD55
2 files changed, 21 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9408e8033d37..a58a479583f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,14 @@
pkgbase = vcvrack-mental-git
pkgdesc = Strum's Mental VCV modules
- pkgver = r75.fff7586
+ pkgver = r116.1660a55
pkgrel = 1
url = https://github.com/Strum/Strums_Mental_VCV_Modules
arch = i686
arch = x86_64
license = custom
makedepends = git
- depends = vcvrack-git
+ depends = vcvrack
source = vcvrack-Mental::git+https://github.com/Strum/Strums_Mental_VCV_Modules.git
- source = vcvrack::git+https://github.com/VCVRack/Rack.git
- source = git+https://github.com/AndrewBelt/osdialog.git
- source = git+https://github.com/AndrewBelt/oui-blendish.git
- source = git+https://github.com/mackron/dr_libs.git
- source = git+https://github.com/memononen/nanosvg.git
- source = git+https://github.com/memononen/nanovg.git
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
sha256sums = SKIP
pkgname = vcvrack-mental-git
diff --git a/PKGBUILD b/PKGBUILD
index 6201e35fad35..0fb82fbfea29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,24 @@
-# Maintainer: Miroslav Koškár <http://mkoskar.com/>
+# Maintainer: Popolon <popolon@popolon.org>
+# Contributor: Miroslav Koškár <http://mkoskar.com/>
_basename='vcvrack'
_plugname='Mental'
pkgname='vcvrack-mental-git'
-pkgver=r75.fff7586
+pkgver=r116.1660a55
pkgrel=1
pkgdesc="Strum's Mental VCV modules"
url='https://github.com/Strum/Strums_Mental_VCV_Modules'
license=(custom)
arch=(i686 x86_64)
-depends=(vcvrack-git)
+depends=(vcvrack)
makedepends=(git)
source=(
"$_basename-$_plugname::git+https://github.com/Strum/Strums_Mental_VCV_Modules.git"
- "$_basename::git+https://github.com/VCVRack/Rack.git"
- git+https://github.com/AndrewBelt/osdialog.git
- git+https://github.com/AndrewBelt/oui-blendish.git
- git+https://github.com/mackron/dr_libs.git
- git+https://github.com/memononen/nanosvg.git
- git+https://github.com/memononen/nanovg.git
)
sha256sums=(
SKIP
- SKIP
- SKIP
- SKIP
- SKIP
- SKIP
- SKIP
)
pkgver() {
@@ -38,29 +27,23 @@ pkgver() {
"$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "$_basename"
- git submodule init
- git config submodule.ext/dr_libs.url "$srcdir/dr_libs"
- git config submodule.ext/nanosvg.url "$srcdir/nanosvg"
- git config submodule.ext/nanovg.url "$srcdir/nanovg"
- git config submodule.ext/osdialog.url "$srcdir/osdialog"
- git config submodule.ext/oui-blendish.url "$srcdir/oui-blendish"
- git submodule update
-
- cd plugins
- git clone "$srcdir/$_basename-$_plugname" "$_plugname"
-}
-
build() {
- cd "$_basename/plugins/$_plugname"
- make
+ # define RACK_DIR, so Makefile snippets can be found
+ export RACK_DIR="/usr/share/vcvrack"
+ # define FLAGS, so headers can be included
+ export FLAGS="-I/usr/include/vcvrack -I/usr/include/vcvrack/dep"
+ # exporting LDFLAGS for libsamplerate, as the Delay module requires it
+ export LDFLAGS="$(pkg-config --libs samplerate) ${LDFLAGS}"
+ cd "${_basename}-${_plugname}"
+ USE_SYSTEM_LIBS=true make
+ USE_SYSTEM_LIBS=true make dist
}
package() {
- cd "$_basename/plugins/$_plugname"
- #install -D -m644 -t "$pkgdir/usr/share/licenses/$_basename/$_plugname" LICENSE*
- install -d "$pkgdir/opt/$_basename/plugins/$_plugname"
- cp -dr --preserve=mode -t "$pkgdir/opt/$_basename/plugins/$_plugname" \
- res plugin.so
+ cd "${_basename}-${_plugname}"
+ install -vDm 644 "dist/${_plugname}"*".zip" \
+ "${pkgdir}/opt/vcvrack/${_plugname}.zip"
+ install -vDm 644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -vDm 644 {CHANGELOG,README}.md \
+ -t "${pkgdir}/usr/share/doc/${pkgname}"
}