summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSonus Dept2017-10-12 13:40:38 +0200
committerSonus Dept2017-10-12 13:40:38 +0200
commit48d097446d66c5ea86dd27d3117e3e02d9992e31 (patch)
tree9bebedd60620d94986f221e357042cda74ba1441
downloadaur-48d097446d66c5ea86dd27d3117e3e02d9992e31.tar.gz
First commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD66
2 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..882c6972e4c8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = vcvrack-sonusmodular-git
+ pkgdesc = Sonus Dept. VCV modules
+ pkgver = r87.5085c86
+ pkgrel = 1
+ url = https://sonusmodular.sonusdept.com
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = vcvrack-git
+ source = vcvrack-sonusmodular::git+https://gitlab.com/sonusdept/sonusmodular.git
+ source = vcvrack::git+https://github.com/VCVRack/Rack.git
+ source = git+https://github.com/AndrewBelt/osdialog.git
+ source = git+https://github.com/AndrewBelt/oui-blendish.git
+ source = git+https://github.com/mackron/dr_libs.git
+ source = git+https://github.com/memononen/nanosvg.git
+ source = git+https://github.com/memononen/nanovg.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = vcvrack-sonusmodular-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed15b66876d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Maintainer: Valerio Orlandini <http://www.sonusdept.com>
+
+_basename='vcvrack'
+_plugname='sonusmodular'
+
+pkgname='vcvrack-sonusmodular-git'
+pkgver=r87.5085c86
+pkgrel=1
+pkgdesc="Sonus Dept. VCV modules"
+url='https://sonusmodular.sonusdept.com'
+license=(GPL3)
+arch=(i686 x86_64)
+depends=(vcvrack-git)
+makedepends=(git)
+
+source=(
+ "$_basename-$_plugname::git+https://gitlab.com/sonusdept/$_plugname.git"
+ "$_basename::git+https://github.com/VCVRack/Rack.git"
+ git+https://github.com/AndrewBelt/osdialog.git
+ git+https://github.com/AndrewBelt/oui-blendish.git
+ git+https://github.com/mackron/dr_libs.git
+ git+https://github.com/memononen/nanosvg.git
+ git+https://github.com/memononen/nanovg.git
+)
+sha256sums=(
+ SKIP
+ SKIP
+ SKIP
+ SKIP
+ SKIP
+ SKIP
+ SKIP
+)
+
+pkgver() {
+ cd "$_basename-$_plugname"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$_basename"
+ git submodule init
+ git config submodule.ext/dr_libs.url "$srcdir/dr_libs"
+ git config submodule.ext/nanosvg.url "$srcdir/nanosvg"
+ git config submodule.ext/nanovg.url "$srcdir/nanovg"
+ git config submodule.ext/osdialog.url "$srcdir/osdialog"
+ git config submodule.ext/oui-blendish.url "$srcdir/oui-blendish"
+ git submodule update
+
+ cd plugins
+ git clone "$srcdir/$_basename-$_plugname" "$_plugname"
+}
+
+build() {
+ cd "$_basename/plugins/$_plugname"
+ make
+}
+
+package() {
+ cd "$_basename/plugins/$_plugname"
+ install -D -m644 -t "$pkgdir/usr/share/licenses/$_basename/$_plugname" LICENSE*
+ install -d "$pkgdir/opt/$_basename/plugins/$_plugname"
+ cp -dr --preserve=mode -t "$pkgdir/opt/$_basename/plugins/$_plugname" \
+ res plugin.so
+} \ No newline at end of file