summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergej Pupykin2015-06-13 00:48:32 +0300
committerSergej Pupykin2015-06-13 00:48:32 +0300
commit71bbe457f777223776589df51fd7da1c64ba5a80 (patch)
tree831b404c032dd0f4e7e247eff648bf8cf910b3b1
downloadaur-71bbe457f777223776589df51fd7da1c64ba5a80.tar.gz
migrate to aur4
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD30
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..54a17f4bc25a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = vde2-static
+ pkgdesc = Virtual Distributed Ethernet for emulators like qemu
+ pkgver = 2.3.2
+ pkgrel = 5
+ url = http://sourceforge.net/projects/vde/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ license = CUSTOM
+ makedepends = python
+ depends = bash
+ depends = libpcap
+ depends = openssl
+ options = !makeflags
+ options = staticlibs
+ options = !emptydirs
+ source = http://downloads.sourceforge.net/vde/vde2-2.3.2.tar.bz2
+ md5sums = 46fbc5f97f03dc517aa3b2c9d9ea6628
+
+pkgname = vde2-static
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86a51abe0db5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id: PKGBUILD 198476 2013-10-30 15:05:50Z allan $
+# Contributor: Sergej Pupykin
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+
+pkgname=vde2-static
+pkgver=2.3.2
+pkgrel=5
+pkgdesc="Virtual Distributed Ethernet for emulators like qemu"
+url="http://sourceforge.net/projects/vde/"
+license=("GPL" "LGPL" "CUSTOM")
+arch=('i686' 'x86_64')
+depends=('bash' 'libpcap' 'openssl')
+makedepends=('python')
+options=(!makeflags 'staticlibs' '!emptydirs')
+source=(http://downloads.sourceforge.net/vde/vde2-$pkgver.tar.bz2)
+md5sums=('46fbc5f97f03dc517aa3b2c9d9ea6628')
+
+build() {
+ cd $srcdir/vde2-$pkgver
+ ./configure --prefix=/usr --sbindir=/usr/bin --sysconfdir=/etc --libexecdir=/usr/lib/vde2 \
+ --enable-experimental
+ make
+}
+
+package() {
+ cd $srcdir/vde2-$pkgver
+ make prefix=$pkgdir/usr sysconfdir=$pkgdir/etc sbindir=$pkgdir/usr/bin libexecdir=$pkgdir/usr/lib/vde2 install
+ install -D -m 644 COPYING.slirpvde $pkgdir/usr/share/licenses/$pkgname/COPYING.slirpvde
+ find $pkgdir -type f -or -type l | grep -vE '.a$' | while read a; do rm -f $a; done
+}