summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGFdevelop2018-03-26 23:52:49 +0200
committerGFdevelop2018-03-26 23:52:49 +0200
commite83e0a93084c3ac5234a4d45adb7e31190e094e5 (patch)
tree22360adaf716fe96d5c4a3c1d7804696630b9699
downloadaur-e83e0a93084c3ac5234a4d45adb7e31190e094e5.tar.gz
first push
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7123f4299c90
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vdeplug4-git
+ pkgdesc = VDE: Virtual Distributed Ethernet. Plug your VM directly to the cloud
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/rd235/vdeplug4
+ arch = any
+ groups = view-os
+ license = GPL2
+ depends = libs2argv-execs-git
+ provides = vdeplug4
+ conflicts = vdeplug4
+ replaces = vdeplug4
+ source = git+https://github.com/rd235/vdeplug4.git
+ md5sums = SKIP
+
+pkgname = vdeplug4-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6bfabe2ae71
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Gabriele Fulgaro <gabriele.fulgaro@gmail.com>
+
+_pkgname="vdeplug4"
+
+pkgname="$_pkgname-git"
+pkgver=0.1
+pkgrel=1
+pkgdesc="VDE: Virtual Distributed Ethernet. Plug your VM directly to the cloud"
+arch=(any)
+url="https://github.com/rd235/vdeplug4"
+license=('GPL2')
+groups=('view-os')
+depends=('libs2argv-execs-git')
+#makedepends=()
+#optdepends=()
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+replaces=("$_pkgname")
+#backup=()
+#options=()
+#install=
+#changelog=
+source=("git+https://github.com/rd235/$_pkgname.git")
+#noextract=()
+md5sums=('SKIP')
+
+build() {
+ cd "$_pkgname"
+
+ autoreconf -i
+ ./configure --prefix="/usr"
+ make
+}
+
+package() {
+ cd "$_pkgname"
+
+ make DESTDIR="$pkgdir/" install
+}