summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGFdevelop2019-03-13 22:03:37 +0100
committerGFdevelop2019-03-13 22:03:37 +0100
commit5a68da55666563e5e649f4d995f242ea26c236d9 (patch)
tree411d52a16528705a55d6803df7543f66251167d6
downloadaur-5a68da55666563e5e649f4d995f242ea26c236d9.tar.gz
First commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..647c2b574bc4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vdeplug_vlan-git
+ pkgdesc = 802.1q (vlan) support nested plugin for vdeplug4
+ pkgver = r3.37f5795
+ pkgrel = 1
+ url = https://github.com/rd235/vdeplug_vlan
+ arch = any
+ license = GPL2
+ depends = vdeplug4-git
+ provides = vdeplug_vlan
+ conflicts = vdeplug_vlan
+ source = git+https://github.com/rd235/vdeplug_vlan.git
+ md5sums = SKIP
+
+pkgname = vdeplug_vlan-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..30837b5987b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Gabriele Fulgaro <gabriele.fulgaro@gmail.com>
+
+_pkgname="vdeplug_vlan"
+
+pkgname="$_pkgname-git"
+pkgver=r3.37f5795
+pkgrel=1
+pkgdesc="802.1q (vlan) support nested plugin for vdeplug4"
+arch=('any')
+url="https://github.com/rd235/$_pkgname"
+license=('GPL2')
+depends=('vdeplug4-git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+$url.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+ autoreconf -if
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir/" install
+}