summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Ray Mahardhika2018-06-28 13:38:06 +0700
committerMario Ray Mahardhika2018-06-28 13:41:29 +0700
commit19f0f71413b557d4ee1b6627f4b910c4206d3ab5 (patch)
tree35020bde65cc4a953e1b97648fe7b48668e2dba5
downloadaur-19f0f71413b557d4ee1b6627f4b910c4206d3ab5.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD31
-rw-r--r--vdhcoapp-install.hook10
-rw-r--r--vdhcoapp-remove.hook9
5 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8eff3ee9b398
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Thu Jun 28 06:39:24 UTC 2018
+pkgbase = vdhcoapp-bin
+ pkgdesc = Companion application for Video DownloadHelper browser add-on, precompiled binary version
+ pkgver = 1.2.3
+ pkgrel = 1
+ url = https://github.com/mi-g/vdhcoapp
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = ffmpeg
+ depends = orc
+ options = !strip
+ source = https://github.com/mi-g/vdhcoapp-bin/releases/download/v1.2.3/net.downloadhelper.coapp-1.2.3-1_amd64.deb
+ source = vdhcoapp-install.hook
+ source = vdhcoapp-remove.hook
+ sha256sums = 6fb56491aed5a60643cbfccba2b03c82372b48bffb463e53bdd19a6075453a47
+ sha256sums = 9f8cbe84b2543738390b70d770551259c6db2b67235b7792e9094908cecbc955
+ sha256sums = 448ee36b350b6bcd304d33cf7638c13bda88d5086f2256e823d73ccc22e52ce0
+
+pkgname = vdhcoapp-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..487ee0170074
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+/pkg/*
+/src/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..feb77f849182
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Mario Ray MahardhikZza <leledumbo_cool@yahoo.co.id>
+
+pkgname=vdhcoapp-bin
+pkgver=1.2.3
+pkgrel=1
+pkgdesc="Companion application for Video DownloadHelper browser add-on, precompiled binary version"
+arch=('i686' 'x86_64')
+url="https://github.com/mi-g/vdhcoapp"
+license=('GPL2')
+depends=('ffmpeg' 'orc')
+makedepends=()
+options=('!strip') # IMPORTANT! DO NOT REMOVE THIS, OTHERWISE THE BINARY WILL BE BROKEN!
+source=(https://github.com/mi-g/${pkgname}/releases/download/v${pkgver}/net.downloadhelper.coapp-${pkgver}-${pkgrel}_amd64.deb
+ vdhcoapp-install.hook
+ vdhcoapp-remove.hook)
+sha256sums=('6fb56491aed5a60643cbfccba2b03c82372b48bffb463e53bdd19a6075453a47'
+ 'a2b56e6ae3f7f8933e20762baa90e69f63f0802b2e6d213b51e0bc68843e5d27'
+ '3287859986d67e15e269965676bf9c75d1e853ea0ec97695811072fb8f10a7a8')
+
+prepare() {
+ rm control.tar.gz
+ rm debian-binary
+ mkdir -p ${srcdir}/${pkgname}
+ tar xf data.tar.gz -C ${pkgname}
+}
+
+package() {
+ cp -Rfp ${srcdir}/${pkgname}/* ${pkgdir}/
+ mkdir -p ${srcdir}/${pkgname}/usr/bin
+ ln -s /opt/net.downloadhelper.coapp/bin/net.downloadhelper.coapp-linux-64 ${pkgdir}/usr/bin/vdhcoapp
+}
diff --git a/vdhcoapp-install.hook b/vdhcoapp-install.hook
new file mode 100644
index 000000000000..b6086347fb1e
--- /dev/null
+++ b/vdhcoapp-install.hook
@@ -0,0 +1,10 @@
+[Trigger]
+Operation = Install
+Operation = Upgrade
+Type = Package
+Target = vdhcoapp-bin
+
+[Action]
+Description = Installing JSON configuration file ...
+When = PostTransaction
+Exec = /usr/bin/vdhcoapp install --system
diff --git a/vdhcoapp-remove.hook b/vdhcoapp-remove.hook
new file mode 100644
index 000000000000..ddf2690b1be1
--- /dev/null
+++ b/vdhcoapp-remove.hook
@@ -0,0 +1,9 @@
+[Trigger]
+Operation = Remove
+Type = Package
+Target = vdhcoapp-bin
+
+[Action]
+Description = Uninstalling JSON configuration file ...
+When = PreTransaction
+Exec = /usr/bin/vdhcoapp uninstall --system