summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaik Broemme2021-03-18 21:35:57 +0100
committerMaik Broemme2021-03-18 21:35:57 +0100
commit203429ed7f9d2e721a8af00469cc167374e9abe3 (patch)
treedea1350763651239581c9ef8339efde0c0d5c896
downloadaur-203429ed7f9d2e721a8af00469cc167374e9abe3.tar.gz
Initial checkin
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..518045dba50e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vdi-stream-client
+ pkgdesc = A tiny and low latency desktop streaming client for remote Windows guests with GPU passthrough
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://libmpq.org/
+ arch = x86_64
+ license = GPL
+ depends = sdl2
+ depends = sdl2_ttf
+ depends = usbredir
+ source = https://github.com/mbroemme/vdi-stream-client/releases/download/v0.1.0/vdi-stream-client-0.1.0.tar.gz
+ source = https://github.com/parsec-cloud/parsec-sdk/archive/5.0.tar.gz
+ sha256sums = 693a8a644e0146b5b392ad2bd7f9503ffc0b9a7a5e98dedef392262b216a763f
+ sha256sums = d0b3f46f5b67830f6e38d7417e92ed8bf34d2e8d7508fa796454a0214cdb7452
+
+pkgname = vdi-stream-client
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b3815a2d0f9a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Maik Broemme <mbroemme@libmpq.org>
+pkgname="vdi-stream-client"
+pkgdesc="A tiny and low latency desktop streaming client for remote Windows guests with GPU passthrough"
+pkgver="0.1.0"
+pkgrel="1"
+arch=("x86_64")
+url="https://libmpq.org/"
+license=("GPL")
+depends=("sdl2" "sdl2_ttf" "usbredir")
+source=(
+ "https://github.com/mbroemme/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz"
+ "https://github.com/parsec-cloud/parsec-sdk/archive/5.0.tar.gz"
+)
+sha256sums=(
+ "693a8a644e0146b5b392ad2bd7f9503ffc0b9a7a5e98dedef392262b216a763f"
+ "d0b3f46f5b67830f6e38d7417e92ed8bf34d2e8d7508fa796454a0214cdb7452"
+)
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ mv ../parsec-sdk-5.0 parsec-sdk
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}