summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Pehla2024-05-18 04:38:12 +0200
committerFelix Pehla2024-05-18 04:38:12 +0200
commitb80ced4b2b61b252ceb21a6275302a54ecd991d5 (patch)
tree834d0f32b32a920e8a13750e62b89f93535e2435
parent2d58bdc9f13ea6c3c6603a3d6d1518123fe46549 (diff)
downloadaur-b80ced4b2b61b252ceb21a6275302a54ecd991d5.tar.gz
Updated PKGBUILD for v8.3.0.70 and linux-6.9
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD23
2 files changed, 13 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6589fc3638d..bdddcc2dc7e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,12 @@
pkgbase = vdo
pkgdesc = Userspace tools for managing VDO volumes
- pkgver = 8.2.2.2
+ pkgver = 8.3.0.70
pkgrel = 1
url = https://github.com/dm-vdo/vdo
arch = x86_64
- license = GPL2
- depends = kvdo-dkms
- depends = python-yaml
+ license = GPL-2.0-or-later
depends = device-mapper
- source = vdo-8.2.2.2.tar.gz::https://github.com/dm-vdo/vdo/archive/8.2.2.2.tar.gz
- sha256sums = 54957556d41f203aa1c9f381762b64695a8fb18c29375f428a4dcf3b1963b7e7
+ source = vdo-8.3.0.70.tar.gz::https://github.com/dm-vdo/vdo/archive/8.3.0.70.tar.gz
+ sha256sums = 7e920e30c487dcc858bcf565a1edcf6bc157376eee5f5bcd463346e46e7ead94
pkgname = vdo
diff --git a/PKGBUILD b/PKGBUILD
index 521fc41d3c95..b5487454f8cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,26 @@
-# Maintainer: zapp-brannigan (fuerst.reinje@web.de)
-# jgottula
+# Maintainer: Felix Pehla <29adc1fd92@gmail.com>
+# Contributor: zapp-brannigan <fuerst.reinje@web.de>
+# Contributor: jgottula <justin@jgottula.com>
pkgname=vdo
+pkgver=8.3.0.70
pkgrel=1
-pkgver=8.2.2.2
pkgdesc='Userspace tools for managing VDO volumes'
arch=('x86_64')
url="https://github.com/dm-vdo/vdo"
-license=('GPL2')
-depends=('kvdo-dkms' 'python-yaml' 'device-mapper')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/dm-vdo/vdo/archive/$pkgver.tar.gz")
-sha256sums=('54957556d41f203aa1c9f381762b64695a8fb18c29375f428a4dcf3b1963b7e7')
+license=('GPL-2.0-or-later')
+depends=('device-mapper')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/dm-vdo/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=('7e920e30c487dcc858bcf565a1edcf6bc157376eee5f5bcd463346e46e7ead94')
build() {
cd "$pkgname-$pkgver"
- make
+ make EXTRA_LDFLAGS="-z relro -z now"
}
package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" \
- unitdir=/usr/lib/systemd/system \
- presetdir=/usr/lib/systemd/system-preset \
mandir=/usr/share/man \
install
- cd $pkgdir
- mkdir -p usr/share/bash-completion/completions
- mv bash_completion.d/* usr/share/bash-completion/completions/
- rmdir bash_completion.d
}