summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzapp-brannigan2020-04-10 15:45:54 +0200
committerzapp-brannigan2020-04-10 15:45:54 +0200
commit5bbe0b42571ac38c5894435003c36481cdc38eb1 (patch)
treed189c39d9a735974f8537dc45f26637ca4ee9015
downloadaur-5bbe0b42571ac38c5894435003c36481cdc38eb1.tar.gz
add vdoestimator to the aur
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..47ccc451949b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = vdoestimator-git
+ pkgdesc = Estimate space savings from dm-vdo virtual device
+ pkgver = r23.a33ce60
+ pkgrel = 1
+ url = https://github.com/dm-vdo/vdoestimator
+ arch = x86_64
+ license = GPL-2.0
+ makedepends = git
+ source = git+https://github.com/dm-vdo/vdoestimator.git
+ md5sums = SKIP
+
+pkgname = vdoestimator-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a84218c09283
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: zapp-brannigan <fuerst.reinje@web.de>
+
+_pkgname=vdoestimator
+pkgname="$_pkgname"-git
+pkgver=r23.a33ce60
+pkgrel=1
+pkgdesc="Estimate space savings from dm-vdo virtual device "
+url="https://github.com/dm-vdo/vdoestimator"
+license=('GPL-2.0')
+arch=(x86_64)
+makedepends=('git')
+source=("git+$url.git")
+md5sums=('SKIP')
+
+pkgver() {
+cd "$_pkgname"
+printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+cd $srcdir/$_pkgname
+make lz4
+make uds
+make vdoestimator
+}
+package() {
+mkdir -p $pkgdir/usr/bin
+install -o root -g root -m 0755 $srcdir/$_pkgname/vdoestimator $pkgdir/usr/bin
+}