summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Reimer2015-06-08 11:00:36 +0200
committerChristopher Reimer2015-06-08 11:00:36 +0200
commitf346abd882c69beada72ae869da85430ef0d9110 (patch)
treed4f9b7f76b4a11652084483fc60cc0b0e699075c
downloadaur-f346abd882c69beada72ae869da85430ef0d9110.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/3bf8a4492e3b973a559fd2c53855b231e25c7e74)
-rw-r--r--.SRCINFO26
-rw-r--r--50-autostart.conf3
-rw-r--r--PKGBUILD43
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec6cd79933db
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = vdr-autostart
+ pkgdesc = Automatic start of other plug-ins on change or insertion of removable devices
+ pkgver = 0.9.6
+ pkgrel = 7
+ url = http://www.uli-eckhardt.de/vdr/autostart.en.shtml
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = GPL2
+ depends = libcdio
+ depends = libdbus
+ depends = libdvdread
+ depends = vdr-api=2.2.0
+ backup = etc/vdr/conf.avail/50-autostart.conf
+ backup = var/lib/vdr/plugins/autostart/autostart.conf
+ source = http://www.uli-eckhardt.de/vdr/download/vdr-autostart-0.9.6.tgz
+ source = autostart-improve_libcdio.diff::http://hg.uli-eckhardt.de/autostart/raw-rev/51e4428d565d
+ source = 50-autostart.conf
+ md5sums = 7d833142939d21a3edae907f9fa0b55b
+ md5sums = 826139f5212b9ee465f2233ad084e137
+ md5sums = bfac43507495484a347bf5ab6c158651
+
+pkgname = vdr-autostart
+
diff --git a/50-autostart.conf b/50-autostart.conf
new file mode 100644
index 000000000000..ddfe7f3fff6e
--- /dev/null
+++ b/50-autostart.conf
@@ -0,0 +1,3 @@
+[autostart]
+#--configdir=<directory>
+# Directory for config files
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f1773317b68
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
+pkgname=vdr-autostart
+pkgver=0.9.6
+_vdrapi=2.2.0
+pkgrel=7
+pkgdesc="Automatic start of other plug-ins on change or insertion of removable devices"
+url="http://www.uli-eckhardt.de/vdr/autostart.en.shtml"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('GPL2')
+depends=('libcdio' 'libdbus' 'libdvdread' "vdr-api=${_vdrapi}")
+_plugname=$(echo $pkgname | sed 's/vdr-//g')
+backup=("var/lib/vdr/plugins/$_plugname/cd.mpg")
+source=("http://www.uli-eckhardt.de/vdr/download/${pkgname}-${pkgver}.tgz"
+ "autostart-improve_libcdio.diff::http://hg.uli-eckhardt.de/autostart/raw-rev/51e4428d565d"
+ "50-$_plugname.conf")
+backup=("etc/vdr/conf.avail/50-$_plugname.conf"
+ "var/lib/vdr/plugins/$_plugname/$_plugname.conf")
+md5sums=('7d833142939d21a3edae907f9fa0b55b'
+ '826139f5212b9ee465f2233ad084e137'
+ 'bfac43507495484a347bf5ab6c158651')
+
+prepare() {
+ cd "${srcdir}/${_plugname}-${pkgver}"
+ patch -p1 -i "$srcdir/autostart-improve_libcdio.diff"
+ sed -i 's/$(DESTDIR)//g' Makefile.inc
+}
+
+build() {
+ cd "${srcdir}/${_plugname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${_plugname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 contrib/$_plugname.conf "$pkgdir/var/lib/vdr/plugins/$_plugname/$_plugname.conf"
+ install -Dm644 "$srcdir/50-$_plugname.conf" "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+
+ chown -R 666:666 "$pkgdir/var/lib/vdr"
+}