summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Reimer2015-06-08 11:08:45 +0200
committerChristopher Reimer2015-06-08 11:08:45 +0200
commit18820986e10a8c503a44717ff01f4bfc226ffb10 (patch)
treee12872066e321692de63e4c6ba0f49d99dcbf64e
downloadaur-18820986e10a8c503a44717ff01f4bfc226ffb10.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/3bf8a4492e3b973a559fd2c53855b231e25c7e74)
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD43
-rw-r--r--bgprocess-osditem-fix.diff13
-rw-r--r--bgprocess-tlphrases-fix.diff28
4 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a8222413e14
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = vdr-bgprocess
+ pkgdesc = Displays information about background processes
+ pkgver = 0.1.0
+ pkgrel = 20
+ url = http://projects.vdr-developer.org/projects/plg-undelete
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = GPL2
+ depends = gcc-libs
+ depends = vdr-api=2.2.0
+ backup = etc/vdr/conf.avail/50-bgprocess.conf
+ source = http://ftp.uni-kl.de/pub/linux/gentoo/distfiles/vdr-bgprocess-0.1.0.tgz
+ source = bgprocess-tlphrases-fix.diff
+ source = bgprocess-osditem-fix.diff
+ md5sums = 46bc8626cf843110eedef74d2dc27c3d
+ md5sums = d2f7efb1ab40727298d4d17e1b07e37c
+ md5sums = 1556e199ab90264a1f45838abbef0243
+
+pkgname = vdr-bgprocess
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de0b62c446ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
+pkgname=vdr-bgprocess
+pkgver=0.1.0
+_vdrapi=2.2.0
+pkgrel=20
+pkgdesc="Displays information about background processes"
+url="http://projects.vdr-developer.org/projects/plg-undelete"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('GPL2')
+depends=('gcc-libs' "vdr-api=${_vdrapi}")
+_plugname=$(echo $pkgname | sed 's/vdr-//g')
+source=("http://ftp.uni-kl.de/pub/linux/gentoo/distfiles/$pkgname-$pkgver.tgz"
+ 'bgprocess-tlphrases-fix.diff'
+ 'bgprocess-osditem-fix.diff')
+backup=("etc/vdr/conf.avail/50-$_plugname.conf")
+md5sums=('46bc8626cf843110eedef74d2dc27c3d'
+ 'd2f7efb1ab40727298d4d17e1b07e37c'
+ '1556e199ab90264a1f45838abbef0243')
+
+prepare() {
+ cd "${srcdir}/${_plugname}-${pkgver}"
+
+ patch -p1 -i ${srcdir}/bgprocess-tlphrases-fix.diff #By Holger Schvestka (yaVDR)
+ patch -p1 -i ${srcdir}/bgprocess-osditem-fix.diff #By Holger Schestka (yaVDR)
+}
+
+package() {
+ cd "${srcdir}/${_plugname}-${pkgver}"
+
+ mkdir -p "$pkgdir/usr/lib/vdr/plugins"
+ make CFLAGS="$(pkg-config vdr --variable=cflags)" \
+ CXXFLAGS="$(pkg-config vdr --variable=cxxflags)" \
+ VDRDIR="/usr/include/vdr" \
+ LIBDIR="$pkgdir/$(pkg-config vdr --variable=libdir)" \
+ LOCALEDIR="$pkgdir/$(pkg-config vdr --variable=locdir)" \
+ VDRLOCALE=1 \
+ all
+
+ mkdir -p "$pkgdir/etc/vdr/conf.avail"
+ echo "[$_plugname]" > "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+}
diff --git a/bgprocess-osditem-fix.diff b/bgprocess-osditem-fix.diff
new file mode 100644
index 000000000000..56b91f7cde92
--- /dev/null
+++ b/bgprocess-osditem-fix.diff
@@ -0,0 +1,13 @@
+diff --git a/bgprocess.c b/bgprocess.c
+index 69206bb..eff2a10 100644
+--- a/bgprocess.c
++++ b/bgprocess.c
+@@ -330,7 +330,7 @@ void BgProcessMenu::ShowBgProcesses()
+ Clear();
+ if (iter == bgProcessList.end() && CompletedList.size()==0)
+ {
+- Add(new cOsdItem(" "),osUnknown,false);
++ Add(new cOsdItem(" ",osUnknown,false));
+ Add(new cOsdItem(tr(" No background process running"),osUnknown,false));
+ }
+ for (; iter != bgProcessList.end(); iter++)
diff --git a/bgprocess-tlphrases-fix.diff b/bgprocess-tlphrases-fix.diff
new file mode 100644
index 000000000000..01e5cc7f124a
--- /dev/null
+++ b/bgprocess-tlphrases-fix.diff
@@ -0,0 +1,28 @@
+diff --git a/bgprocess.c b/bgprocess.c
+index 69206bb..126c09e 100644
+--- a/bgprocess.c
++++ b/bgprocess.c
+@@ -152,7 +152,9 @@ bool cPluginBgprocess::ProcessArgs(int argc, char *argv[])
+ bool cPluginBgprocess::Initialize(void)
+ {
+ // Initialize any background activities the plugin shall perform.
+- RegisterI18n(tlPhrases);
++#if VDRVERSNUM < 10507
++RegisterI18n(tlPhrases);
++#endif
+ return true;
+ }
+
+diff --git a/i18n.h b/i18n.h
+index ee84e4c..c625a5e 100644
+--- a/i18n.h
++++ b/i18n.h
+@@ -13,6 +13,8 @@
+ #include <vdr/i18n.h>
+ #include <vdr/config.h> // for VDRVERSNUM define only
+
++#if VDRVERSNUM < 10507
+ extern const tI18nPhrase tlPhrases[];
++#endif
+
+ #endif //_I18N__H