summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Reimer2017-09-08 00:05:07 +0200
committerChristopher Reimer2017-09-08 00:05:07 +0200
commitbc503c07ac147dc55dfed024546d349bc0c2224d (patch)
tree5b4cd4bf694a4cb67f7c92b4e0f3403b19b4ec2b
downloadaur-bc503c07ac147dc55dfed024546d349bc0c2224d.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/d6ca7c75eb1614a74d7ec4460fe5d0cce20031ca)
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD36
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..53b1d17d4946
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by makepkg 5.0.2
+# Thu Sep 7 22:05:06 UTC 2017
+pkgbase = vdr-channelscan
+ pkgdesc = Channel scanner for VDR
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://www.forum.free-x.de/wbb/index.php?page=Thread&threadID=1745
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = bzip2
+ depends = vdr-api=2.2.0
+ depends = zlib
+ backup = etc/vdr/conf.avail/50-channelscan.conf
+ source = git+https://bitbucket.org/ua0lnj/channelscan.git#tag=1.0.0
+ md5sums = SKIP
+
+pkgname = vdr-channelscan
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4a5c424d0cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
+# Contributor: Yarema aka Knedlyk <yupadmin at gmail dot com>
+pkgname=vdr-channelscan
+pkgver=1.0.0
+_vdrapi=2.2.0
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc="Channel scanner for VDR"
+url="http://www.forum.free-x.de/wbb/index.php?page=Thread&threadID=1745"
+license=("GPL2")
+depends=('bzip2' "vdr-api=${_vdrapi}" 'zlib')
+makedepends=('git')
+_plugname=${pkgname//vdr-/}
+source=("git+https://bitbucket.org/ua0lnj/channelscan.git#tag=$pkgver")
+backup=("etc/vdr/conf.avail/50-$_plugname.conf")
+md5sums=('SKIP')
+
+prepare() {
+ cd "${srcdir}/${_plugname}"
+ sed -i '/VDRDIR =/d' Makefile
+}
+
+build() {
+ cd "${srcdir}/${_plugname}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${_plugname}"
+ make DESTDIR="${pkgdir}" install
+
+ mkdir -p "$pkgdir/etc/vdr/conf.avail"
+ echo "[$_plugname]" > "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+}