summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Reimer2022-03-14 19:05:05 +0100
committerManuel Reimer2022-03-14 19:05:05 +0100
commit304a2b87a5ac79ce7d7dd554fdd932a0385241fc (patch)
tree4176204940c1ce1de4cdfd66a14c65a76c271e2f
parent9ec42f2739a2fe10437276da71cdd284619d656e (diff)
downloadaur-304a2b87a5ac79ce7d7dd554fdd932a0385241fc.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/bfa8ead970a73d904bde7b2aa60433c4d675eb5f)
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 14 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68a62aa03a8d..2c978ec43d07 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
-# Generated by makepkg 5.2.2
-# Fri Jan 15 13:57:40 UTC 2021
+# Generated by makepkg 6.0.1
+# Mon Mar 14 18:05:04 UTC 2022
pkgbase = vdr-ddci2
pkgdesc = Support for stand alone CI by Digital Devices for VDR 2.1.6 and higher.
pkgver = 1.0.5
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/jasmin-j/vdr-plugin-ddci2
arch = x86_64
arch = i686
@@ -13,12 +13,11 @@ pkgbase = vdr-ddci2
license = GPL2
makedepends = git
depends = gcc-libs
- depends = vdr-api=2.4.6
+ depends = vdr-api=2.6.1
backup = etc/vdr/conf.avail/50-ddci2.conf
- source = git+https://github.com/jasmin-j/vdr-plugin-ddci2.git#commit=a5a7ab1cb6be3ebddb8af77cc18313d75404ed81
+ source = vdr-ddci2-1.0.5.tar.gz::https://github.com/jasmin-j/vdr-plugin-ddci2/archive/refs/tags/1.0.5.tar.gz
source = 50-ddci2.conf
- md5sums = SKIP
- md5sums = 5dc8a287efe1419aaf1162cb6a6f28f3
+ sha256sums = 6ec748ee235ec70cb41e0529832c53cfbfa5b53b83f71285e87d2d61edcd14bb
+ sha256sums = 8537997f76d6ccb3ee45ac288134a32e596d422082a4bff70ccd6cc3eb7e64f5
pkgname = vdr-ddci2
-
diff --git a/PKGBUILD b/PKGBUILD
index 76509145f73a..59cf1797cde5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,8 @@
# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
pkgname=vdr-ddci2
pkgver=1.0.5
-_gitver=a5a7ab1cb6be3ebddb8af77cc18313d75404ed81
-_vdrapi=2.4.6
-pkgrel=4
+_vdrapi=2.6.1
+pkgrel=5
pkgdesc="Support for stand alone CI by Digital Devices for VDR 2.1.6 and higher."
url="https://github.com/jasmin-j/vdr-plugin-ddci2"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
@@ -13,34 +12,19 @@ license=('GPL2')
depends=('gcc-libs' "vdr-api=${_vdrapi}")
makedepends=('git')
_plugname=${pkgname//vdr-/}
-source=("git+https://github.com/jasmin-j/vdr-plugin-ddci2.git#commit=$_gitver"
+source=("$pkgname-$pkgver.tar.gz::https://github.com/jasmin-j/vdr-plugin-ddci2/archive/refs/tags/$pkgver.tar.gz"
"50-$_plugname.conf")
backup=("etc/vdr/conf.avail/50-$_plugname.conf")
-md5sums=('SKIP'
- '5dc8a287efe1419aaf1162cb6a6f28f3')
-
-pkgver() {
- cd "${srcdir}/vdr-plugin-$_plugname"
- _last_release=1.0.5
- _last_release_commit=a5a7ab1cb6be3ebddb8af77cc18313d75404ed81
-
- _count=$((`git rev-list --count HEAD` - `git rev-list --count $_last_release_commit`))
- if [ $_count -gt 0 ]; then
- printf "%s.r%s.g%s" $_last_release \
- $_count \
- `git rev-parse --short HEAD`
- else
- printf "%s" $_last_release
- fi
-}
+sha256sums=('6ec748ee235ec70cb41e0529832c53cfbfa5b53b83f71285e87d2d61edcd14bb'
+ '8537997f76d6ccb3ee45ac288134a32e596d422082a4bff70ccd6cc3eb7e64f5')
build() {
- cd "${srcdir}/vdr-plugin-$_plugname"
+ cd "${srcdir}/vdr-plugin-$_plugname-$pkgver"
make
}
package() {
- cd "${srcdir}/vdr-plugin-$_plugname"
+ cd "${srcdir}/vdr-plugin-$_plugname-$pkgver"
make DESTDIR="${pkgdir}" install
mkdir -p "$pkgdir/etc/vdr/conf.avail"