summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Reimer2015-06-08 11:07:37 +0200
committerChristopher Reimer2015-06-08 11:07:37 +0200
commita391342bd7b489e4805167d2bfd59ef9caee0065 (patch)
tree5eaa5aed6f5c13115d1b374bbed3e0be218f4a06
downloadaur-a391342bd7b489e4805167d2bfd59ef9caee0065.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/3bf8a4492e3b973a559fd2c53855b231e25c7e74)
-rw-r--r--.SRCINFO22
-rw-r--r--50-ddci2.conf3
-rw-r--r--PKGBUILD39
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3eda897d30ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = vdr-ddci2
+ pkgdesc = Support for stand alone CI by Digital Devices for VDR 2.1.6 and higher.
+ pkgver = 0.0.13
+ pkgrel = 6
+ url = https://github.com/jasmin-j/vdr-plugin-ddci2
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = GPL2
+ makedepends = git
+ depends = gcc-libs
+ depends = vdr-api=2.2.0
+ backup = etc/vdr/conf.avail/50-ddci2.conf
+ source = git+https://github.com/jasmin-j/vdr-plugin-ddci2.git#commit=381a83d8c7a2d975f0c60bf21105f1f85a1003be
+ source = 50-ddci2.conf
+ md5sums = SKIP
+ md5sums = 5dc8a287efe1419aaf1162cb6a6f28f3
+
+pkgname = vdr-ddci2
+
diff --git a/50-ddci2.conf b/50-ddci2.conf
new file mode 100644
index 000000000000..3a340409b2ef
--- /dev/null
+++ b/50-ddci2.conf
@@ -0,0 +1,3 @@
+[ddci2]
+#--loglevel
+# 0/1/2/3 log nothing/error/info/debug
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6f127793f46
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
+pkgname=vdr-ddci2
+pkgver=0.0.13
+_gitver=381a83d8c7a2d975f0c60bf21105f1f85a1003be
+_vdrapi=2.2.0
+pkgrel=6
+pkgdesc="Support for stand alone CI by Digital Devices for VDR 2.1.6 and higher."
+url="https://github.com/jasmin-j/vdr-plugin-ddci2"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('GPL2')
+depends=('gcc-libs' "vdr-api=${_vdrapi}")
+makedepends=('git')
+_plugname=$(echo $pkgname | sed 's/vdr-//g')
+source=("git+https://github.com/jasmin-j/vdr-plugin-ddci2.git#commit=$_gitver"
+ "50-$_plugname.conf")
+backup=("etc/vdr/conf.avail/50-$_plugname.conf")
+md5sums=('SKIP'
+ '5dc8a287efe1419aaf1162cb6a6f28f3')
+
+pkgver() {
+ cd "${srcdir}/vdr-plugin-$_plugname"
+ git tag -a v0.0.13 -m 'Added Tag' 381a83d8c7a2d975f0c60bf21105f1f85a1003be 2> /dev/null
+ git describe --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g;s/^v//'
+}
+
+build() {
+ cd "${srcdir}/vdr-plugin-$_plugname"
+ make
+}
+
+package() {
+ cd "${srcdir}/vdr-plugin-$_plugname"
+ make DESTDIR="${pkgdir}" install
+
+ mkdir -p "$pkgdir/etc/vdr/conf.avail"
+ install -Dm644 "$srcdir/50-$_plugname.conf" "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+}