summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Reimer2018-12-25 16:23:33 +0100
committerManuel Reimer2018-12-25 16:23:33 +0100
commit1b60f6f28414ea4ae38267d15db34eabeafd72f2 (patch)
tree369f452298ff83857092213a23ce274d4fcf7d27
parent388a21f1e49d44c9a50bbd0f1981fc9e9d70440e (diff)
downloadaur-1b60f6f28414ea4ae38267d15db34eabeafd72f2.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/2f2b722cc9615f43a543dc79430a94db6c369e68)
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
2 files changed, 20 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26e63df3d3eb..0d1c11e3e57b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
-# Generated by makepkg 5.0.2
-# Fri Sep 8 20:46:18 UTC 2017
+# Generated by makepkg 5.1.1
+# Tue Dec 25 15:23:31 UTC 2018
pkgbase = vdr-dvbapi
pkgdesc = A bridge between VDR and OScam.
- pkgver = 2.2.4
- pkgrel = 2
+ pkgver = 2.2.4_4_g7d51cc4
+ pkgrel = 1
epoch = 1
url = https://github.com/manio/vdr-plugin-dvbapi
arch = x86_64
@@ -16,10 +16,10 @@ pkgbase = vdr-dvbapi
depends = gcc-libs
depends = libdvbcsa
depends = openssl
- depends = vdr-api=2.2.0
+ depends = vdr-api=2.4.0
backup = etc/vdr/conf.avail/50-dvbapi.conf
- source = https://github.com/manio/vdr-plugin-dvbapi/archive/v2.2.4.tar.gz
- sha256sums = 0014cd9fbf40d10f630c4aa9b2e60c9dca44d4cdab27529da3e47be9a9c01e13
+ source = git+https://github.com/manio/vdr-plugin-dvbapi.git#commit=7d51cc457823156d446d06c6ae40f850958fa735
+ sha256sums = SKIP
pkgname = vdr-dvbapi
diff --git a/PKGBUILD b/PKGBUILD
index ac237564d84f..32aeac80ecec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,11 @@
# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
pkgname=vdr-dvbapi
-pkgver=2.2.4
+pkgver=2.2.4_4_g7d51cc4
epoch=1
-_vdrapi=2.2.0
-pkgrel=2
+_gitver=7d51cc457823156d446d06c6ae40f850958fa735
+_vdrapi=2.4.0
+pkgrel=1
pkgdesc="A bridge between VDR and OScam."
url="https://github.com/manio/vdr-plugin-dvbapi"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
@@ -13,18 +14,23 @@ license=('GPL2')
depends=('gcc-libs' 'libdvbcsa' 'openssl' "vdr-api=${_vdrapi}")
makedepends=('git')
_plugname=${pkgname//vdr-/}
-source=("https://github.com/manio/vdr-plugin-dvbapi/archive/v$pkgver.tar.gz")
+source=("git+${url}.git#commit=${_gitver}")
backup=("etc/vdr/conf.avail/50-$_plugname.conf")
-sha256sums=('0014cd9fbf40d10f630c4aa9b2e60c9dca44d4cdab27529da3e47be9a9c01e13')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/vdr-plugin-${_plugname}"
+ git describe --tags | sed 's/-/_/g;s/v//'
+}
build() {
- cd "${srcdir}/vdr-plugin-${_plugname}-${pkgver}"
+ cd "${srcdir}/vdr-plugin-${_plugname}"
sed -i 's/ -fdiagnostics-color=auto//g' Makefile
make LIBDVBCSA=1
}
package() {
- cd "${srcdir}/vdr-plugin-${_plugname}-${pkgver}"
+ cd "${srcdir}/vdr-plugin-${_plugname}"
make LIBDVBCSA=1 DESTDIR="$pkgdir" install
mkdir -p "$pkgdir/etc/vdr/conf.avail"