summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Reimer2021-04-05 11:50:50 +0200
committerManuel Reimer2021-04-05 11:50:50 +0200
commit857e11dadb23c34fa51ca01c44c7f2d5af0489bd (patch)
tree5b54d08d50cb82703e8515b2fe8fc64948a4c1c7
parent4696d3a4642069f6548d8ffabd490f6e8eeac64e (diff)
downloadaur-857e11dadb23c34fa51ca01c44c7f2d5af0489bd.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/534221b9e0815f339267f8a8df1cd8c0bca37e3f)
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
-rw-r--r--vdr-eepg-fix_sscanf.patch13
3 files changed, 13 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fccf1e7a7ada..7d16ced9be3c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,21 @@
# Generated by makepkg 5.2.2
-# Wed Dec 23 12:08:56 UTC 2020
+# Mon Apr 5 09:50:48 UTC 2021
pkgbase = vdr-eepg
pkgdesc = Extended EPG (EEPG) plugin for VDR
- pkgver = 0.0.5_242_g32b4e66
- pkgrel = 2
- url = http://projects.vdr-developer.org/projects/plg-eepg
+ pkgver = 0.0.6
+ pkgrel = 1
+ url = https://github.com/vdr-projects/vdr-plugin-eepg
arch = x86_64
arch = i686
arch = arm
arch = armv6h
arch = armv7h
license = GPL2
- makedepends = git
depends = gcc-libs
depends = vdr-api=2.4.6
backup = etc/vdr/conf.avail/50-eepg.conf
- source = git+https://projects.vdr-developer.org/git/vdr-plugin-eepg.git#commit=32b4e669bf8bc6e3336073616c121f10b8518fe8
- source = vdr-eepg-fix_sscanf.patch
- sha256sums = SKIP
- sha256sums = bb6213bbe4941b92ec2e6d9852d72d9a3186d99e9a0e65ee082f9cc971c10e51
+ source = vdr-eepg-0.0.6.tar.gz::https://github.com/vdr-projects/vdr-plugin-eepg/archive/refs/tags/0.0.6.tar.gz
+ sha256sums = c603c2c5683c002ad0f0e79c0e91247283b49dfc73211a4923df2ff209a0e771
pkgname = vdr-eepg
diff --git a/PKGBUILD b/PKGBUILD
index a8f64870176c..564ccd69f856 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,41 +2,26 @@
# Maintainer: George Kranis https://github.com/gkranis/vdr4arch
pkgname=vdr-eepg
-pkgver=0.0.5_242_g32b4e66
-_gitver=32b4e669bf8bc6e3336073616c121f10b8518fe8
+pkgver=0.0.6
_vdrapi=2.4.6
-pkgrel=2
+pkgrel=1
pkgdesc="Extended EPG (EEPG) plugin for VDR"
-url="http://projects.vdr-developer.org/projects/plg-eepg"
+url="https://github.com/vdr-projects/vdr-plugin-eepg"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
license=('GPL2')
depends=('gcc-libs' "vdr-api=${_vdrapi}")
-makedepends=('git')
_plugname=${pkgname//vdr-/}
-source=("git+https://projects.vdr-developer.org/git/vdr-plugin-eepg.git#commit=$_gitver"
- "$pkgname-fix_sscanf.patch")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/vdr-projects/vdr-plugin-eepg/archive/refs/tags/$pkgver.tar.gz")
backup=("etc/vdr/conf.avail/50-$_plugname.conf")
-sha256sums=('SKIP'
- 'bb6213bbe4941b92ec2e6d9852d72d9a3186d99e9a0e65ee082f9cc971c10e51')
-
-pkgver() {
- cd "${srcdir}/vdr-plugin-${_plugname}"
- git describe --tags | sed 's/-/_/g;s/eepg_//g'
-}
-
-prepare() {
- cd "${srcdir}/vdr-plugin-${_plugname}"
-
- patch -p1 -i "$srcdir/$pkgname-fix_sscanf.patch"
-}
+sha256sums=('c603c2c5683c002ad0f0e79c0e91247283b49dfc73211a4923df2ff209a0e771')
build() {
- cd "${srcdir}/vdr-plugin-${_plugname}"
+ cd "${srcdir}/vdr-plugin-${_plugname}-$pkgver"
make
}
package() {
- cd "${srcdir}/vdr-plugin-${_plugname}"
+ cd "${srcdir}/vdr-plugin-${_plugname}-$pkgver"
make DESTDIR="${pkgdir}" install
mkdir -p "$pkgdir/etc/vdr/conf.avail"
diff --git a/vdr-eepg-fix_sscanf.patch b/vdr-eepg-fix_sscanf.patch
deleted file mode 100644
index 77b185286e82..000000000000
--- a/vdr-eepg-fix_sscanf.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: vdr-plugin-eepg-0.0.5+git20190704-242-32b4e66/eepg.c
-===================================================================
---- vdr-plugin-eepg-0.0.5+git20190704-242-32b4e66.orig/eepg.c 2019-07-04 11:58:14.000000000 +0200
-+++ vdr-plugin-eepg-0.0.5+git20190704-242-32b4e66/eepg.c 2020-05-03 18:13:34.913090779 +0200
-@@ -391,7 +391,7 @@
-
- while (fgets (buf, sizeof (buf), fp) != NULL) {
- from = binary = to = NULL;
-- int elems = sscanf (buf, "%a[^:]:%a[^:]:%a[^:]:", &from, &binary, &to);
-+ int elems = sscanf (buf, "%m[^:]:%m[^:]:%m[^:]:", &from, &binary, &to);
- if (elems == 3) {
- int bin_len = strlen (binary);
- int from_char = resolve_char (from);