summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Reimer2019-11-23 10:28:27 +0100
committerManuel Reimer2019-11-23 10:28:27 +0100
commit4b918503a247f2030e23fbe655405fd786d6499e (patch)
treeee9977f9f5ae89f8fa8638d99d0cab2761d3c1e8
parentd3d0334091a4fbad67715cd635a17a7cb47290ba (diff)
downloadaur-4b918503a247f2030e23fbe655405fd786d6499e.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/a77b569e1e822d6dcaa4740e401296c46eb9c38c)
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD13
-rw-r--r--vdr-epg2vdr-python3.8-compat.patch127
3 files changed, 142 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca8ef35dab9c..fdc90611ff83 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
-# Generated by makepkg 5.1.3
-# Tue Jun 18 20:42:51 UTC 2019
+# Generated by makepkg 5.2.1
+# Sat Nov 23 09:28:26 UTC 2019
pkgbase = vdr-epg2vdr
pkgdesc = Used to retrieve EPG data into the VDR
- pkgver = 1.1.98
- pkgrel = 3
+ pkgver = 1.1.101
+ pkgrel = 1
url = http://projects.vdr-developer.org/projects/plg-epg2vdr
arch = x86_64
arch = i686
@@ -19,10 +19,10 @@ pkgbase = vdr-epg2vdr
depends = vdr-api=2.4.1
backup = etc/vdr/conf.avail/50-epg2vdr.conf
backup = var/lib/vdr/plugins/epg2vdr/epg.dat
- source = https://projects.vdr-developer.org/git/vdr-plugin-epg2vdr.git/snapshot/vdr-plugin-epg2vdr-1.1.98.tar.bz2
- source = https://projects.vdr-developer.org/attachments/download/2142/vdr-epg2vdr-mariadb-fix-build.patch
- md5sums = 1f46818f9ab311ffd9475a68f4aba881
- md5sums = 22c0229df1663027f54db93ddc655be4
+ source = https://projects.vdr-developer.org/git/vdr-plugin-epg2vdr.git/snapshot/vdr-plugin-epg2vdr-1.1.101.tar.bz2
+ source = vdr-epg2vdr-python3.8-compat.patch
+ sha256sums = 9f756baa0e9c20571885d8f729c4b13dbb961bd99103f8df2a941ba15b656a41
+ sha256sums = bcf1a51393a7e612a11cf5eee3d7f439913d3b0faceab49786b771556804cb42
pkgname = vdr-epg2vdr
diff --git a/PKGBUILD b/PKGBUILD
index c5d0d095057f..822bcde6850b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
pkgname=vdr-epg2vdr
-pkgver=1.1.98
+pkgver=1.1.101
_vdrapi=2.4.1
-pkgrel=3
+pkgrel=1
pkgdesc="Used to retrieve EPG data into the VDR"
url="http://projects.vdr-developer.org/projects/plg-epg2vdr"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
@@ -12,15 +12,16 @@ license=('GPL2')
depends=('jansson' 'libmariadbclient' 'libutil-linux' 'python' 'tinyxml2' "vdr-api=${_vdrapi}")
_plugname=${pkgname//vdr-/}
source=("https://projects.vdr-developer.org/git/vdr-plugin-epg2vdr.git/snapshot/vdr-plugin-$_plugname-$pkgver.tar.bz2"
- 'https://projects.vdr-developer.org/attachments/download/2142/vdr-epg2vdr-mariadb-fix-build.patch')
+ "$pkgname-python3.8-compat.patch"
+)
backup=("etc/vdr/conf.avail/50-$_plugname.conf"
'var/lib/vdr/plugins/epg2vdr/epg.dat')
-md5sums=('1f46818f9ab311ffd9475a68f4aba881'
- '22c0229df1663027f54db93ddc655be4')
+sha256sums=('9f756baa0e9c20571885d8f729c4b13dbb961bd99103f8df2a941ba15b656a41'
+ 'bcf1a51393a7e612a11cf5eee3d7f439913d3b0faceab49786b771556804cb42')
prepare() {
cd "${srcdir}/vdr-plugin-${_plugname}-${pkgver}"
- patch -p1 -i ${srcdir}/vdr-epg2vdr-mariadb-fix-build.patch
+ patch -p1 -i ${srcdir}/$pkgname-python3.8-compat.patch
}
build() {
diff --git a/vdr-epg2vdr-python3.8-compat.patch b/vdr-epg2vdr-python3.8-compat.patch
new file mode 100644
index 000000000000..405b16407155
--- /dev/null
+++ b/vdr-epg2vdr-python3.8-compat.patch
@@ -0,0 +1,127 @@
+Author: seahawk1986
+https://www.vdr-portal.de/forum/index.php?thread/133185-vdr4arch-epg2vdr-scraper2vdr/&postID=1320317#post1320317
+
+diff --git a/Make.config b/Make.config
+index 85024f4..2d2296d 100644
+--- a/Make.config
++++ b/Make.config
+@@ -19,6 +19,9 @@ PREFIX = /usr/local
+ DEBUG = 1
+ #USE_CLANG = 1
+
++# set python interpreter
++PYTHON = python
++
+ # -----------------------
+ # don't touch below ;)
+
+@@ -35,6 +38,17 @@ doLib = ar -rs
+ USEPYTHON = 1
+ USEEPGS = 1
+
++ifdef USEPYTHON
++ ifeq ($(shell $(PYTHON) -c 'import sys; sys.exit(0) if sys.version_info[:2] < (3,8) else print(1)'), 1)
++ PYTHON_LIBS = $(shell $(PYTHON)-config --libs --embed)
++ else
++ PYTHON_LIBS = $(shell $(PYTHON)-config --libs)
++ endif
++ LIBS += $(PYTHON_LIBS)
++ BASELIBS += $(PYTHON_LIBS)
++ CXXFLAGS += $(shell $(PYTHON)-config --includes)
++endif
++
+ USES = -DVDR_PLUGIN -DUSEUUID -DUSEMD5 -DUSEJSON -DUSEGUNZIP -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
+
+ ifdef DEBUG
+diff --git a/Makefile b/Makefile
+index 1403938..f112dfe 100644
+--- a/Makefile
++++ b/Makefile
+@@ -66,11 +66,16 @@ OBJS = $(PLUGIN).o \
+ status.o ttools.o svdrpclient.o \
+ menu.o menusched.o menutimers.o menudone.o menusearchtimer.o
+
+-LIBS = $(HLIB)
++LIBS += $(HLIB)
+ LIBS += -lrt -larchive -lcrypto
+ LIBS += $(shell pkg-config --libs uuid)
+ LIBS += $(shell pkg-config --libs tinyxml2)
+-LIBS += $(shell mysql_config --libs_r) $(shell python-config --libs) $(shell pkg-config --libs jansson)
++LIBS += $(shell mysql_config --libs_r)
++ifdef USEPYTHON
++ CFLAGS += $(shell python-config --includes)
++ LIBS += $(PYTHON_LIBS)
++endif
++LIBS += $(shell pkg-config --libs jansson)
+
+ EPG2VDR_DATA_DIR = "/var/cache/vdr"
+
+diff --git a/lib/Makefile b/lib/Makefile
+index 07c3e36..a752842 100644
+--- a/lib/Makefile
++++ b/lib/Makefile
+@@ -25,7 +25,7 @@ endif
+ CFLAGS += $(shell pkg-config --cflags uuid)
+ CFLAGS += $(shell pkg-config --cflags zlib)
+
+-BASELIBS = -lrt
++BASELIBS += -lrt
+ BASELIBS += $(shell mysql_config --libs_r)
+ BASELIBS += $(shell pkg-config --libs uuid)
+ BASELIBS += $(shell pkg-config --libs zlib)
+@@ -36,11 +36,11 @@ ifdef USECURL
+ endif
+
+ ifdef USEEPGS
+- LIBOBJS += searchtimer.o
++ LIBOBJS += searchtimer.o
+ endif
+
+ ifdef USEPYTHON
+- BASELIBS += $(shell python-config --libs)
++ BASELIBS += $(PYTHON_LIBS)
+ LIBOBJS += python.o
+ endif
+
+@@ -50,16 +50,12 @@ endif
+
+ ifdef SYSD_NOTIFY
+ BASELIBS += $(shell pkg-config --libs libsystemd-daemon)
+- CFLAGS += $(shell pkg-config --cflags libsystemd-daemon)
++ CFLAGS += $(shell pkg-config --cflags libsystemd-daemon)
+ endif
+
+ CFLAGS += $(shell mysql_config --include)
+ DEFINES += $(USES)
+
+-ifdef USEPYTHON
+- CFLAGS += $(shell python-config --includes)
+-endif
+-
+ all: lib $(TEST) $(DEMO)
+ lib: $(LIBTARGET).a
+
+diff --git a/lib/db.c b/lib/db.c
+index 2554cd8..84f4267 100644
+--- a/lib/db.c
++++ b/lib/db.c
+@@ -1379,11 +1379,19 @@ int cDbConnection::errorSql(cDbConnection* connection, const char* prefix,
+
+ if (error == CR_SERVER_LOST ||
+ error == CR_SERVER_GONE_ERROR ||
++// for compatibility with newer versions of MariaDB library
++#ifdef CR_INVALID_CONN_HANDLE
+ error == CR_INVALID_CONN_HANDLE ||
++#endif
+ error == CR_COMMANDS_OUT_OF_SYNC ||
+ error == CR_SERVER_LOST_EXTENDED ||
+ error == CR_STMT_CLOSED ||
++// for compatibility with newer versions of MariaDB library
++#ifdef CR_CONN_UNKNOW_PROTOCOL
+ error == CR_CONN_UNKNOW_PROTOCOL ||
++#else
++ error == CR_CONN_UNKNOWN_PROTOCOL ||
++#endif
+ error == CR_UNSUPPORTED_PARAM_TYPE ||
+ error == CR_NO_PREPARE_STMT ||
+ error == CR_SERVER_HANDSHAKE_ERR ||