summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Reimer2019-08-16 20:10:02 +0200
committerManuel Reimer2019-08-16 20:10:02 +0200
commit666e95f1c2cc07b6aebb72d815dd01d95a2b4e80 (patch)
tree57dd35a8b8345efbed60132448f9473277e2d251
parent51acea50a32722e3ef647632d5f0a34181d130fc (diff)
downloadaur-666e95f1c2cc07b6aebb72d815dd01d95a2b4e80.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/729bc26670cb07f6cac02433fce5b68186d3eac0)
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--vdr-filebrowser-new-makefile.patch189
3 files changed, 197 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbf494fe9222..08a0be5c77f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by makepkg 5.1.3
-# Tue Jun 18 20:44:00 UTC 2019
+# Fri Aug 16 18:10:01 UTC 2019
pkgbase = vdr-filebrowser
pkgdesc = filebrowser with custom commands for vdr
pkgver = 0.2.1
- pkgrel = 19
+ pkgrel = 20
url = http://opensource.holgerbrunn.net/vdr/filebrowser/
arch = x86_64
arch = i686
@@ -21,9 +21,9 @@ pkgbase = vdr-filebrowser
backup = var/lib/vdr/plugins/filebrowser/sources.conf
backup = etc/vdr/conf.avail/50-filebrowser.conf
source = http://opensource.holgerbrunn.net/vdr/filebrowser/vdr-filebrowser-0.2.1.tgz
- source = filebrowser-makefile-1.7.36.tar.gz::https://www.vdr-portal.de/index.php?attachment/32857
+ source = vdr-filebrowser-new-makefile.patch
md5sums = a1813fec39604b62c38c3ab44fe4aa5f
- md5sums = d6bd0a727bb17e01a029391ec93e3630
+ md5sums = d4a9a9442645c1168b0ed58021958c73
pkgname = vdr-filebrowser
diff --git a/PKGBUILD b/PKGBUILD
index 68556de6070e..9e58a92cab9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=vdr-filebrowser
pkgver=0.2.1
_vdrapi=2.4.1
-pkgrel=19
+pkgrel=20
pkgdesc="filebrowser with custom commands for vdr"
url="http://opensource.holgerbrunn.net/vdr/filebrowser/"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
@@ -14,18 +14,18 @@ _plugname=${pkgname//vdr-/}
replaces=("vdr-plugin-$_plugname")
conflicts=("vdr-plugin-$_plugname")
source=("http://opensource.holgerbrunn.net/vdr/filebrowser/$pkgname-$pkgver.tgz"
- "filebrowser-makefile-1.7.36.tar.gz::https://www.vdr-portal.de/index.php?attachment/32857")
+ "$pkgname-new-makefile.patch")
backup=("var/lib/vdr/plugins/filebrowser/commands.conf"
"var/lib/vdr/plugins/filebrowser/order.conf"
"var/lib/vdr/plugins/filebrowser/othercommands.conf"
"var/lib/vdr/plugins/filebrowser/sources.conf"
"etc/vdr/conf.avail/50-$_plugname.conf")
md5sums=('a1813fec39604b62c38c3ab44fe4aa5f'
- 'd6bd0a727bb17e01a029391ec93e3630')
+ 'd4a9a9442645c1168b0ed58021958c73')
prepare() {
cd "${srcdir}/${_plugname}-${pkgver}"
- cp "$srcdir/filebrowser-makefile-1.7.36" Makefile
+ patch -p1 -i "$srcdir/$pkgname-new-makefile.patch"
}
build() {
diff --git a/vdr-filebrowser-new-makefile.patch b/vdr-filebrowser-new-makefile.patch
new file mode 100644
index 000000000000..fda98ee5391c
--- /dev/null
+++ b/vdr-filebrowser-new-makefile.patch
@@ -0,0 +1,189 @@
+Author: mamomoz
+https://www.vdr-portal.de/forum/index.php?thread/116781-plugins-mit-altem-makefile-sammlung/&postID=1125762#post1125762
+
+diff -U 8 -pr a/Makefile b/Makefile
+--- a/Makefile 2010-09-15 21:47:00.000000000 +0200
++++ b/Makefile 2013-02-08 18:42:51.000000000 +0100
+@@ -1,122 +1,126 @@
+ #
+ # Makefile for a Video Disk Recorder plugin
+ #
+ # $Id$
+
+ # The official name of this plugin.
+ # This name will be used in the '-P...' option of VDR to load the plugin.
+ # By default the main source file also carries this name.
+-#
++
+ PLUGIN = filebrowser
+
+ ### The version number of this plugin (taken from the main source file):
+
+ VERSION = $(shell grep 'static const char \*VERSION *=' $(PLUGIN).c | awk '{ print $$6 }' | sed -e 's/[";]//g')
+
+-### The C++ compiler and options:
+-
+-CXX ?= g++
+-CXXFLAGS ?= -fPIC -O2 -Wall -Woverloaded-virtual
+-
+ ### The directory environment:
+
+-DVBDIR = ../../../../DVB
+-VDRDIR = ../../..
+-LIBDIR = ../../lib
+-TMPDIR = /tmp
++# Use package data if installed...otherwise assume we're under the VDR source directory:
++PKGCFG = $(if $(VDRDIR),$(shell pkg-config --variable=$(1) $(VDRDIR)/vdr.pc),$(shell pkg-config --variable=$(1) vdr || pkg-config --variable=$(1) ../../../vdr.pc))
++LIBDIR = $(call PKGCFG,libdir)
++LOCDIR = $(call PKGCFG,locdir)
++PLGCFG = $(call PKGCFG,plgcfg)
++#
++TMPDIR ?= /tmp
+
+-### Add Debug macro
++### The compiler options:
+
+-ifdef DEBUG
+- DEFINES += -DDEBUG
+-endif
++export CFLAGS = $(call PKGCFG,cflags)
++export CXXFLAGS = $(call PKGCFG,cxxflags)
+
+-### The the sources that we want to compile the plugin
++### The version number of VDR's plugin API:
+
+-DEFINES+= -DFILEBROWSER_PLUGIN_BUILD
++APIVERSION = $(call PKGCFG,apiversion)
+
+ ### Allow user defined options to overwrite defaults:
+
+--include $(VDRDIR)/Make.config
+-
+-### The version number of VDR (taken from VDR's "config.h"):
+-
+-APIVERSION = $(shell sed -ne '/define APIVERSION/s/^.*"\(.*\)".*$$/\1/p' $(VDRDIR)/config.h)
++-include $(PLGCFG)
+
+ ### The name of the distribution archive:
+
+ ARCHIVE = $(PLUGIN)-$(VERSION)
+ PACKAGE = vdr-$(ARCHIVE)
+
++### The name of the shared object file:
++
++SOFILE = libvdr-$(PLUGIN).so
++
+ ### Includes and Defines (add further entries here):
+
++#INCLUDES +=
+ INCLUDES += -I$(VDRDIR)/include -I$(DVBDIR)/include
+-
+-DEFINES += -D_GNU_SOURCE -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
++DEFINES += -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
++DEFINES += -DFILEBROWSER_PLUGIN_BUILD
+
+ ### The object files (add further files here):
+
+ OBJS = $(PLUGIN).o menu-filebrowser.o commands.o threads.o menu-output.o statebag.o menu-threads.o menu-setup.o tools.o command-sources.o command-other.o commands-plugins.o menu-accesscode.o menu-userinput.o
+
+-### Targets:
++### The main target:
+
+-all: libvdr-$(PLUGIN).so i18n
+-
+-libvdr-$(PLUGIN).so: $(OBJS)
+- $(CXX) $(CXXFLAGS) -shared $(OBJS) -o $@
+- @cp $@ $(LIBDIR)/$@.$(APIVERSION)
+-
+-dist: clean
+- @$(MAKE) clean -C developers/filebrowserdemo > /dev/null
+- @-rm -rf $(TMPDIR)/$(ARCHIVE)
+- @mkdir $(TMPDIR)/$(ARCHIVE)
+- @cp -a * $(TMPDIR)/$(ARCHIVE)
+- @-rm -rf $(TMPDIR)/$(ARCHIVE)/filebrowser.{filelist,kdev*}
+- @-rm -rf $(TMPDIR)/$(ARCHIVE)/{*,*/*,*/*/*}~
+- @-rm -rf $(TMPDIR)/$(ARCHIVE)/Doxyfile
+- @tar --numeric-owner -czf $(PACKAGE).tgz -C $(TMPDIR) $(ARCHIVE)
+- @-rm -rf $(TMPDIR)/$(ARCHIVE)
+- @echo Distribution package created as $(PACKAGE).tgz
+-
+-clean:
+- @-rm -f $(PODIR)/*.mo $(PODIR)/*.pot
+- @-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~
++all: $(SOFILE) i18n
+
+ ### Implicit rules:
+
+ %.o: %.c
+- $(CXX) $(CXXFLAGS) -c $(DEFINES) $(INCLUDES) $<
++ $(CXX) $(CXXFLAGS) -c $(DEFINES) $(INCLUDES) -o $@ $<
+
+-# Dependencies:
++### Dependencies:
+
+ MAKEDEP = $(CXX) -MM -MG
+ DEPFILE = .dependencies
+ $(DEPFILE): Makefile
+- @$(MAKEDEP) $(DEFINES) $(INCLUDES) $(OBJS:%.o=%.c) > $@
++ @$(MAKEDEP) $(CXXFLAGS) $(DEFINES) $(INCLUDES) $(OBJS:%.o=%.c) > $@
+
+ -include $(DEPFILE)
+
+ ### Internationalization (I18N):
+
+ PODIR = po
+-LOCALEDIR = $(VDRDIR)/locale
+ I18Npo = $(wildcard $(PODIR)/*.po)
+-I18Nmsgs = $(addprefix $(LOCALEDIR)/, $(addsuffix /LC_MESSAGES/vdr-$(PLUGIN).mo, $(notdir $(foreach file, $(I18Npo), $(basename $(file))))))
++I18Nmo = $(addsuffix .mo, $(foreach file, $(I18Npo), $(basename $(file))))
++I18Nmsgs = $(addprefix $(DESTDIR)$(LOCDIR)/, $(addsuffix /LC_MESSAGES/vdr-$(PLUGIN).mo, $(notdir $(foreach file, $(I18Npo), $(basename $(file))))))
+ I18Npot = $(PODIR)/$(PLUGIN).pot
+
+ %.mo: %.po
+ msgfmt -c -o $@ $<
+
+ $(I18Npot): $(wildcard *.c)
+- xgettext -C -cTRANSLATORS --no-wrap --no-location -k -ktr -ktrNOOP --msgid-bugs-address='<filebrowser@vdr.nasenbaeren.net>' -o $@ $^
++ xgettext -C -cTRANSLATORS --no-wrap --no-location -k -ktr -ktrNOOP --package-name=vdr-$(PLUGIN) --package-version=$(VERSION) --msgid-bugs-address='<see README>' -o $@ `ls $^`
+
+ %.po: $(I18Npot)
+- msgmerge -U --no-wrap --no-location --backup=none -q $@ $<
++ msgmerge -U --no-wrap --no-location --backup=none -q -N $@ $<
+ @touch $@
+
+-$(I18Nmsgs): $(LOCALEDIR)/%/LC_MESSAGES/vdr-$(PLUGIN).mo: $(PODIR)/%.mo
+- @mkdir -p $(dir $@)
+- cp $< $@
++$(I18Nmsgs): $(DESTDIR)$(LOCDIR)/%/LC_MESSAGES/vdr-$(PLUGIN).mo: $(PODIR)/%.mo
++ install -D -m644 $< $@
+
+ .PHONY: i18n
+-i18n: $(I18Nmsgs)
++i18n: $(I18Nmo) $(I18Npot)
++
++install-i18n: $(I18Nmsgs)
++
++### Targets:
++
++$(SOFILE): $(OBJS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared $(OBJS) -o $@
++
++install-lib: $(SOFILE)
++ install -D $^ $(DESTDIR)$(LIBDIR)/$^.$(APIVERSION)
++
++install: install-lib install-i18n
++
++dist: $(I18Npo) clean
++ @-rm -rf $(TMPDIR)/$(ARCHIVE)
++ @mkdir $(TMPDIR)/$(ARCHIVE)
++ @cp -a * $(TMPDIR)/$(ARCHIVE)
++ @tar czf $(PACKAGE).tgz -C $(TMPDIR) $(ARCHIVE)
++ @-rm -rf $(TMPDIR)/$(ARCHIVE)
++ @echo Distribution package created as $(PACKAGE).tgz
++
++clean:
++ @-rm -f $(PODIR)/*.mo $(PODIR)/*.pot
++ @-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~
++
++
++