summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Reimer2015-06-08 11:09:22 +0200
committerChristopher Reimer2015-06-08 11:09:22 +0200
commitc9c9a6fdd2d93ebe2d99b8946779bd124696e294 (patch)
tree6a40c2fba5ec0065d89b7c0af9bd51d77b9a61fd
downloadaur-c9c9a6fdd2d93ebe2d99b8946779bd124696e294.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/3bf8a4492e3b973a559fd2c53855b231e25c7e74)
-rw-r--r--.SRCINFO24
-rw-r--r--50-fritzbox.conf6
-rw-r--r--PKGBUILD30
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..04725edb51f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = vdr-fritzbox
+ pkgdesc = Connects to the Fritz!Box to inform you about incoming and outgoing calls
+ pkgver = 1.5.3
+ pkgrel = 14
+ url = http://www.joachim-wilke.de/vdr-fritz.htm
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = GPL2
+ makedepends = boost
+ depends = boost-libs>=1.57.0
+ depends = commoncpp2
+ depends = libgcrypt
+ depends = vdr-api=2.2.0
+ backup = etc/vdr/conf.avail/50-fritzbox.conf
+ source = https://github.com/jowi24/vdr-fritz/releases/download/1.5.3/vdr-fritzbox-1.5.3.tgz
+ source = 50-fritzbox.conf
+ md5sums = 14a81f5c5fd0f871e9294964c1bf21fc
+ md5sums = a46d5cab7444a60d0ca9657d0785a8a0
+
+pkgname = vdr-fritzbox
+
diff --git a/50-fritzbox.conf b/50-fritzbox.conf
new file mode 100644
index 000000000000..8be82e36fdb5
--- /dev/null
+++ b/50-fritzbox.conf
@@ -0,0 +1,6 @@
+[fritzbox]
+#--log-personal-info
+# log personal information (e.g. passwords, phone numbers, ...)
+
+#--on-call=cmd
+# call cmd on incoming or outgoing call events (see README) \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5739856101da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
+pkgname=vdr-fritzbox
+pkgver=1.5.3
+_vdrapi=2.2.0
+pkgrel=14
+pkgdesc="Connects to the Fritz!Box to inform you about incoming and outgoing calls"
+url="http://www.joachim-wilke.de/vdr-fritz.htm"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('GPL2')
+depends=('boost-libs>=1.57.0' 'commoncpp2' 'libgcrypt' "vdr-api=${_vdrapi}")
+makedepends=('boost')
+_plugname=$(echo $pkgname | sed 's/vdr-//g')
+source=("https://github.com/jowi24/vdr-fritz/releases/download/$pkgver/$pkgname-$pkgver.tgz"
+ "50-$_plugname.conf")
+backup=("etc/vdr/conf.avail/50-$_plugname.conf")
+md5sums=('14a81f5c5fd0f871e9294964c1bf21fc'
+ 'a46d5cab7444a60d0ca9657d0785a8a0')
+
+build() {
+ cd "${srcdir}/${_plugname}-${pkgver}"
+ make
+}
+package() {
+ cd "${srcdir}/${_plugname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 "$srcdir/50-$_plugname.conf" "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+}