summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Reimer2015-06-08 11:00:33 +0200
committerChristopher Reimer2015-06-08 11:00:33 +0200
commit112ace04d45f07e255aa7b027cac2a19c5f892fc (patch)
treecc2a7a2c29a452f5b6597e53351afe8b87fe13a2
downloadaur-112ace04d45f07e255aa7b027cac2a19c5f892fc.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/3bf8a4492e3b973a559fd2c53855b231e25c7e74)
-rw-r--r--.SRCINFO29
-rw-r--r--50-imonlcd.conf9
-rw-r--r--92-imonlcd.rules2
-rw-r--r--PKGBUILD45
4 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1751e83e522
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = vdr-imonlcd
+ pkgdesc = shows information about the current state of VDR on iMON LCD
+ pkgver = 1.0.1
+ pkgrel = 19
+ epoch = 1
+ url = http://projects.vdr-developer.org/projects/show/plg-imonlcd
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = GPL3
+ depends = freetype2
+ depends = gcc-libs
+ depends = vdr-api=2.2.0
+ backup = etc/vdr/conf.avail/50-imonlcd.conf
+ source = http://projects.vdr-developer.org/attachments/download/1327/vdr-imonlcd-1.0.1.tgz
+ source = imonlcd-linker_fix.diff::http://projects.vdr-developer.org/git/vdr-plugin-imonlcd.git/patch/?id=fa47d6df0902d3ac1e4f326be4f2e578fd0f5f19
+ source = imonlcd-fix_replay_time.diff::http://projects.vdr-developer.org/git/vdr-plugin-imonlcd.git/patch/?id=4f8c014e73e9ba11172d6070d8a123f9da20361f
+ source = 92-imonlcd.rules
+ source = 50-imonlcd.conf
+ md5sums = a7f2d49355758d2ccc33ea21dbadc3de
+ md5sums = 260e88452dda6327d532ee61d5c3c45e
+ md5sums = bf67023030f3d5547441e41a709bc7e0
+ md5sums = 4f012281b8a7025e99067e9945aabda0
+ md5sums = bdd88de7c03a24e7a42573b40ed7da32
+
+pkgname = vdr-imonlcd
+
diff --git a/50-imonlcd.conf b/50-imonlcd.conf
new file mode 100644
index 000000000000..7e3f87cbbe78
--- /dev/null
+++ b/50-imonlcd.conf
@@ -0,0 +1,9 @@
+[imonlcd]
+--device=/dev/imon_0038
+#--device=/dev/imon_ffdc
+# sets the lcd-device to other device than /dev/lcd0
+
+#--protocol=MODE
+# sets the protocol of lcd-device
+# '0038' For LCD with ID 15c2:0038 SoundGraph Inc (default)
+# 'ffdc' For LCD with ID 15c2:ffdc SoundGraph Inc \ No newline at end of file
diff --git a/92-imonlcd.rules b/92-imonlcd.rules
new file mode 100644
index 000000000000..be8cc7b70410
--- /dev/null
+++ b/92-imonlcd.rules
@@ -0,0 +1,2 @@
+ACTION=="add", KERNEL=="lcd*", SUBSYSTEMS=="usb", ATTRS{idVendor}=="15c2", ATTRS{idProduct}=="0038", MODE="0660", GROUP="vdr", SYMLINK+="imon_0038"
+ACTION=="add", KERNEL=="lcd*", SUBSYSTEMS=="usb", ATTRS{idVendor}=="15c2", ATTRS{idProduct}=="ffdc", MODE="0660", GROUP="vdr", SYMLINK+="imon_ffdc"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6431e091c12b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
+pkgname=vdr-imonlcd
+pkgver=1.0.1
+epoch=1
+_vdrapi=2.2.0
+pkgrel=19
+pkgdesc="shows information about the current state of VDR on iMON LCD"
+url="http://projects.vdr-developer.org/projects/show/plg-imonlcd"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('GPL3')
+depends=('freetype2' 'gcc-libs' "vdr-api=$_vdrapi")
+optdepends=()
+_plugname=$(echo $pkgname | sed 's/vdr-//g')
+source=("http://projects.vdr-developer.org/attachments/download/1327/$pkgname-$pkgver.tgz"
+ 'imonlcd-linker_fix.diff::http://projects.vdr-developer.org/git/vdr-plugin-imonlcd.git/patch/?id=fa47d6df0902d3ac1e4f326be4f2e578fd0f5f19'
+ 'imonlcd-fix_replay_time.diff::http://projects.vdr-developer.org/git/vdr-plugin-imonlcd.git/patch/?id=4f8c014e73e9ba11172d6070d8a123f9da20361f'
+ '92-imonlcd.rules'
+ "50-$_plugname.conf")
+backup=("etc/vdr/conf.avail/50-$_plugname.conf")
+md5sums=('a7f2d49355758d2ccc33ea21dbadc3de'
+ '260e88452dda6327d532ee61d5c3c45e'
+ 'bf67023030f3d5547441e41a709bc7e0'
+ '4f012281b8a7025e99067e9945aabda0'
+ 'bdd88de7c03a24e7a42573b40ed7da32')
+
+prepare() {
+ cd "$srcdir/$_plugname-$pkgver"
+ patch -p1 -i "$srcdir/imonlcd-linker_fix.diff"
+ patch -p1 -i "$srcdir/imonlcd-fix_replay_time.diff"
+}
+
+build() {
+ cd "$srcdir/$_plugname-$pkgver"
+ make
+}
+package() {
+ cd "$srcdir/$_plugname-$pkgver"
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 "$srcdir/92-imonlcd.rules" "$pkgdir/usr/lib/udev/rules.d/92-imonlcd.rules"
+
+ install -Dm644 "$srcdir/50-$_plugname.conf" "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+}