summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Reimer2018-12-25 16:26:39 +0100
committerManuel Reimer2018-12-25 16:26:39 +0100
commitb669efef7e4984d63d634b4b25d567b96194d96b (patch)
tree540c71c8d25e253f0cd7e8624d439a6eb4e5ef3f
parent77d7e4fa311925745012547355943da23e309ba5 (diff)
downloadaur-b669efef7e4984d63d634b4b25d567b96194d96b.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/b84ed174feb04b0cc206c36c702d349da295a468)
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
-rw-r--r--imonlcd-freetype-2.9.1-fix.diff15
3 files changed, 35 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f313ed54e72d..446d7254dd30 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
-# Generated by makepkg 5.0.2
-# Fri Sep 8 20:46:36 UTC 2017
+# Generated by makepkg 5.1.1
+# Tue Dec 25 15:26:37 UTC 2018
pkgbase = vdr-imonlcd
pkgdesc = shows information about the current state of VDR on iMON LCD
pkgver = 1.0.2
- pkgrel = 1
+ pkgrel = 3
epoch = 1
url = http://projects.vdr-developer.org/projects/show/plg-imonlcd
arch = x86_64
@@ -14,12 +14,16 @@ pkgbase = vdr-imonlcd
license = GPL3
depends = freetype2
depends = gcc-libs
- depends = vdr-api=2.2.0
+ depends = vdr-api=2.4.0
backup = etc/vdr/conf.avail/50-imonlcd.conf
source = http://projects.vdr-developer.org/attachments/download/2086/vdr-imonlcd-1.0.2.tgz
+ source = Fix-release_every-lock-schedules.diff::https://projects.vdr-developer.org/git/vdr-plugin-imonlcd.git/patch/?id=6a03b80df7f18ebb06f160fbe1d2ef3061c4b97a
+ source = imonlcd-freetype-2.9.1-fix.diff
source = 92-imonlcd.rules
source = 50-imonlcd.conf
md5sums = e3155d98e5a0c461dd66b7b89e1880ec
+ md5sums = 0d73b1bb117f51d881a13f39ac31f1e6
+ md5sums = 689cbd832a2a9c829aaf6149d757b1b5
md5sums = 4f012281b8a7025e99067e9945aabda0
md5sums = bdd88de7c03a24e7a42573b40ed7da32
diff --git a/PKGBUILD b/PKGBUILD
index 9eb2b7cac3fc..4cea2db40b0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
pkgname=vdr-imonlcd
pkgver=1.0.2
epoch=1
-_vdrapi=2.2.0
-pkgrel=1
+_vdrapi=2.4.0
+pkgrel=3
pkgdesc="shows information about the current state of VDR on iMON LCD"
url="http://projects.vdr-developer.org/projects/show/plg-imonlcd"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
@@ -14,13 +14,23 @@ depends=('freetype2' 'gcc-libs' "vdr-api=$_vdrapi")
optdepends=()
_plugname=${pkgname//vdr-/}
source=("http://projects.vdr-developer.org/attachments/download/2086/$pkgname-$pkgver.tgz"
+ "Fix-release_every-lock-schedules.diff::https://projects.vdr-developer.org/git/vdr-plugin-imonlcd.git/patch/?id=6a03b80df7f18ebb06f160fbe1d2ef3061c4b97a"
+ "imonlcd-freetype-2.9.1-fix.diff"
'92-imonlcd.rules'
"50-$_plugname.conf")
backup=("etc/vdr/conf.avail/50-$_plugname.conf")
md5sums=('e3155d98e5a0c461dd66b7b89e1880ec'
+ '0d73b1bb117f51d881a13f39ac31f1e6'
+ '689cbd832a2a9c829aaf6149d757b1b5'
'4f012281b8a7025e99067e9945aabda0'
'bdd88de7c03a24e7a42573b40ed7da32')
+prepare() {
+ cd "$srcdir/$_plugname-$pkgver"
+ patch -p1 -i "${srcdir}/Fix-release_every-lock-schedules.diff"
+ patch -p1 -i "${srcdir}/imonlcd-freetype-2.9.1-fix.diff"
+}
+
build() {
cd "$srcdir/$_plugname-$pkgver"
make
diff --git a/imonlcd-freetype-2.9.1-fix.diff b/imonlcd-freetype-2.9.1-fix.diff
new file mode 100644
index 000000000000..959b29027f13
--- /dev/null
+++ b/imonlcd-freetype-2.9.1-fix.diff
@@ -0,0 +1,15 @@
+diff --git a/Makefile b/Makefile
+index fc165e9..d53fe82 100644
+--- a/Makefile
++++ b/Makefile
+@@ -55,8 +55,8 @@ SOFILE = libvdr-$(PLUGIN).so
+
+ ### Includes and Defines (add further entries here):
+
+-INCLUDES += $(shell freetype-config --cflags)
+-LIBS += $(shell freetype-config --libs)
++INCLUDES += $(shell pkg-config freetype2 --cflags)
++LIBS += $(shell pkg-config freetype2 --libs)
+
+ DEFINES += -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
+