summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Reimer2019-08-16 20:10:09 +0200
committerManuel Reimer2019-08-16 20:10:09 +0200
commitb0b54721d2637f82a236098f0eee41a5e74a8f07 (patch)
tree2670c3584c70d2755e783eb5ba4a1239555a0b5f
parent6f466d85310b5d8670726b24a9093c4a106fa213 (diff)
downloadaur-b0b54721d2637f82a236098f0eee41a5e74a8f07.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/b4f55fbadcc10711355818a5676e51c51127cf93)
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
-rw-r--r--vdr-lcdproc-vdr-2.3.2.patch41
3 files changed, 50 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 826a86b4635b..9a9a0c2fe443 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by makepkg 5.1.3
-# Tue Jun 18 20:45:17 UTC 2019
+# Fri Aug 16 18:10:09 UTC 2019
pkgbase = vdr-lcdproc
pkgdesc = Output to LCD modules that are supported by LCDproc
pkgver = 0.0.10_jw9_9_g0c54897
@@ -16,12 +16,12 @@ pkgbase = vdr-lcdproc
depends = vdr-api=2.4.1
optdepends = lcdproc: to use local displays
backup = etc/vdr/conf.avail/50-lcdproc.conf
- source = git://projects.vdr-developer.org/vdr-plugin-lcdproc.git#commit=0c548975b2d66d860180c79d58235a8923641a0c
- source = vdr-2.3.2-lcdproc_v2.diff::https://www.vdr-portal.de/index.php?attachment/40536
+ source = git+https://projects.vdr-developer.org/git/vdr-plugin-lcdproc.git#commit=0c548975b2d66d860180c79d58235a8923641a0c
+ source = vdr-lcdproc-vdr-2.3.2.patch
source = 50-lcdproc.conf
source = 92-lcdproc.rules
md5sums = SKIP
- md5sums = 047746f6f729704ec93da66736480c6e
+ md5sums = ea362bce385ace4e11828702ed5bf509
md5sums = 0221e0b8878d56e3a057ac37a9c853cf
md5sums = 67d1e0de8e90e0d4e9e977ddfd952442
diff --git a/PKGBUILD b/PKGBUILD
index b8a33189e03d..c9c28c9bc316 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,21 +14,21 @@ depends=('gcc-libs' "vdr-api=${_vdrapi}")
makedepends=('git')
optdepends=('lcdproc: to use local displays')
_plugname=${pkgname//vdr-/}
-source=("git://projects.vdr-developer.org/vdr-plugin-lcdproc.git#commit=$_gitver"
- "vdr-2.3.2-lcdproc_v2.diff::https://www.vdr-portal.de/index.php?attachment/40536"
+source=("git+https://projects.vdr-developer.org/git/vdr-plugin-lcdproc.git#commit=$_gitver"
+ "$pkgname-vdr-2.3.2.patch"
"50-$_plugname.conf"
'92-lcdproc.rules')
backup=("etc/vdr/conf.avail/50-$_plugname.conf")
md5sums=('SKIP'
- '047746f6f729704ec93da66736480c6e'
+ 'ea362bce385ace4e11828702ed5bf509'
'0221e0b8878d56e3a057ac37a9c853cf'
'67d1e0de8e90e0d4e9e977ddfd952442')
prepare() {
cd "${srcdir}/vdr-plugin-$_plugname"
- patch -p1 -i "$srcdir/vdr-2.3.2-lcdproc_v2.diff"
+ patch -p1 -i "$srcdir/$pkgname-vdr-2.3.2.patch"
}
-
+
pkgver() {
cd "${srcdir}/vdr-plugin-$_plugname"
git describe --tags | sed 's/-/_/g;s/v.//'
diff --git a/vdr-lcdproc-vdr-2.3.2.patch b/vdr-lcdproc-vdr-2.3.2.patch
new file mode 100644
index 000000000000..55a6bc3b5df2
--- /dev/null
+++ b/vdr-lcdproc-vdr-2.3.2.patch
@@ -0,0 +1,41 @@
+Author: fnu
+https://www.vdr-portal.de/forum/index.php?thread/130045-produktive-problem-und-pluginl%C3%B6sungen-f%C3%BCr-vdr-2-3-2-und-h%C3%B6her/&postID=1284634#post1284634
+
+Index: b/lcd.c
+===================================================================
+--- a/lcd.c
++++ b/lcd.c
+@@ -850,12 +850,22 @@
+ }
+
+ if ( time(NULL) > nextLcdUpdate ) {
++#if APIVERSNUM < 20301
+ cChannel *channel = Channels.GetByNumber(primaryDvbApi->CurrentChannel());
++#else
++ LOCK_CHANNELS_READ;
++ const cChannel *channel = Channels->GetByNumber(primaryDvbApi->CurrentChannel());
++#endif
+ const cEvent *Present = NULL;
++#if APIVERSNUM < 20301
+ cSchedulesLock schedulesLock;
+ const cSchedules *Schedules = cSchedules::Schedules(schedulesLock);
+ if (Schedules) {
+ const cSchedule *Schedule = Schedules->GetSchedule(channel->GetChannelID());
++#else
++ LOCK_SCHEDULES_READ;
++ const cSchedule *Schedule = Schedules->GetSchedule(channel->GetChannelID());
++#endif
+ if (Schedule) {
+ const char *PresentTitle, *PresentSubtitle;
+ PresentTitle = NULL; PresentSubtitle = NULL;
+@@ -873,7 +883,10 @@
+ rtcycle = 10; // RT
+ lcrCycle = 10; // LCR
+ }
++#if APIVERSNUM < 20301
+ }
++#endif
++
+ if ( nextLcdUpdate <= time(NULL) )
+ nextLcdUpdate=(time(NULL)/60)*60+60;
+ }