summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Reimer2018-12-25 16:27:12 +0100
committerManuel Reimer2018-12-25 16:27:12 +0100
commit4e4f3ecb4caed1b4174bd3b637cc85169b834549 (patch)
tree02415f99c61d15fefba5ffc4ada296a0de5cf655
parent333c81b0221fc4427810f0988d7cb959e6070beb (diff)
downloadaur-4e4f3ecb4caed1b4174bd3b637cc85169b834549.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/a852296bcb25f5296b7b266dc4bd246ed8de1198)
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 9 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c9e506d9c7f..b248307e9e1d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
-# Generated by makepkg 5.0.2
-# Fri Sep 8 20:47:55 UTC 2017
+# Generated by makepkg 5.1.1
+# Tue Dec 25 15:27:11 UTC 2018
pkgbase = vdr-live
pkgdesc = Adds the possibility to control VDR and some of it's plugins by a web interface.
- pkgver = 0.3.0_22_g869ac69
+ pkgver = 2.3.1
pkgrel = 2
epoch = 1
url = http://projects.vdr-developer.org/projects/plg-live
@@ -16,19 +16,13 @@ pkgbase = vdr-live
makedepends = git
depends = pcre
depends = tntnet
- depends = vdr-api=2.2.0
+ depends = vdr-api=2.4.0
optdepends = vdr-epgsearch: Manage searchtimers
optdepends = vdr-streamdev: Stream live TV
backup = etc/vdr/conf.avail/50-live.conf
- source = git://projects.vdr-developer.org/vdr-plugin-live.git#commit=869ac69c7b78c89c76cd59ba8a2438ad5bb99d89
- source = live-folderstatecookie-v2.diff::https://www.vdr-portal.de/index.php?attachment/34407
- source = live-osd-patch_150221.diff::https://www.vdr-portal.de/index.php?attachment/37780
- source = live-gcc6-fixes.diff::https://www.vdr-portal.de/index.php?attachment/40135
+ source = git://projects.vdr-developer.org/vdr-plugin-live.git#commit=e582514ede475574842b44ca6792335ff141172d
source = 50-live.conf
md5sums = SKIP
- md5sums = 6abb3d1724057e765e98e1a9b5326fe3
- md5sums = c045e5e6ec376eebee834e6dc178327c
- md5sums = 21a39d584d4e4639d010b2489e640123
md5sums = 563961eb90d9f2b3d2a0a34472ef51ee
pkgname = vdr-live
diff --git a/PKGBUILD b/PKGBUILD
index 5b6d378fabc4..4bf52f5d6b37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
pkgname=vdr-live
-pkgver=0.3.0_22_g869ac69
+pkgver=2.3.1
epoch=1
-_gitver=869ac69c7b78c89c76cd59ba8a2438ad5bb99d89
-_vdrapi=2.2.0
+_gitver=e582514ede475574842b44ca6792335ff141172d
+_vdrapi=2.4.0
pkgrel=2
pkgdesc="Adds the possibility to control VDR and some of it's plugins by a web interface."
url="http://projects.vdr-developer.org/projects/plg-live"
@@ -18,36 +18,16 @@ makedepends=('git')
install="$pkgname.install"
_plugname=${pkgname//vdr-/}
source=("git://projects.vdr-developer.org/vdr-plugin-live.git#commit=$_gitver"
- 'live-folderstatecookie-v2.diff::https://www.vdr-portal.de/index.php?attachment/34407'
- 'live-osd-patch_150221.diff::https://www.vdr-portal.de/index.php?attachment/37780'
- 'live-gcc6-fixes.diff::https://www.vdr-portal.de/index.php?attachment/40135'
"50-$_plugname.conf")
backup=("etc/vdr/conf.avail/50-$_plugname.conf")
md5sums=('SKIP'
- '6abb3d1724057e765e98e1a9b5326fe3'
- 'c045e5e6ec376eebee834e6dc178327c'
- '21a39d584d4e4639d010b2489e640123'
'563961eb90d9f2b3d2a0a34472ef51ee')
+
pkgver() {
cd "${srcdir}/vdr-plugin-${_plugname}"
git describe --tags | sed -e 's/release_//g' -e 's/-/\./' -e 's/-/\./' -e 's/-/_/g'
}
-prepare() {
- cd "${srcdir}/vdr-plugin-${_plugname}"
-
- # Remove some files. Otherwise patch complains with a dirty src dir
- rm -f osd_status.{cpp,h}
- rm -f pages/osd.ecpp
-
- patch -p1 -i "$srcdir/live-folderstatecookie-v2.diff"
- patch -p1 -i "$srcdir/live-osd-patch_150221.diff"
- patch -p1 -i "$srcdir/live-gcc6-fixes.diff"
-
- # Use the more modern ResourceDirectory in /usr/share instead of /var/lib
- sed -i 's/cPlugin::ConfigDirectory/cPlugin::ResourceDirectory/g' live.cpp
-}
-
build() {
cd "${srcdir}/vdr-plugin-${_plugname}"
make